Release Notes

Skyline

Skyline v19.1 Released on 07/14/2019

This is the 19th official release and the first of 2019. So, for this 10th anniversary realese, we are changing to a year-based version number like many other mature products.

  • New! Small molecule and proteomics UI modes [introduction]
    • And a form that asks for your preferred mode once
  • iRT and Optimization library support for small molecules
  • New! Lists - define lists of values in multiple columns and associate them with elements in your documents through annotations. [documentation]
    • See Document Settings – Lists
  • Batch calibration – [documentation]
  • Import > Peptide Search with an existing library (including EncyclopeDIA .elib files)
  • A new MS/MS filtering Acquisition method named "DDA" which sets all fragment ions to non-quantitative and does not truncate MS1 chromatograms the way "Targeted" (or PRM) does.
  • Edit > Refine became a top-level Refine menu between Edit and View and got reorganized for ease-of-use.
  • The Document Grid "Views" menu has been changed to "Reports" to better align with File > Export > Report and Document Settings - Reports
  • Added Actions menu to the Document Grid to enable bulk peak removal based on filtering
  • New command-line help for SkylineRunner/SkylineCmd available with --help argument and Help > Documentation > Command Line in Skyline
  • Command-line support for Refine > Advanced options
  • Command-line support for setting precursor charge states, fragment charge states and fragment types
  • Moved some explicit parameter values like CE from precursor to transition level
  • Audit log improvements to support working with Panorama and tampering detection
  • Building a library from MaxQuant msms.txt now attempts to find the original spectrum source files and use the spectra in them to avoid using charge state deconvoluted spectra, but allows the user to override this default if the spectrum source files cannot be found
  • A new <Edit current...> choice in the dropdown lists in Edit > Modify Peptide to make updating specified modification definitions easier
  • Improved handling of common background proteome building problem where user tries to open or create the FASTA file causing it to be overwritten by an empty PROTDB file
  • Changed File > Share default to "Complete" instead of "Minimal"
  • Add "PeptideResult.ModifiedAreaProportion" which is the normalized area of the PeptideResult, divided by the sum of the other NormalizedAreas for all of the other PeptideResults in the same replicate and protein that have the same unmodified sequenceAdded new Transition.LossFormulas field
  • Allow grouping by built-in properties such as "concentration" in addition to annotations in peak area graph
  • Many smaller bug fixes such as:
    • Fixed to support C-terminal modifications in MaxQuant msms.txt
    • Fixed library building for PeptideShaker results
    • Fixed to add the .wiff2 extension to File > Import > Results form
    • Fixed to support File > Export > Method for Thermo Altis
    • Fixed to allow package installation for R external tools (like MSstats) in China
    • Fixed for calibration curve text exported to report CSV files on Chinese and Japanese systems
    • Fixed library building from paths with extended characters
    • Fixed for spectral library building of Peaks mzIdentML/MGF export
    • Fixed library building support for ProXL cross-linked peptides with PTMs
    • Added support for radioactive 14C labeling as C"
    • Added support for deuterium as D and H' and tritium as T and H"
    • All elements in the periodic table now allowed in chemical formulae
    • Fixed for q value cut-off advanced option in group comparison definition form
    • Fixed to apply chromatogram transformation to non-quantitative chromatograms to match quantitative chromatograms
    • Fixed for invalid precursor transitions after changing Full-Scan settings
    • Performance improvement for importing large small molecule transition lists
    • Fixed to Support new variant of retention time specification in NIST .msp library format
    • Fixed audit log saving to use write and rename to avoid log truncation
    • Fixed audit log enabling to create undo records and be more persistent
    • Fixed to handling of invalid adduct specification
    • Fixed to small molecule persistence with multiple keys
    • Fixed undo/redo of setting standard type
    • Fixed problem where modifications with negative mass cannot be found in iRT database (reported by Anatoly, thanks to Nick)
    • Updated UIMFLibrary DLLs to version 3.6.6
    • Fixed library build support for reading MaxQuant fixed peptide-N/C-terminal modifications
    • Fixed parsing of pS/pT/pY variant of phospho mods from MaxQuant
    • Fixed issue parsing PLGS final_fragment.csv modifications with paren’s in the mod name
    • Fixed problem with implicit modifications not being included in "Modified Sequence" column in Document Grid
    • Fixed importing report layouts from a .skyr file
    • Fixed reading Shimadzu QTOF files that also open with the QQQ reader DLL
    • Change SCIEX centroiding to multiply Y (area) values by 100 to make the numbers more similar to profile extraction (requested by SCIEX)
    • Fixed Area CV histograms to ignore precursors with no chromatograms rather than Calculating... forever
    • Fixed to continue importing chromatograms when iRT regression fails as long as chromatogram extraction is not dependent on it

Skyline v4.2 Updated on 04/08/2019

Skyline v4.2 Updated on 01/08/2019
Skyline v4.2 Released on 11/01/2018

  • AUDIT LOGGING - yes, really [documentation]
  • New Figures of Merit section in Peptide Settings – Quantification tab
    • New LOD and LOQ fields in reports
    • New display in Calibration Curve plot
  • New calibration features
    • Regression fit = Linear in Log Space
    • Single-replicate calibration with isotope labeled standards for system suitability
    • Added Sample Dilution Factor field to Replicates in Document Grid for dilution of a sample to bring it within the linear dynamic range
  • Support for importing OpenSWATH results through File > Import > Peptide Search - DIA wizard [details]
  • Support for using integration boundaries and peak scores from OpenSWATH and EncyclopeDIA
  • Drift time predictor training from Use Results fixed for small molecules
  • Instrument support improvements:
    • Agilint - support for negative ion mode QqQ data
    • Bruker - timsTOF support for PASEF, All Ions, and PRM
    • SCIEX - support for new SCIEX WIFF2 file format & clearer method export, CE and DP settings
    • Shimadzu - support for 9030 Q-TOF and 8045 QqQ
    • Thermo - support for Thermo FAIMS, GC-MS, Tune v3+ compatibility, and faster raw file reader DLL
    • Waters - advances in SONAR and CCS calibration and importing data from UNIFI server
  • Settings > Integrate All no longer affects Precursors.TotalArea nor other quantitative metrics. At last, it is just visual.
  • File > Import or Export > Annotations for importing or exporting annotations values directly from or to a CSV file
  • New command-line support
    • --import-document = File > Import > Document
    • --import-annotations = File > Import > Annotations
    • --share-zip = File > Share
    • --import-all-files = File > Import > Results of all files in the directory specified, but not subdirectories
    • --import-all[-files] and --import-replicate-name together to import multiple files into a new replicate
    • --reintegrate-exclude-feature = unchecking feature in mProphet model
  • New library build support
    • Mascot error tolerant searches and PASEF searches
    • MassIVE mzTab
    • MetaMorpheus mzIdentML
    • Crux Percolator pepXML
    • PEAKS pepXML/mzXML export when scans are out of order
    • Proteome Discoverer ExpectationValue support and pdResult files with multiple workflows
    • MaxQuant deuterium labeling modifications and results lacking Labeling State column
  • Added new iRT standard mix RTBEADS
  • Added ability to separate CVs in Peak Areas > CV Histogram by precursor or fragment ions in mixed MS1 and MS/MS documents
  • Added Plot Type > Residuals to Retention Times > Alignment view
  • Faster volcano pot updates and format filtering peptides by protein attributes
  • Mouse centered zooming added to some graphs that did not yet have it
  • Edit > Delete of transitions removes matching transitions in matching reference precursors
  • Edit > Refine > Advanced new option to remove peptides without a matching spectrum
  • Added find support for report link columns with text display
  • Increased maximum fragment charge state to 20 for whole protein MS/MS
  • Increased custom molecule maximum mass from 100 KDa to 160 KDa
  • Added a new copy button in the lower-left corner of message boxes to make it clearer that form contents can be copied as text
  • Many smaller bug fixes such as:
    • Fixed problem reading Thermo raw files that have scans with multiple precursors.
    • Fixed "use results" on "Edit Drift Time Predictor" form to pay attention to whether "Use high energy offset" is checked. If it's not checked, then always use 0 for the high energy offset.
    • Fixed problem where matching chromatograms to transitions does not pay attention to m/z match tolerance and double counts transitions.
    • Fixed ion mobility lookup in spectral libraries to support high precision modifications.
    • Fixed bug where documents containing the adduct "[2M+H]" cannot be opened.
    • Fixed "Remove Peak" behavior when chromatograms showing more than one file.
    • Fixed performance and background updates for Retention Times - Regression view
    • Fixed to editing small molecules with MS1 precursors that resulted in document corruption
    • Fixed to allow unchecking "Intensity" in an mProphet scoring model
    • Fixed to improve performance in a document with 500 replicates
    • Fixed to improve graphs restoring their visible state in the absence of a .view file
    • Fixed performance for large iRT libraries
    • Fixed a bug where libraries were disregarding modifications when returning retention times
    • Fixed matching spectra in SCIEX Midas data to precursors with modifications, especially heavy labeled
    • Fixed problem where a mixed polarity .raw file can result in an error about the number of times not being equal
    • Fixed obscure Thermo scanfilter parsing issue with a negative SID
    • Fixed case where ModifiedSequence would display the wrong mass if there were two modifications on the same amino acid
    • Fixed unexpected error trying to use Centroided extraction from Waters data acquired in centroid mode
    • Fixed small molecule PrecursorIonFormula vs. PrecursorNeutralFormula in small molecules with isotope labeling
    • Fixed issue with neutral loss transitions not matching spectral libraries during a settings change
    • Fixed to keep fragment ion transitions from matching chromatograms extracted from MS1
    • Fixed error message for file access denied from "Win32 Error 5" to something more helpful
    • Fixed issue with importing transition lists containing O" or 17O
    • Fixed for Waters data import to allow both centroiding and lockmass correction
    • Fixed small molecule transition list reader when Transition Settings precursor and fragment mass types are different
    • Fixed small molecule transition list import where the product columns are left empty to imp[y that the precursor is the ion of interest for this row
    • Fixed excessive memory use building a background proteome
    • Fixed issue with chromatogram extraction from mixed polarity raw data files
    • Fixed protein annotation using Uniprot to keep up with changes in their interface
    • Fixed command-line to import all samples from a multi-sample WIFF file

Skyline v4.1 Release Updated on 6/19/2018

Skyline v4.1 Release Updated on 2/18/2018
Skyline v4.1 Released on 1/11/2018

  • Improved small molecule support [detail slides]
    • Support for NIST and self-built (from SSL format) small molecule spectral libraries with fragment annotation
    • Neutral molecules with multiple precursor adducts
    • Improved support for pasting small molecule transition lists with column headers
  • Bruker TIMS support that parallels IMS support for other vendors
  • A new Document Grid pivot editor and saved report layouts [detail slides]
  • Improved Import Peptide Search wizard for DIA with DDA for the mProphet workflow
  • File > Import > Assay Library makes importing Assay Library files easier than File > Import > Transition List
  • More performance improvements (memory use and speed) for large-scale DIA data processing
  • Interactive volcano plots for group comparisons with custom formatting [detail slides]
  • Interactive peak area CV histogram plots [detail slides]
  • High precision modification delta-mass support past a single decimal place
  • Points across the peak and manual integration adjustment visualizations in chromatogram plots [detail slide]
  • New line plot modes for summary (Replicate and Peptide Comparison) plots
  • Synchronized zooming available in summary (Replicate and Peptide Comparison) plots
  • New Import Results common prefix and suffix removal UI with real-time replicate name display
  • New delete button (red X) on the Document Grid
    • allows deletion from the Targets View (proteins, peptides, precursors and transitions)
    • filter and delete.
  • Possible to rename replicates from Document Grid (including copy-paste) with "Replicate Name" field
  • New "Exclude From Calibration" column on PeptideResult
  • New Quantitative column on Transitions [detail slides]
  • New non-blocking background population of Document Grid with full support for chromatogram values (times, intensities, mass errors) in Live Reports, both interpolated and raw values
  • New Edit > Integration menu with shortcuts for Remove Peak and Apply Peak to All
  • Display an informative warning when iRT calibration fails during import
  • Improvements for library building from peptide search formats which do not support probability cutoffs to make sure they get ordered correctly
  • Many other fixes...

Skyline v3.7 Release Updated on 9/10/2017

Skyline v3.7 Released on 6/12/2017

New features include:

  • Extensive performance improvements in speed and memory use for proteomewide, label-free DIA and DDA data processing
    • If you have the hardware, Skyline should be able to use up to 100% CPU and 100% of your memory. Though we continue working on making it do more with less.
    • Performance improvements in very large DIA (6,000,000 transitions x 20 files)
    • Convergence detection in mProphet modeling and 10 iteration maximum (down from 30)
    • New --import-process-count=[num] and --import-theads=[num] arguments for SkylineRunner. The former can yield up to 10x import performance improvement on a 24-core NUMA server and 2-4x on a standard i7.
  • Reduced .sky file size by 70% for large (over 1000 transitions) files
  • Multi-peptide peak area graph
  • Customizable color schemes
  • Import isolation scheme feature from DIA data files
  • Improved iRT calibration from DDA data directly into spectral libraries
  • Storing raw chromatograms in SKYD files. This is a big one which also gives us:
    • View > Transform > Interpolated (F12) shows the chromatograms as Skyline used to show them
    • View > Transform > None (Shift+F12) shows the raw uninterpolated chromatogram
    • Skyline can now always show in Full-Scan graph every spectrum from which chromatograms were extracted. Previously interpolation could cause spectra to be skipped
    • A new report value TransitionResults.PointsAcrossPeak
    • File > Share can now create document archives in 3.6 format for sharing to Skyline 3.6
  • File > Export > Spectral library for exporting targeted results as a spectral library for your next experiment
  • Support for semi-cleavage enzymes in Peptide Settings - Digestion tab
  • Support for Associate Proteins checkbox in View > Spectral Libraries with background proteome for nonspecific cleavage
  • Run-to-run retention time correlation graph
  • New file details (score type, score cut-off, unique peptides and spectra) in Spectral Library Explorer source file details form.
  • Support BLIB files with StartTime and EndTime in the RetentionTimes table
    • Allowing external tools to provide their own peak detection and picking
    • Times are used for peak integration boundaries without further peak detection
    • Faster imports and smaller resulting files
  • File > Import > Peak Boundaries 2-10x faster
  • Add Total Ion Current Area under Results.File in reports/Document Grid
  • Add "Equalize Medians" as normalization method in Peptide Settings / Quantification for large exploratory experiments where most targets are not changing
  • Improved paste performance in the Document Grid
  • Column tips and reference help in the Live Report view editor
  • New SkylineDailyCmd.exe in same folder as Skyline-daily.exe with same command-line interface as SkylineRunner.exe, but runs Skyline in a single process, useful for ZIP-file or Administrator installations where these EXEs are placed in easily located paths
  • Proteome Discoverer 2.2 support in spectral library builder
  • Improved support for SCIEX Midas workflow
  • Improved support for Agilent IMS workflow
  • Improved handling of importing modified peptide sequences with SCIEX 3-letter modification abbreviations
  • Export transition list feature for mixed polarity small molecule documents to allow exporting different polarities separately
  • Various other fixes such as:
    • Use of .NET API to encrypt passwords for Panorama and Chorus stored by Skyline in its user.config file.
    • Fix to z ion mass calculation, which was off by one hydrogen atom
    • Fix to View > Mass Errors > Replicates graph to match colors with other replicate graphs when MS1 and MS/MS XICs are present
    • Fix y axis scaling in chromatograms which had problems when IDs or Predicted annotations were present and scale was less than 100
    • Fix tracking of changes to iRT standards to better match changes to documents
    • Fix to avoid removing iRT standards when Edit > Refine > Advanced minimum transition count is higher than they contain
    • Fix to keep from duplicating spectrum source files - especially problematic for iRT training - in spectral libraries when a DDA file is searched twice
    • Slightly more tolerant peak grouping which allows undetected peaks to be added to the group based on chromatogram correlation over the integration boundaries.
    • Fix precursor matching with SRM data in fringe case where the precursor m/z is worse, but transition matching is better
    • Fix error message reporting missing required columns in File > Import > Peak Boundaries
    • Fix to "Unable to sort because the IComparer.Compare() method returns inconsistent results"

Skyline v3.6 Release Updated on 2/21/2017

Skyline v3.6 Released on 11/7/2016

New features include:

  • Improved results import:
    • Parallel multi-file results import (in user and command-line interfaces)
    • New results import interface for improved unattended imports
    • Greatly improved import performance for Skyline documents on network drives
  • Calibrated quantification improvements:
    • Surrogate standards for normalizing to explicit non-homologous molecules
    • Remove point right-click option in calibration curve graph
    • Explicit Global Standard Area added to replicates for explicit global normalization control with values like TIC
  • Group comparison additions and fixes to improve consistency with MSstats
  • New Detection Q Value and Detection Z Score report columns for mProphet scored peak picking
  • New Peak Rank By Level report value and Targets view showing separate peak rankings for MS1 and MS/MS transitions
  • Peptide uniqueness constraint added to Peptide Settings - Digestion tab (by protein, gene or organism)
  • New Edit > Refine > Associate Proteins for adding protein associations for targeted peptides after they have been added to the targets list
  • Ability to choose which modifictions to use when showing a library in the Spectral Library Explorer
  • New and improved plots:
    • Mass error plots (replicate and peptide comparisions and 1D and 2D histograms
    • Multi-peptide retention time plot
    • Point set selection in retention time regression plot
  • Improved small molecule support:
    • Improved support for negative ion mode
    • Improved chromatogram matching for molecules with identical precursor m/z but different scheduled retention times
    • Parsing of chemical formula with adduct syntax in Edit > Insert > Transitions
    • Support for small molecule transition list import with Edit > Paste, File > Import > Transition List, external tools and with command-line
  • Improved Transition Settings for Full-Scan
    • Centroided extraction with mass error tolerance made default, based on improvement seen with Thermo, Sciex and Bruker instruments
    • New high-selectivity extraction option (1/2 extraction width) for extraction from profile spectra, based on improvement seen with Termo and Sciex raw data files
    • Easier import of existing data with improved isolation schemes based on raw data
    • Fixed support for importing from instruments using different high- and low-resolution between MS1 and MS/MS
  • Ability to include ambiguously matched spectra in spectral libraries build by Skyline
  • Improved support for iRT:
    • Support for more iRT standard mixes
    • Automatic adding of iRT standard targets to document
    • More flexible iRT regression support (allowing 80% of standards at 0.995 correlation)
    • CiRT support
  • SkylineRunner command-line interface improvements:
    • Command-line support for importing transition lists and assay libraries
    • Command-line support for exporting isolation lists
    • Command-line support for adding decoy peptides
    • Improvements made to support AutoQC
    • mProphet model generation output to console log
  • Initial support for Sciex MIDAS data
  • Initial support fixes for Waters SONAR data
  • Fix for File > Save As bug that disabled Edit > Refine > Re-import
  • Many other smaller bug fixes

 

Skyline v3.5 Release Updated on 1/24/2016

Skyline v3.5 Released on 12/1/2015

New features include:

  • Calibrated quantification (a.k.a. absolute quantification) [see tip]
  • Impressive performance improvements for large full-scan data sets (DIA and DDA)
  • Many longer operations made much faster and showing progress form allowing cancel
  • Chromatogram extraction from centroided scans using mass accuracy in PPM (Peptide Settings - Full-Scan tab, using Centroided mass analyzer)
  • Improved small molecule support:
    • Support for negative polarity ions
    • Support for multiple ions per precursor, including isotope labeling
  • SkylineRunner command-line improvements supporting processing pipelines from raw data to Panorama uploads
  • Improved assay library and transition list import with better modification guessing
  • Full support for Panorama AutoQC system suitability run processing
  • Support for building spectral libraries from DIA-Umpire search results
  • Ability to include report templates in document with Document Settings
  • Fill Down function available on Document Grid right-click menu
  • Delete-key clears cells in Document Grid
  • Apply to All for faster manual correction of multi-replicate peak picking
  • Compensation voltage optimization for Sciex instruments with SelexION
  • Default Sciex SWATH isolation schemes and abilitly to export Sciex isolation lists
  • Automated drift-time training for Agilent and Waters IMS Q-TOF instruments
  • Lockmass correction for Waters Q-TOF data
  • Export directly to instrument methods for Shimadzu QqQ instruments
  • Many display improvements:
    • Peak area and background shading of selected transition
    • New residuals plot in Retention Times > Regression graph
    • Keep ID annotations from being hidden by chromatograms
    • Improved dotp display in Peak Areas plot
    • Option for strict scientific notation for intensity y-axis on plots
    • Graph text scaling based on right-click > Properties for all graph text

 

Skyline v3.1 Release updated on 4/13/2015

Skyline v3.1 Released on 3/16/2015

New features include:

  • Integrated Group Comparison support (see images below). Get started with:
    • View > Group Comparisons > Add
    • Settings > Document Settings - Group Comparisons tab
    • Tutorial coming soon...
  • Support for custom ions / small molecule targeted MS
    • Use Edit > Insert > Transitions - Small molecules to start a Skyline small molecule document
    • Watch Skyline Tutorial Webinar #4 - Preview of Small Molecule Support
  • Cloud chromatogram extraction from full-scan data with Chorus
  • New wizards for importing peptide searches with PRM and DIA data sets
  • Direct filtering of Document Grid views
  • Support for iRT scores in chromatogram libraries from Panorama
  • Faster start-up and file open and save progress
  • Fully enforced light-heavy ion matching and Find form support for "Mismatched transitions"
  • Improved optimization library support

 

Skyline v2.6 Release updated on 2/8/2015

Skyline v2.6 Release updated on 10/27/2014
Skyline v2.6 Released on 9/22/2014

New features include:

  • Full-Scan spectrum view for chromatograms extracted from full-scan data, with heat-map graph for IMS data
  • New Skyline start page for faster access to common start scenarios and tutorials
  • Ion mobility drift time filtering for Agilent and Waters TOF instruments
  • Optimization library support for storing optimized CE values
  • Custom fragment ion support for defining non-peptide-backbone fragments (like iTRAQ, TMT, etc.)
  • Support for isotope labeling experiments (like SILAC) without standards
  • Support for Shimadzu triple-quadrupole instruments
  • Improved chromatogram peak picking
  • Import of tabular "assay library" format
  • Support for protein details information (accession number, gene name and preferred name) queried from internet sites
  • DIA isolation scheme viewer
  • Option to exclude transitions within the DIA isolation window for the precursor

 

Skyline v2.5 Release updated on 7/10/2014

Skyline v2.5 Release updated on 5/5/2014

With:

  • Chinese and Japanese translations

Skyline v2.5 Released on 2/8/2014

New features include:

  • Live Reports - interact directly with Skyline documents through a grid interface with
    • Customizable column display
    • Sort and filter
    • Direct paste to annotation values
    • Text search
    • Much faster report generation than the original Custom Reports
  • Improved peak scoring and picking
    • Improved default peak picking
    • Integrated mProphet scores and semi-supervised learning model training
    • Edit > Refine > Reintegrate form for applying non-default peak scoring and picking models
    • Peak q value assignment
    • Model training and evaluation interface
  • Global standard type assignment
    • Right-click > Set Standard Type to assign Normalization and QC standard types
    • New icons to display iRT, Normalization and QC standard types in Targets view
    • New ratio values for peptides, precursors and transitions to global standard types in Peak Areas graph and reports
    • All global standard peptides measured in every method of multiple method documents
  • Fully integrated Tool Storeuser interface
    • Tools > Tool Store form for reviewing and installing External Tools without leaving Skyline or manually downloading files
    • Update notifications for new tool releases
    • Tools > Updates form for automatic updates to installed tools
  • Multi-peptide chromatogram graphs - use protein selection or multiple selection (shift- or ctrl-click) to see annotated chromatogram peaks for many peptides at once
  • Improved support for Scheduled Extraction of chromatograms from full-scan mass spectra
  • Improved File > Import > Peptide Search wizard
  • Thermo raw file import support on systems with European number format settings

 

Skyline v2.1 Released on 9/8/2013

New features include:

  • Support for building chromatogram libraries on Panorama and using them in Skyline
  • File > Import > Peptide Search wizard for DDA data quick start
  • Mass accuracy metrics for high resolution full-scan data
  • TIC and base peak chromatograms from MS1 survey scans
  • Installed support for Bruker TOF data, with improved performance
  • Demultiplexing of overlapped DIA/SWATH methods
  • Improved External Tool integration (see the list of available tools)
    • Install from file (Tools > External Tools - click Add button, and choose From File)
    • Automatic R installation
    • Automatic Python installation
    • Support for MSstats with new GUI form [download]
    • Support for QuaSAR with new GUI form [download]
  • Direct pasting into the Results Grid (especially useful for replicate annotations for external tools)
  • Fix to be able to distinguish peptides with the same precursor m/z in MS1 filtered data
  • Improved memory performance for large full-scan imports
  • Enhanced results data import progress interface with peak graph
  • Split chromatogram graphs for simultaneous viewing of light and heavy transitions, and precursor and product ions
  • Alignment by iRT scores in graphs
  • Improved integration with PanoramaWeb
  • Save and restore of Targets View expansion and selection state
  • Several spectral library builder fixes, including support for larger libraries and new search pipelines:
    • PEAKS pepXML/mzXML
    • MSGF+ pepXML/mzXML
  • File > Import > Peak Boundaries for importing peak selection from other tools
  • File > Export > Chromatograms for exporting chromatogram points

 

Skyline v1.4 Release Updated on 3/18/2013

With:

  • Support for building spectral libraries from Proteome Discoverer MSF
  • Support for building spectral libraries from MaxQuant Andromeda msms.txt

Skyline v1.4 Release Updated on 12/17/2012

With:

  • Support for building spectral libraries from PRIDE XML

Skyline v1.4 Released on 11/12/2012

New features include:

  • Bruker TOF support [details]
  • Export triggered MRM (a.k.a. iSRM) transition list support (Agilent and Thermo instruments)
  • Peak picking based on retention time alignment of MS/MS IDs for MS1 filtering
  • Improved retention time alignment features for MS1 filtering
  • Support for publishing Skyline documents to Panorama targeted proteomics repository web sites (server software currently in beta, available early 2013)
  • Support for MS1 filtering from SIM scans
  • Customizable Tools menu (EXE, Batch and Web site) with macro and custom reports as inputs and command-line customization for installers
  • Replicate custom annotations, e.g. Concentration, Case/Control, SubjectId, etc.
    (see the updated Existing and Quantitative Experiments tutorial pp. 30-35)
  • Replicate comparison graphs grouped by replicate annotations
  • Renaming of FASTA sequences (direct edit and Edit > Refine > Rename Proteins)

 

Skyline v1.3 Release Updated on 8/12/2012

Skyline v1.3 Released on 6/20/2012

New features include:

  • Advanced support for data independent acquisition (DIA) across vendors:
    • AB SCIEX SWATH™
    • Agilent DIA
    • Thermo DIA & Multiplexed DIA
    • Waters MSe™
  • Isolation list export for Thermo Q Exactive and Agilent TOF instruments
  • 64-bit version with higher memory limits
  • Retention time alignment for MS1 filtering
  • MS/MS retention times in built libraries for more peptide ID pipelines
  • Auto-refinement for selecting best responding peptides
  • Improved handling for high charge peptides
  • Auto-detection of modifications in the Spectral Library Explorer
  • Decoy peptide and transition generation for FDR based peak picking

 

Skyline v1.2 Release Updated on 3/27/2012

Skyline v1.2 Released on 2/15/2012

New features include:

  • Integrated display of MS/MS peptide ID spectra in MS1 chromatograms
  • Peak picking in MS1 chromatograms based on MS/MS peptide ID retention times
  • New isotope dot-product score on MS1 full-scan filtered peaks, and expected relative isotope abundance in peak area plot and reports
  • More accurate retention time prediction with integrated iRT Calculator support
  • Command-line interface for running Skyline operations in automated scripts on instrument control computers
  • Faster MS/MS library loading
  • Improved memory performance for full-scan chromatogram extraction
  • Improved full-scan method export for Thermo LTQs, including support for Accurate Inclusion Mass Spectrometry (AIMS)
  • Full-scan method export for AB SCIEX Q-TOFs, including support for AIMS
  • Data import support for Thermo Q-Exactive
  • Data import support for Waters Synapt G2-S
  • Spectral library build support for iProphet and Protein Prospector pepXML
  • New enhanced Find with Find All
  • Unexpected error form with button to report the issue
  • Manage results, minimize for reducing chromatogram data size in final documents

 

Skyline v1.1 Release Updated on 8/8/2011

Skyline v1.1 Released on 6/11/2011

New features include:

  • Import results from WIFF files much improved (50-fold faster for large scheduled runs - thanks to AB SCIEX)
  • Full-scan MS/MS ion chromatogram extraction
  • Full-scan MS1 multiple isotope ion chromatogram extraction
  • Full-scan method export for Thermo LTQ
  • Import document with multiple documents and support for merging results
  • Integrated support for Unimod modification definitions
  • Modification auto-detect support for pasted/inserted annotated peptide sequences
  • Native method export for AB SCIEX QTRAP
  • Native method export for Agilent 6400 Series
  • Spectral library build support for Scaffold, Waters MS^e and OMSSA
  • Improved Edit / Find in the Peptide View
  • Larger text sizes in the peptide tree view
  • Multi-select annotation editing
  • Multiple color annotation indicators
  • Improved scheduling for multi-replicate documents
  • Variable modification and neutral loss detection in transition list paste/insert/import
  • Peptide filter expression support for matching modifications
  • New bulk refinement operations
  • Replicate acquired time in reports and replicate plot ordering
  • New summary plots

 

Skyline v0.7 Release Updated on 3/30/2011

Skyline v0.7 Release Updated on 2/7/2011
Skyline v0.7 Release Updated on 10/30/2010
Skyline v0.7 Release Updated on 10/5/2010
Skyline v0.7 Released on 9/15/2010

New features include:

  • Variable modifications
  • Neutral loss product ion transitions
  • Native Waters file import support installed
  • Spectral Library Explorer
  • Multiple heavy label types
  • Multi-select copy-paste (text, HTML formatted, and Skyline document to Skyline document)
  • Peptide view enhancements (multiple selection, peptide modification highlighting, etc.)
  • Spectral libraries built from Protein Pilot results
  • Analysis support for fractionation replicates
  • Synchronized zooming of multiple chromatogram graphs
  • Copy data from graphs to re-plot with your favorite graphing package
  • Data import performance improvements for Agilent, AB Sciex and Thermo
  • Improved international system settings support

 

Skyline v0.6 Release Updated on 7/7/2010

Skyline v0.6 Release Updated on 5/21/2010

Now with native WIFF file import support installed.

Skyline v0.6 Release Updated on 4/21/2010
Skyline v0.6 Release Updated on 4/2/2010
Skyline v0.6 Released on 3/17/2010

New features include:

  • Improved automatic peak integration
  • Collision energy optimization
  • Peak area charts
  • Peptide summary charts
  • Manuscript ready charts
  • Results grid with per replicate annotations
  • Custom annotations
  • Auto-refinement dialog box
  • SpectraST library support
  • Unique peptides view with a Background Proteome
  • Improved support for document sharing
  • Summary result statistics in reports
  • Waters instrument native method export

 

Skyline v0.5 Release Updated on 11/8/2009

Skyline v0.5 Released on 9/24/2009
Skyline v0.5 Preview Updated on 8/14/2009
Skyline v0.5 Preview Updated on 7/7/2009

Skyline v0.5 Preview Released on 5/30/2009

The core focus of v0.5 is analysis of result data, building on the successful method creation features of v0.2. Our ASMS 2009 poster gives a broad overview of how we are using these features to extend the scope of our targeted proteomics research at the MacCoss Lab.

New features include:

  • Scheduled and unscheduled transition list support for instruments from:
    • Agilent
    • Applied Biosystems
    • Thermo Fisher
    • Waters
  • Import of results data for instruments from:
    • Agilent (native)
    • Applied Biosystems (native)
    • Thermo Fisher (native)
    • Waters (native with MassLynx 4.1 installed)
    • All of the above converted to mzML or mzXML
  • Share methods and results across labs with different instruments, using Skyline's high-performance, compact data caching
  • Build your own spectral libraries from Mascot and X! Tandem search results
  • Multiple sample replicates, and multiple replicate import
  • Chromatogram plotting with dynamic layout for multi-replicate viewing
  • Peak detection and advanced peak picking
  • Peak quality indicators
  • Isotope labeling ratios
  • Advanced peak integration editing
  • Dynamic report designer
  • Retention time analysis views:
    • Linear regression
    • Replicate comparison
    • Scheduling

 

Skyline v0.2 Released on 2/17/2009

Skyline is a Windows client application for building Selected Reaction Monitoring (SRM) methods. It aims to employ cutting-edge technologies for creating and iteratively refining SRM methods for large-scale proteomics studies. The latest version of Skyline contains support for:

  • Full featured SRM method editing
  • Transition list export for Thermo Finnigan TSQ and ABI Q-Trap
  • Retention time prediction
  • Isotope labeling
  • Spectral libraries (NIST, GPM, BiblioSpec)
  • Building spectral libraries from your results in TPP pepXML/mzXML

Skyline edits its own universal method format document (saved in XML), and can export transition lists for a variety of instruments. For large, un-refined methods these may be multiple lists per document.


previousnext
 
expand all collapse all