Issue 629: No import due to overlapping chromatogram start times?

issues
Status:open
Assigned To:matt.chambers42@gmail.com
Type:Defect
Area:Skyline
Priority:2
Milestone:4.3
Opened:2019-01-24 by blaine roberts
Changed:2019-03-26 by Brendan MacLean
Resolved:
Resolution:
Duplicates:640
Closed:
2019-01-24 blaine roberts
Title»No import due to overlapping chromatogram start times?
Assigned ToGuest»Brendan MacLean
Notify»blaine roberts
Type»Defect
Area»Skyline
Priority»3
Milestone»4.3
Trying to import ion mobility DIA data with a peptide list generated from an error tolerant peptide search. I suspect the error tolerant peptides are causing the issue. See error text below. I removed the peptides listed below and tired again but another peptide becomes the problem. If I generate the spectral library without the ET results then the import proceeds as normal.




At 12:47 PM:
Failed importing results file 'E:\MassHunter\Data\Blaine\24.01.19.Harvey_gen_Pro\DIA-30ms-IMS-40ug_BrainRef.d'.
Unable to process chromatograms for the molecule 'EGPGEAIVR' because one chromatogram ends at time '14.4538164138794' and the other ends at time '14.4933662414551'.


Inner exceptions:
Exception type: System.InvalidOperationException
Error message: Unable to process chromatograms for the molecule 'EGPGEAIVR' because one chromatogram ends at time '14.4538164138794' and the other ends at time '14.4933662414551'.
Unable to process chromatograms for the molecule 'EGPGEAIVR' because one chromatogram ends at time '14.4538164138794' and the other ends at time '14.4933662414551'.
   at pwiz.Skyline.Model.Results.PeptideChromDataSets.AddDataSet(ChromDataSet chromDataSet) in C:\proj\pwiz_x64\pwiz_tools\Skyline\Model\Results\PeptideChromData.cs:line 838
   at pwiz.Skyline.Model.Results.PeptideChromDataSets.Add(PeptideDocNode nodePep, ChromDataSet chromDataSet) in C:\proj\pwiz_x64\pwiz_tools\Skyline\Model\Results\PeptideChromData.cs:line 794
   at pwiz.Skyline.Model.Results.ChromCacheBuilder.AddChromDataSet(Boolean isProcessedScans, ChromDataSet chromDataSet, PeptidePrecursorMz peptidePrecursorMz, IDictionary`2 dictPeptideChromData, ICollection`1 listChromData, ChromFileInfo fileInfo) in C:\proj\pwiz_x64\pwiz_tools\Skyline\Model\Results\ChromCacheBuilder.cs:line 680
   at pwiz.Skyline.Model.Results.ChromCacheBuilder.CalcPeptideChromDataSets(ChromDataProvider provider, List`1 listMzPrecursors, HashSet`1 setInternalStandards) in C:\proj\pwiz_x64\pwiz_tools\Skyline\Model\Results\ChromCacheBuilder.cs:line 520
   at pwiz.Skyline.Model.Results.ChromCacheBuilder.Read(ChromDataProvider provider) in C:\proj\pwiz_x64\pwiz_tools\Skyline\Model\Results\ChromCacheBuilder.cs:line 393
   at pwiz.Skyline.Model.Results.ChromCacheBuilder.BuildCache() in C:\proj\pwiz_x64\pwiz_tools\Skyline\Model\Results\ChromCacheBuilder.cs:line 263

2019-01-27 Brendan MacLean
Assigned ToBrendan MacLean»Nick Shulman
Nick, can you have a look at this?

2019-02-04 Nick Shulman
This error message can happen if the Skyline document contains two copies of the same peptide, and Skyline has a different predicted retention time for the two peptides. This could happen if the two peptides have different "Explicit Retention Time", or there are also ways this could happen involving the way that decoy peptides map back to the peptide that they came from.
I am not sure what is going wrong in this case, but it sounds like we should make the error message more helpful so that people know how to change their document so that they can extract chromatograms.

2019-03-26 Brendan MacLean
Issue 640 marked as duplicate of this issue.
2019-03-26 Brendan MacLean
Assigned ToNick Shulman»matt.chambers42@gmail.com
Notifyblaine roberts»blaine roberts;Nick Shulman;Brendan MacLean
Priority3»2
Reported twice, would be nice to fix.