Spectronaut assay library import failed

Spectronaut assay library import failed Rita  2022-12-08 04:23


I tried to import a large Spectronaut Mouse library - MouseRefSWATH_iRT.csv by Krasny, L. et al 2020 (https://db.systemsbiology.net/sbeams/cgi/PeptideAtlas/GetDIALibs). Skyline was able to read .csv and check the file for errors but the process ended up with an error message (please see the attachment). I have Skyline running on 64-bit Win10 Pro 128 GB RAM. Would you have any suggestions?


Nick Shulman responded:  2022-12-08 07:12
It appears that the way that Skyline is reading that .csv file does not work for files which are larger than one gigabyte, regardless of how much memory is in your computer.

I am not sure how easy it will be for us to fix this.
In the meantime, it is probably possible to work around the limitation by reducing the size of the CSV file that you are importing, maybe by removing columns that Skyline ignores.

I see that I can download the 1.2GB "MouseRefSWATH_iRT.csv" from the page that you linked to.
I will try to edit that file so that it is smaller and send it to you.
I will also try to fix this limitation in Skyline.
-- Nick
Rita responded:  2022-12-08 07:25
Hi Nick,

It would be much appreciated if you send me this file "small" enough before you fix this limitation for general use.

Nick Shulman responded:  2022-12-08 08:56
It appears that this limitation has been fixed in Skyline-daily.
You can install Skyline-daily using the "Skyline-daily (beta)" button on the Skyline page:
You can have both Skyline and Skyline-daily installed on your computer at the same time.
Documents that you create using Skyline-daily cannot be opened by older versions of Skyline, but you can use the menu item "File > Share" to create something that will be able to be opened by older versions.

Skyline does not hit the "Out of Memory Error" when Skyline is first reading the CSV file. Instead, the problem happens when Skyline is trying to record in the audit log what text was being imported. The exact text that Skyline tries to write to the audit log depends on what columns you have selected in the "Assay Library: Identify Columns" window. The Audit Log is the thing that you see if you go to "View > Other Grids > Audit Log".

We have fixed things in Skyline-daily so that the text that you are importing does not get written to the audit log if you are importing from a file. The text only gets written to the audit log if you are pasting from the Clipboard.

I see that you are running Skyline 21.2. The latest version of Skyline is 22.2. We always recommend that you run the latest released version of Skyline unless you are trying to reproduce results from older experiments.
Skyline 22.2 probably still has the same Out of Memory error that you are seeing with Skyline 21.2, You will need to use Skyline-daily to be sure that you don't run into this error.

I made a slightly smaller version of that file which you can download from here:
I am not sure whether this smaller CSV will actually help you with the bug that you are hitting.

By the way, if you ever need to edit an enormous CSV file like this again, I recommend the program "EmEditor professional":

-- Nick
Rita responded:  2022-12-10 07:45
Hi Nick,

I got that Out Of Memory error using the original file (1.2 GB) in both versions (22.2 - 128 GB RAM workstation, 22.1 - laptop). Both accept the smaller file that you sent to me without an error message, but Skyline stops responding. Only when the ASSOCIATE PROTEINS box remains unticked, the import can be finished. Proteins can be associated later on in Spectral Library Explorer, but for some reason, the library match for associated proteins is not displayed (empty spectra).

I tried to import the original 1.2 GB file into Skyline-daily installed on my colleague's computer and I can confirm that even a file of this size can be processed successfully if proteins are associated in Spectral Library Explorer, once the import has been completed.

Thank you for your help and EmEditor recommendation for future editing.

By the way, I am not able to install Skyline-daily using my account, getting this message: There was an issue with your request please contact the system administrator. I had Skyline-daily running on my previous laptop and now it seems that I am not allowed to install the beta version anywhere.

Nick Shulman responded:  2022-12-10 08:13
In order to install Skyline-daily, you need to go to this page:
and click on the "Agree and Register" button.

When you push that button the website will grant your account additional permissions so that you can install Skyline-daily. If you were able to install Skyline-daily before, I imagine that you might have used a different account to download it from this website.

By the way, another way to get peptides grouped into proteins is using the "Refine > Associate Proteins" menu item. The algorithm used by that menu item is very efficient in terms of simultaneously searching for thousands of peptide sequences inside of thousands of protein sequences. Also, the Associate Proteins dialog gives you options in terms of creating protein groups for peptides that can be found in multiple proteins.
-- Nick
Rita responded:  2022-12-10 08:40
When I follow the link and click on the "Agree and Register" button in Google Chrome or Microsoft Edge, I am asked to contact the system administrator (screenshot attached).

Nick Shulman responded:  2022-12-10 08:57
That definitely looks like a bug. I will ask around and see if someone can figure out why the website is doing that.
In the meantime I will email you directly with a link that you can use to download Skyline-daily.
-- Nick
Brendan MacLean responded:  2022-12-12 14:24
Nick did follow the instruction and contacted me at the email address provided.

I have manually added you to the DailyRequests group, which will give you access to Skyline-daily. We will look into fixing the root problem for any others like you that created their accounts in 2015 and earlier.

Thanks for your long-term interest in Skyline.

Rita responded:  2022-12-13 01:33
Thanks for your help. Everything works now.