Small Molecule Peak Integration

support
Small Molecule Peak Integration tony considine  2022-07-18
 

Hello,

I am using the molecule interface of Skyline in conjunction with the ALIS system to perform RNA/protein screens looking for novel chemical matter. Since I will be screening for novel binders, I need to have a peak integration method that identifies the correct peak. I cannot go through each chromatogram to perform a manual integration as that will not be feasible due to the sizes of the screens. Instead, I have to rely on applying different filters in the exported CVS file to filter out nonspecific binders from specific binders and trust that the initial peaks identified are the correct ones. I have tried to optimize the peak integration method by spiking in known "weak" binders into pooled compound wells of 250-300 compounds per well and seeing if the correct peak is integrated. I am doing this as we don't expect to identify very strong binders in the initial screening process.

However, in some cases, it identifies the wrong peak and a peak with an idotp score much lower than the correct peak with the much higher idotp score. I have tried to look under the "refine" tab and the advanced section and modify the parameters, especially the minimum idotp value. However, changing the minimum idotp value seems in mess up my method and results in the wrong compounds being identified as the peak in the respective chromatograms. I will typically know the chemical formula of all the compounds in the well and would expect an idotp score of 0.80 or greater. I have also tried to set the amount of transitions to 3 (M, M+1, M+2) and would expect to see at least main precursor and the C13 isotope. I also don't see a feature to isolate peaks based on the mass error (typically less than 10ppm) and in general, changing the parameters under the "refine" tab and the advanced section does not seem to have much of an effect. It would be super helpful if people who have experience could point me in the right direction and ways to optimize the peak integration methods so that only peaks with high idotp scores, low mass error, etc etc are identified from the chromatogram.

Thank You,
Tony Considine

 
 
Nick Shulman responded:  2022-07-18
If you install Skyline-Daily, there is a new feature "Candidate Peak Grid" which will help you figure out why Skyline is picking the peak that is peaking.
You can install Skyline-Daily from here:
https://skyline.ms/project/home/software/Skyline/daily/begin.view?

In Skyline-Daily, you can use the menu item:
View > Other Grids > Candidate Peaks
to bring up the candidate peak grid. It will show you the list of peaks that Skyline detected, and how they all scored.

If you send us your Skyline document and some of your raw files, we might be able to give you some more advice about how to improve the peak picking.
In Skyline you can use the menu item:
File > Share
to create a .zip file containing your Skyline document and supporting files including extracted chromatograms.

If that .zip file and/or your raw files are less than 50MB, you can attach them to this support request.
You can upload larger files here:
https://skyline.ms/files.url

-- Nick
 
tony considine responded:  2022-07-19
Hi Nick,

I was not able to download the software, I get the error attached in the Word document. I talked with my IT department and they think that although I can log into your website, I cannot access any shared drives and/or links you send to me.

I am excited to try the software and see if that helps me to change the parameters to ID the correct peak in each chromatogram.

Thanks,
Tony
 
Nick Shulman responded:  2022-07-19
Oops. Try this link instead.
https://skyline.ms/project/home/software/Skyline/daily/register-form/begin.view?

There is also a button to install Skyline-Daily on the main Skyline page:
https://skyline.ms/project/home/software/Skyline/begin.view
-- Nick
 
tony considine responded:  2022-07-19
Hi Nick,

Thanks for sending me the new link, I was able to install the Skyline-Daily. There are 2 questions I have:

1) The peak I want selected is most of the time included as a candidate peak but it is not picking that peak. The correct peak has very low intensity as it is a weak binder to my target. I know that the weaker intensity peak is the correct peak as I spiked it into the matrix to optimize my integration parameters. However, in a screen, I will not have that luxury of knowing what the binders are to my target. Instead, it is picking the peak that occurs right when I switch the diverter valve over from waste to the MS as this peak has a more intense signal compared to the correct peak. 2 ways to overcome this would be to have the software only ID peaks within a specific retention time and limit the "idotp" value to a minimum threshold. Are there ways to do this so that I can increase the chances of identifying a "true" binder to my target when I export the document grid and apply my filters?

2) In some cases, the peak I want selected is not included as a candidate peak. How do I include the peak into the candidate list and start applying the filter described above?

Thank you for all your help. I hope to discuss my use of the software at a conference/seminar someday.

Thank You,
Tony
 
Nick Shulman responded:  2022-07-19
Can you send us your Skyline document?
In Skyline you can use the menu item:
File > Share
to create a .zip file containing your Skyline document and supporting files including extracted chromatograms.

If that .zip file is less than 50MB you can attach it to this support request. You can upload larger files here:
https://skyline.ms/files.url

Can you also send me a screenshot of what you are looking at? A picture of the whole Skyline window usually works great so I can see which molecule you are looking at and in which result file.
-- Nick
 
tony considine responded:  2022-07-19
Hi Nick,

I cannot send a zip file as the file will contain the formulas of compounds in our internal screening deck and my company will not allow that. I can send you an image screenshot.

Hopefully, this will help.

Thanks,
Tony
 
Nick Shulman responded:  2022-07-19
I will send you an email message in case you would prefer not posting your screenshots to this forum.
-- Nick
 
Nick Shulman responded:  2022-07-27

Thank you for showing me your dataset.
You have MS1 chromatograms for some molecules, and Skyline was picking the incorrect peaks a lot of the time.
We tried specifying the Explicit Retention Time and Explicit Retention Time Window values for the molecules, and that helped a little, except that in a lot of cases, Skyline was still picking the incorrect peak.
Those incorrect peaks had worse Isotope Dot Product scores than the correct peaks, but, for some reason, they had better Shape scores.
For this reason, I sent you some XML for a peak scoring model which only paid attention to the isotope dot product, and you were able to paste that peak scoring model into your Skyline document right before the "</peptide_settings>" closing tag.
This was the peak scoring model:

     <peptide_integration>
        <mprophet_peak_scoring_model name="MyPeakScoringModel" bias="0">
          <peak_feature_calculator type="pwiz.Skyline.Model.Results.Scoring.NextGenIsotopeDotProductCalc" weight="1" />
          <peak_feature_calculator type="pwiz.Skyline.Model.Results.Scoring.NextGenPrecursorMassErrorCalc" weight="-0.01" />
        </mprophet_peak_scoring_model>
      </peptide_integration>

This new peak scoring model seems to be doing a better job, except for your molecules which have only two precursor isotopes, Skyline does not calculate the isotope dot product. Skyline will not allow you to give your molecules three isotopes if the predicted abundance of that third isotope is less than 1% as large as the monoisotopic isotope.

We might be able to make things easier for you in a future version of Skyline. I could imagine that we might be able to make it so that Skyline does calculate the Isotope Dot Product even if there are only two isotopes.
It also would be nice if Skyline would give you a user interface to change the weightings of the features in a peak scoring model since there is no way to automatically train a peak scoring model in a small molecule document, since Skyline does not have the concept of "Decoy" small molecules.

I will ask around and see what we can do about improving things in a future version of Skyline. If you post more screenshots of what you are seeing, and what Skyline is doing, someone on this support board may have better ideas about what to do about them.
-- Nick