Spectral Library Building – Option: Filter for document peptides Fails

support
Spectral Library Building – Option: Filter for document peptides Fails peter r mosen  2021-06-02
 

Dear Skyline team,

for a MRM-assay I tried to generate a “reduced/tailored” spectral library covering only the peptides of interest using as input multiple, already existing *.blib-files (generated from DDA-data). To do so, I used the option: Filter for document peptides. The merged, resulting spectral library gets generated however it does not only contain the MS2 spectra corresponding to my peptides of interest. I.e. the “merged, reduced” spectral library (which got filtered for my 70 document peptides) comprised as many peptides as the original, full spectral library. No filtering takes place.

According to Kaipo’s post (https://skyline.ms/announcements/home/support/thread.view?rowId=25366) I understand the “filter for document peptides” option, that it will consider only the activated (ticked off peptides per protein) in the target window and it will ignore deactivated peptides, right ? I am using Windows 10, Skyline 21.1.0.146 (alpha), however I had the same problem also with your latest Skyline daily version. Thank you for your help.
Best Peter

 
 
Kaipo responded:  2021-06-02

Hi Peter,
This looks like a bug. Building a library by merging existing blibs is a special case, where BiblioSpec essentially just combines the files together (skipping other code that usually gets run, such as the filtering peptides). I think that's probably what's happening here.
Would you mind sharing your files to https://skyline.ms/files.url so I can verify and fix the issue?

Thanks,
Kaipo

 
peter r mosen responded:  2021-06-02

Hi Kaipo,
thank you for your quick response. I am happy to share the document with you, however I would prefer the non-public data transfer. Is there a possibility to share data non-public within the forum, or shall I sent an e-mail?

Best Peter

 
Kaipo responded:  2021-06-02

Sure, you can e-mail them to me directly (kaipot@uw.edu)

Thanks,
Kaipo