Instrument setting issue

support
Instrument setting issue Tobi  2020-06-08
 

Dear Skyline team,

I noticed the Instrument settings/ Min Max m/z applies to both fragments and precursors at the same time. Did skyline always behave like this? I find it a bit troublesome as fragment measurement ranges are nearly all the time much wider than precursor measurement ranges. If I use this setting to properly filter precursors I loose lots of fragments, and if I properly filter fragments I spend alot of time on loading sometimes thousands of nonsense precursors into the target list.

Do you have a good tip or workaround on how I can differently filter precusors/fragments when building a target list?
Do you consider having separate settings for MS1 and MS2 in the near future? (just asking if by chance it makes sense for me to wait a bit).

Looking forward to a short reply.

[Skyilne-daily 20.1.1.158, add peptide PEPTIDER++, filter for 400 to 500 mz yields only 3 fragments]

Best wishes,
tobi

 
 
Brendan MacLean responded:  2020-06-08

Hi Tobi,
I have considered in the past changing this to be two sets of min and max values, as you suggest. However, 1 is appropriate for SRM and most of the time when people do DIA, the min and max precursor range is controlled by a prespecified isolation scheme, and DDA with MS1-only extraction also only requires one min and max for controlling the precursor m/z values.

So, the cases where this is still less than ideal might be summarized as:

  • PRM
  • DIA with a "Use results" isolation scheme
  • DDA with fragment ion extraction (unusual, but people do this and we now support it with an option in the MS/MS filtering Isolation scheme dropdown list)

Are you using one of these methods, or something else that requires what you are asking for.

In these cases, we don't yet have an answer for you, if you want to limit both precursors and products to different ranges. Maybe we should add it to our list for Skyline 20.2. But, yes, this has always been the case, and hardly anyone has complained about it.

Can you describe your exact experimental setup? PRM seems the most validly problematic to me. If you are doing either of the other two, I would suggest using a prespecified isolation scheme for DIA and we are just less interested in the fragment ions from DDA case.

Thanks for your feedback.

--Brendan

 
Tobi responded:  2020-06-09
Title: Instrument setting issue - Document grid bug

Hi Brendan,

you made an excellent guess with both DDA and PRM suffering from just the total mz range being specified in Skyline.

The good news is, a workaround is Setting / Transition Setting / Instrument / min max mz to fit fragments and filter undesired nonsense Precursors out of measurement range via Document grid / Filer Precursor mz for < 350 and >1700 (in 2 seperate steps) and Action / Delete Precursor. Works even before loading raw data to save time.

However, the document grid seems bugged:

If it is floating select all with CTRL+A and delete Precursor etc. works fine as it should.
If the document grid is docked the CRTL+A jumps always to the target list and you cant use it as intended on the doc grid. Also, Action / remove Precursor and such do not apply to all selected rows but only the first row.

I think we can close this issue as a workaround exists and any change to the settings might do more harm than good.
Could you please open an issue on the doc grid behavior floating vs docked?

Best wishes,
tobi

 
Nick Shulman responded:  2020-06-10
Thanks for pointing out the Select All problem. I will fix this.
We already have code to make sure that the Cut, Copy, Paste and Delete menu items get directed to the correct window.

You can always select all of the rows by clicking the square in the top left corner of the grid.

When you have rows selected, the "remove precursor" menu item will apply to all of the selected rows. You can tell that the row is selected because the row header at the left edge of the grid row is highlighted.

You probably had a rectangular selection which did not include the row header. In this case, the "Remove Precursor" menu item would only apply to the current row (that is, the row whose header has the triangle in it).
-- Nick