Failed importing results- .wiff file from SCIEX triple Quad

Failed importing results- .wiff file from SCIEX triple Quad sarahmacpherson676  2019-06-19 14:07

First, thank you for offering this software, I’m new to Skyline and I am excited to use it.

My data files were collected from another lab using SCIEX triple Quad (5500). I am looking at small molecule data (around 200 metabolites). I was given a .wiff file containing the multiple runs and the .wiff.scan. However I am unable to upload either(file-->import-->results). I’m not sure if this is a file issue, software or something on my side. I have tried using the newest version of Skyline and Skyline Daily.
Attached are the errors that I receive for the .wiff file and .wiff.scan
Also attached is the .wiff and .wiff.scan files
Thank you for your time

Brendan MacLean responded:  2019-06-19 14:22

With an error like that, we usually start by asking whether you can open the file in Analyst. The message is suggesting that it might be corrupted. Opening with Analyst is the first step in proving that it is not.

Let us know what you find.


Nick Shulman responded:  2019-06-19 14:25
Those files work fine for me in both Skyline 4.2 and Skyline-Daily.

Have you tried doing this on a different computer?

The error code that you are seeing is "-2147286960". The name of that Microsoft error is "STG_E_FILEALREADYEXISTS".
I do not know which part of Skyline or the Sciex software library is causing that error, but it seems like maybe there is a file on your computer somewhere which is not supposed to exist or was supposed to be created only temporarily, and which is messing things up. and maybe a different computer will not have this problem.
-- Nick
sarahmacpherson676 responded:  2019-06-24 13:48
Thanks for your help, but I'm still unable to open the files on a different computer. Both are Mac computers with Windows partitioned onto it.
However, the tutorial files will open.
Nick Shulman responded:  2019-06-24 14:04
Which version of Windows are you using?
sarahmacpherson676 responded:  2019-06-24 18:39
Windows 10 - May 2019 version
Matt Chambers responded:  2019-06-25 07:16
Hi Sarah,

Do you have Skyline installed using the administrative installer (installed to Program Files)? If so, try running Skyline as administrator when importing this file.

Alternately, download and install ProteoWizard (, then right click on your wiff file and click "Open with MSConvert". Then press the Start button to convert the WIFF samples to mzML files. You should be able to import these mzML files into Skyline. If that conversion fails with a similar error, I'll have to think about what could be causing this, since Nick reports he's able to open the files.
sarahmacpherson676 responded:  2019-06-26 15:53
Hi Matt,
I re-installed Skyline using administrative installer and still no change.
I installed ProteoWizard and got a similar error when trying to convert the Wiff sample to mzML.
Let me know if you can think of anything else.
Matt Chambers responded:  2019-06-26 16:01
Wow. Really strange. Like Nick, I'm able to convert the file fine. Are you using 32-bit?
Nick Shulman responded:  2019-06-26 16:53

When you try to import results in Skyline, Skyline brings up a dialog asking you which of the samples you want to import chromatograms from. Your original error happened while Skyline was trying to read the chromatograms from "sample 0_03MPA" (which is the first sample in the list). I wonder whether it would work if you unchecked that first one, or whether Skyline would simply run encounter the same error on the next sample.

By the way, attached is a .zip file containing .mzML files for the samples in the .wiff file. If you cannot get Skyline to read .wiff files on your computer, you will probably be able to use these .mzML files.
-- Nick
sarahmacpherson676 responded:  2019-06-28 13:54
the mzML files work!
MSConvert can convert my files now too.
Thanks for all your help!
onursenol responded:  2022-09-14 15:45
hi sarah i have seen your problem in google and registered this web-site. I hope you can see this respond. I have a trouble on Sciex X500R tof. I have .wiff and .wiff.scan data and import them on xcms but it does not work. i have converted the .wiff file and i get feature detection error. I could not find the what happened. We get used to agilent and sciex is quite different. do you have any suggestion about what i have to do. There is also a .wiff2 data and i have no idea what it is.
Nick Shulman responded:  2022-09-14 18:47

It sounds like you are saying that something is not working for you.
Can you give us more information about what is going wrong? Are you seeing any sort of error message?
-- Nick
onursenol responded:  2022-09-14 23:43
Hi nick, data is very big. I have three data from Sciex X500R which are .wiff, .wif2 and wiff.scan. They are all automatically generated. I use proteowizard to centroid the data and wiff and wiff2 data succesfully converted into mzxml format. However there is no possibility to convert wiff.scan via proteowizard. I upload the data into xcms and encountered in an error message it says there is no feature. XCMS recommend to upload wiff and wiff.scan data together but it also give error. I firstly used sciex in metabolomics analysis and can not figure out the situation. I wonder, there is anyone familiar with metabolomics and sciex software to upload xcms or other softwares.
Matt Chambers responded:  2022-09-15 07:27

The WIFF/WIFF2/WIFF.SCAN are all part of the same data acquisition. The WIFF2 format is newer and the WIFF format is older but they both represent the same data. Actually due to some vendor API quirks, Skyline/ProteoWizard are better at extracting data from WIFF1 files currently. The .SCAN files are where the bulk of the data is actually stored and is used by both formats.

If you're having trouble with XCMS you should probably post on their support board though. :) XCMS and Skyline aren't connected.