Maintaining Integration Windows When Re-importing Data

support
Maintaining Integration Windows When Re-importing Data meyermr  2014-02-28
 
Hi Skyline Team,

I'd like to know if Skyline can maintain integration windows manually set by the user when re-importing a data file? For example, when I manually set the integration window for a given peak, add additional fragment ions to the peptide tree, and then re-import the data...Skyline will shift the integration windows slightly. Is there a way to override this so I don't have to manually go through and reset the integration windows?

Thanks for the help,
Matt
 
 
Brendan MacLean responded:  2014-02-28
Hi Matt,
If you can give me a small example case, I will look into this. If you are using Edit > Manage Results > Re-import, then this should not be happening.

A good example would help me debug why it is in your case.

I will contact you through email with a location you can use to post files.

Thanks for taking the time to report this, and sorry it is not working correctly for you yet.

--Brendan
 
bzhai2 responded:  2020-02-18
Manual Integration Windows was not maintain when I re-import the raw data.
 
amckenzie responded:  2020-07-09
Hi Skyline team. I have the same problem. Everty time I reimport data any prior integration that I have done gets overwritten. Any way to avoid that?
 
Tobi responded:  2020-07-13
Hi all,

for a quick try to fix you can File - Export - Report - Peak Boundaries, then reload the data, and afterwards File - Import - Peak Boundaries.

Please check User Set Peak or RT Start/End in the Document grid to see if that actually helps with your specific problem.

Best,
tobi
 
Brendan MacLean responded:  2020-07-13
When you re-import your data which are you doing?
1. Edit > Manage Results - selecting replicates and clicking the Re-import button and OK
2. Edit > Manage Results - selecting replicates and clicking Remove or clicking Remove All and OK and then File > Import > Results

The latter is not expected to preserve peak integration. However, the former is.

If you have a simple way to reproduce #1 failing for you, please use File > Share to create a .sky.zip, and then zip that and any necessary raw data files into a single ZIP file with all of the necessary files to reproduce the issue. Then add the simplest possible steps you can come up with that show the problem and post them to this thread.

Once we have files and steps to reproduce the problem, we can usually find a fix relatively quickly. To our knowledge we have fixed all issues of this type which have been reported.

Thanks for posting to the Skyline support board.

--Brendan
 
Brendan MacLean responded:  2020-07-13
Again, we would like to fix this if there truly is an issue with #1. Tobi's suggestion is a workaround, but we'd prefer people didn't feel they needed to do this, unless they truly are going to do #2.
 
bzhai2 responded:  2020-07-13
I have always been using option 1 to re-import.
It seems my issue is somehow fixed now. My assumption was recent program updates fixed it.
 
Brendan MacLean responded:  2020-07-13
Okay. That makes sense. Skyline has had this bug in multiple cases in the past, but we have fixed each case as it arose. Should any new cases arise, we would also like to fix those and would only need files and steps to reproduce the problem in order to debug and fix it.

Glad, however, that your case was already fixed.