Add modifications to Skyline

support
Add modifications to Skyline francescomattia mancuso  2013-11-24
 

Dear Brendan,

I would like to know if there is an automatic way to add modifications that are not present in Skyline.

I saw the possibility to add one by one, but the best would be importing them directly from unimod xml, all in one step.

 

Many thanks for your help,

Francesco
 
 
Brendan MacLean responded:  2013-11-25
Hi Francesco,
Skyline contains all of the modifications from Unimod already, but mostly you still need to add the ones you are interested in one-by-one. If you have a spectral library containing your modifications of interest, then Skyline will automatically guess them from its Unimod list when you open your library in the Spectral Library Explorer (View > Spectral Libraries). It will also guess from its internal Unimod list when you paste (Edit > Paste - Ctrl-V) or insert (Edit > Insert > Peptides) peptide sequences annotated with modifications like:

PEPT[+80]IDER
PEPT[Phospho (ST)]IDER

Even when you add modifications one-by-one, you just need to choose then from a list of Unimod modifications, which we join with Mascot naming definitions to ensure naming consistent with Mascot.

See the attached PowerPoint slides for screenshots of how these features look.

Thanks for posting your question to the support board.

--Brendan
 
scappadona responded:  2014-06-10
Dear Brendan,
I have one more question on this subject.
When working with the MS1 full scan filtering wizard , I usually get a dialog box with all the modifications found in my DAT files.
In my current project, I am working with DAT files created with Error Tolerant search in Mascot.
The DAT files seem to be correct and contain all the desired modifications in Unimod format.

My problem is that when I import these data, I don't get any message to add 'guessed' modifications.
Furthermore, when I inspect the library in the explorer, I get a message that asks me to add only Caroxymethyl[M]=58

Can you tell me if I am missing any step?
Am I wrong if I think that Skyline should automatically recognize (and ask me to import) the Unimod modifications in my DAT files (as in the tutorial and the slides you posted in your last answer)?
Might there be a specific problem with error tolerant searches?

Thanks for your support,
Salvo

If you want to inspect an ErrorTolerant DAT files, I could send you one by WeTransfer or similar ...
 
shezi 323 responded:  2019-02-17
Dear Brendan,

I am now studying on glycopeptide quantification using Skyline. I also want to input a glycan mass library into Skyline. I cannot find all of these glycans from Unimod. Therefore, I have to input them one-by-one to make it work. But it is 701 glycans, which I really hope to input in a batch mode. Is there any suggestion about this?

Thanks for your support,
Qingbo
 
Brendan MacLean responded:  2019-02-19
Hi Qingbo,
You could have a look at a very simple Skyline document (.sky file) in a text editor with some modifications defined. These files are XML. Once you understand the format, you should be able to construct a Skyline document that contains all of your modifications of interest, simply by generating the appropriate XML text. For instance, here is what the structural modifications for Carbamidomethyl (C), Oxidation (M) and Phospho (ST) look like in Skyline XML:

        <static_modifications>
          <static_modification name="Oxidation (M)" aminoacid="M" variable="true" formula="O" unimod_id="35" short_name="Oxi">
            <potential_loss formula="H4COS" massdiff_monoisotopic="63.998285" massdiff_average="64.10701" />
          </static_modification>
          <static_modification name="Carbamidomethyl (C)" aminoacid="C" formula="H3C2NO" unimod_id="4" short_name="CAM" />
          <static_modification name="Phospho (ST)" aminoacid="S, T" variable="true" formula="HO3P" unimod_id="21" short_name="Pho">
            <potential_loss formula="H3O4P" massdiff_monoisotopic="97.976896" massdiff_average="97.995181" />
          </static_modification>
        </static_modifications>

You may choose to omit the unimod_id and short_name attributes, and I believe the <potential_loss ... massdiff_...> values will be ignored and recalculated when the document is opened.

Assuming you can use something to convert your 701 glycans into this format and insert it into a very small Skyline document (targets are unnecessary), then you only need to open that document once to get the modifications into your instance of Skyline.

Hope this helps.

--Brendan
 
shezi 323 responded:  2019-02-19
Hello Brendan,

Thank you very much for this advise. I will try it then.

Qingbo
 
shezi 323 responded:  2019-02-21
Dear Brendan,

You suggestion is so helpful. I already added all 701 glycans into the structure mod list following the way you suggested. Attached please find the "glycoform in skyline.sky" file for this. Now it seems like all of them are recognized by Skyline. After that, I chose to import a peptide search result in .ssl format, which included glycopeptides from a sing protein. Step-by-step processing lead me to the step of "import FASTA (optional)", and I copied and pasted the fasta sequence of this protein into the blank box. After a long while, no progress could be observed (see attached slide please). I had to cancel it.

My question is how to omit this step "import FASTA" since it is optional and type in all peptides directly?

Thanks,

Qingbo
 
Nick Shulman responded:  2019-02-21
Yes, you can cancel out of the "Import Peptide Search" wizard when you get to the "Import FASTA" page. That will leave you with a document that has a spectral library (.blib) that was created from your peptide search results.

After you cancel out of the wizard, you can go to:
View > Spectral Libraries
and then press the "Add All Peptides" button.

After adding the peptides to your document you can do:
File > Import > Results
to extract chromatograms for the peptides that you have.

I imagine that the reason that the "Import FASTA" got stuck was that Skyline was considering every possible combination of the available modifications (we should fix this so the cancel button works better).

It might speed things up if you go to:
Settings > Peptide Settings > Modifications
and change "Max variable mods" to "1" (the default value is 3, which would result in millions of combinations of your 700 modifications)

-- Nick