In few data files peak peaking is not working

In few data files peak peaking is not working darshak niper  2024-05-08 12:42


In few files peak peaking is not working. We manually look at the TIC and check the data file in mass hunter qualitative analysis, it looks ok. But in skyline processing those file does not show any peaks. In the attached skyline document , the file name "Pos_CC6" where peak peaking is not working.

Nick Shulman responded:  2024-05-08 13:40
When Skyline is extracting from a file which has both regular MS1 spectra and SIM spectra which match the precursor, Skyline will preferentially extract chromatogram points from the SIM spectra. In Skyline, a SIM spectrum is defined as any spectrum where the m/z range that was scanned is less than 500m/z.
Sometimes you would prefer that Skyline extract chromatograms from the MS1 spectra instead of the SIM spectra, in which case you should check the checkbox "Ignore SIM scans" at "Settings > Transition Settings > Full Scan" and then reimport chromatograms using the Reimport button at "Edit > Manage Results".

When Skyline extracts chromatograms from spectra, Skyline sums the intensities across a m/z channel centered on the target m/z. The width of the channel that Skyline sums across is controlled by the "Resolution" setting at "Settings > Transition Settings > Full Scan".
If you click on a point along the chromatogram Skyline will bring up a spectrum viewer which will display the spectrum from which that chromatogram point was extracted. The spectrum viewer will highlight the m/z channel that was summed across.
If the chromatogram that you see is completely flat, and you expect there to be some signal, the problem might be that the extraction window was too narrow in which case you should choose a lower resolution at "Settings > Transition Settings > Full Scan" and then reimport chromatograms using the Reimport button at "Edit > Manage Results".

By the way, it would be very helpful if you could send me "Pos_CC6.d". I am confused by what I am seeing in terms of what Skyline thinks the spectra looked like in terms of what m/z range was available. If I could see your original raw data I could figure out whether there is a bug here that I need to fix.
You can package the "Pos_CC6.d" folder in a zip file. If that zip file is less than 50MB you can attach it to this support request, otherwise you can upload larger files here:
-- Nick
darshak niper responded:  2024-05-08 14:05
Thanks a lot for quick reply. I checked "ignore SIM scans" its working now.

I have also uploaded raw files "Pos_CC6".

Thanks Nick.
Nick Shulman responded:  2024-05-08 15:38
Thank you for sending that file.
When Skyline is extracting chromatograms from MS1 spectra, Skyline has to decide whether a particular spectrum is a regular MS1 spectrum which was intended to provide data for all of the molecules in your dataset, or whether it is a targeted MS1 spectrum (what Skyline calls a "SIM" scan) which was only supposed to provide data for a subset of the molecules whose m/z values are in a small range.
The way that Skyline decides what sort of spectrum it is looking at is by looking at the m/z range over which data was collected.

It appears that for some types of data, such as the Agilent .d folder that you sent me, Skyline does not have access to the actual scan window that was collected, and is, instead, basing its decision on the lowest and highest m/z's that were observed in the spectrum.
When you check the checkbox "Ignore SIM scans" at "Settings > Transition Settings > Full Scan", your chromatograms do end up looking a little better, but the chromatograms are actually missing points from the spectra where the difference between the highest and the lowest observed m/z value happens to be less than 500.
This does not actually affect the observed peak areas in your dataset because the only spectra with very few observed m/z's only occur at the very beginning or end of the run, nowhere near your actual chromatogram peak.

I will ask around among my coworkers and try to fix this behavior.
-- Nick