error using "DIA raw" option when performing Import Peptide Search

error using "DIA raw" option when performing Import Peptide Search wphipps5  2024-02-21 14:53

Hi there-- I am trying out this "Start from: DIA Raw" option during Import Peptide Search of our DIA results. It runs for several hours but then gets an error message. Here is how it ends:

"[2024/02/21 12:08:14] INFO: Issued command:
[2024/02/21 12:08:14] INFO: percolator --results-peptides D:\dia_mzml\231101_dia_mzml_rename\crux-output/ --decoy-results-peptides D:\dia_mzml\231101_dia_mzml_rename\crux-output/percolator.decoy.peptides.txt --results-psms D:\dia_mzml\231101_dia_mzml_rename\crux-output/ --decoy-results-psms D:\dia_mzml\231101_dia_mzml_rename\crux-output/percolator.decoy.psms.txt --verbose 2 --protein-decoy-pattern DECOY_ --seed 1 --subset-max-train 0 --trainFDR 0.01 --testFDR 0.05 --maxiter 10 --search-input auto --no-schema-validation --protein-enzyme trypsin --post-processing-tdc D:\dia_mzml\231117_dia_mzml_rename\
[2024/02/21 12:08:14] INFO: Started Wed Feb 21 12:08:14 2024
[2024/02/21 12:08:14] INFO: Hyperparameters: selectionFdr=0.01, Cpos=0, Cneg=0, maxNiter=10
[2024/02/21 12:08:14] INFO: Reading tab-delimited input from datafile D:\dia_mzml\231117_dia_mzml_rename\
[2024/02/21 12:08:14] INFO: Features:
[2024/02/21 12:08:14] INFO: retentiontime rank abs_ppm isotope_errors log10_evalue hyperscore delta_hyperscore matched_ion_num complementary_ions ion_series weighted_average_abs_fragment_ppm peptide_length ntt nmc Charge1 Charge2 Charge3 Charge4 Charge5 Charge6 Charge7
[2024/02/21 12:08:14] INFO: Found 28 PSMs
[2024/02/21 12:08:14] INFO: Concatenated search input detected and --post-processing-tdc flag set. Applying target-decoy competition on Percolator scores.
[2024/02/21 12:08:14] INFO: Train/test set contains 28 positives and 0 negatives, size ratio=inf and pi0=1
[2024/02/21 12:08:14] FATAL: An exception occurred: Error: no decoy PSMs were provided.
[2024/02/21 12:08:14]
[2024/02/21 14:20:21] Search canceled."

The full output is attached as well as a pdf of my settings. I can provide the mzML files and the fasta.


Nick Shulman responded:  2024-02-21 17:24
Someone else ran into this same error a year ago, and, unfortunately, it looks like we never tried to answer their question:

It's conceivable that an error like this could be caused by a FASTA file that was much too small.

If you send us your FASTA file and your .mzML files, we could try to reproduce the error that you are running into.
You can package everything up in a .zip file and upload it here:
-- Nick
wphipps5 responded:  2024-02-21 19:41
I had brought up the issue of a small fasta to Mike but he didn't expect it to be problematic here. Perhaps notably, however, using DIA-NN I also get no results with these mzML files when using a small fasta (compared to say the human proteome).

I uploaded a zip with the mzml and fasta.

Thank you
Bill Phipps
Nick Shulman responded:  2024-02-22 00:13
This worked for me.
I tried this with both Skyline 23.1 and Skyline-daily and I did not get any error.
I am attaching the file which I ended up with when I did this with Skyline-daily.
Also, I am attaching the output that I got when I did this with Skyline-daily and with Skyline 23.1.

Maybe you could look at the output that I got and figure something out. I wasn't able to see anything that would explain why your behavior is different, but maybe you'll see something.
-- Nick
wphipps5 responded:  2024-02-22 12:32
Thank you. I may not be a 1:1 comparison because I only submitted 6 of the 41 mzML files. I'll try subsets of files and see if a particular file is a culprit or the total # of files is problematic.