Skyline Error on MS data file import

Skyline Error on MS data file import db432  2024-02-21 04:43

Dear Skyline Support,

I am using Skyline to import MS data collected on waters Xevo TQXS and Skyline fails to open the file with the error below.

"At 12:28 PM:
Could not load file or assembly 'pwiz_data_cli.dll' or one of its dependencies. The specified module could not be found".

I have uninstalled Skyline from the PC, deleted all command files, restarted the PC and reinstalled the most up to date version (Skyline 64-Bit) (cf25ad847) but still the error appears.

I also note that my Skyline files on the PC do not have the Skyline logo but just plain files (see attached PDF file).

Can you please advice on what to do?

Nick Shulman responded:  2024-02-21 07:39
That error usually means that something has gone wrong with your Skyline installation and that you should uninstall Skyline and install it again.

Someone else reported the same error two days ago:

When multiple people start to report the same error like this we do have to worry that something might have been messed up with the latest Skyline installer, and that we forgot to include a .dll that turns out to be required on some computers.
Let us know if uninstalling Skyline and installing it again does not fix your problem.

The procedure for diagnosing exactly why you a computer is experiencing the "Could not load file or assembly 'pwiz_data_cli.dll' or one of its dependencies" error is long and complicated, so I hope we do not have to resort to that sort of troubleshooting.

If you cannot get the regular installer of Skyline to work, you might have more luck with the "unplugged" installer:
One thing about the "unplugged" installer is that after you have downloaded the .zip file, you should right-click on the .zip file in Windows Explorer and choose "Properties" and then check the checkbox that says "Unblock". If you ask Windows to extract all of the files from the .zip file without doing that step first, that might put you in a state where you could get the "Could not load file or assembly 'pwiz_data_cli.dll'" error.
-- Nick