Filter peptide contains specific peptide in library

Filter peptide contains specific peptide in library GH  2024-02-14 11:43

I generated my library from other software and want to import to skyline (import library assay). I want to filter a peptide containing only L (leucine). I tried in peptide setting -->Filter-->Exclude peptides containing. I created the one to be excluded (attached file here). I did refine and advanced, however it does not filter peptides and still see all peptides.
my question is that is it possible to filter peptide for library? or Do you have any suggestion to solve this problem?

Thank you, Gazale

Nick Shulman responded:  2024-02-14 11:55
If you want to remove all of the peptides from your document that do not contain Leucine, the easiest way to do that is probably with the Document Grid.
You can show the Document Grid using the "View > Document Grid" menu item, and then you can choose "Peptides" from the "Reports" dropdown at the top of the Document Grid.
After that, you can right-click on the "Peptide" column and choose "Filter" and set the filter to "Does not contain" and "L".
Then you can select all the rows in the Document Grid and use the red "X" button on the toolbar at the top of the Document Grid to delete the peptides associated with the selected rows.

If you would like to learn more about the Document Grid you should look at the Custom Reports tutorial:

A different way to remove large numbers of peptides from the document is to use the "Refine > Accept Peptides" menu item. You would use that menu item if you have managed to figure out the list of peptides that you want to keep, perhaps by using some other tool such as Microsoft Excel, and you want to get rid of all of the peptides that are not in your list.

There might also be a way to get it to work using the "Exclude peptides containing" feature that you tried using on the "Filter" tab of the Peptide Settings dialog. However, in order for that to work, you also need to make sure that the "Pick peptides matching" setting on the "Library" tab is set to either "Library and Filter" or "Filter" because otherwise the Filter will not be considered a requirement for a peptide to be included in the document. Also, for every protein in the document Skyline keeps track of whether the user is controlling which peptides it has, or whether Skyline is, and, sometimes proteins get switched to user-managed-mode, and you also have to go to "Refine > Advanced" and check the "Auto select all peptides" checkbox for the filter settings to have an effect.
-- Nick
GH responded:  2024-02-15 13:24
Thank you for you answer, very helpful.