"Failed importing results...the calculator requires all targets list in order to determine a regression."

"Failed importing results...the calculator requires all targets list in order to determine a regression." lh48280  2024-01-25 13:24

Hi Skyline Team,
I have been trying to develop a PRM method for a targeted DIA experiment in skyline. I have eight targets of interest which have been built into a transition list, but I do not expect all my samples to have all 8 of these targets. I have been successful in building the calibration curves from spectra for my targets and setting up the iRT calculator, however, when attempting to upload results for sample quantification, I keep receiving this error:

"Failed importing results file.
The calculator requires all 8 of its standard peptides to be in the targets list in order to determine a regression."

I have followed the PRM and iRT tutorials and looked through other support requests, but unfortunately have not been able to fix this. The tutorial data works without any trouble, but once applied to my own spectra throws an error. I have attempted to re-import spectra, and rebuild the calculators, but the same error still occurs. Any advice/help would be greatly appreciated!


Nick Shulman responded:  2024-01-25 16:01
Can you send us your Skyline document?

In Skyline you can use the menu item:
File > Share
to create a .zip file containing your Skyline document and supporting files including extracted chromatograms and ion mobility database (.irtdb).

The error message is telling you that some of the peptide standards in the .irtdb file are not in your Skyline document.
That is, if you go to:
Settings > Peptide Settings > Prediction and push the calculator button and choose "Edit", in the "Edit iRT Calculator" you will see that in the "iRT standards" list there are some peptides that are not in your Skyline document.
One thing that you could do is push the "Choose Standards" button and remove the peptides from the list that you do not have in your document.

Alternatively, there is also usually a way to get Skyline to offer to add the missing iRT standard peptides to the document. You sometimes have to fiddle with things in the "Edit iRT Calculator" dialog and then push OK, and, if Skyline notices that something might have changed Skyline usually offers to add the missing iRT peptides to the document.

After I see your Skyline document I will probably be able to give you better advice.
-- Nick
lh48280 responded:  2024-01-26 08:13
Yes, of course. I have attached 1 of 4 of my documents, being that they have all had the same error message. I appreciate the response and help!

I have the 'Edit iRT Calculator' dialog box open, but I am not seeing an option for choosing standards. With the biological samples, I am not able to predict what targets would and would not be present in the samples.

I was able to get a dialog box to pop up on one document once that when I went to import results, prompted me to choose which replicates would make the calibration. I have yet to receive that message again nor on any of my other documents. I used a serial dilution of standards to get exact masses and retention times. I was able to use the spectra, to create a transition list for my eight targets and I created the calibration curves, just have not been able to use them for quantification in the samples.

Thank you for getting back to me,
Nick Shulman responded:  2024-01-26 11:49
Thank you for sending me your Skyline document.

I see that this is a small molecule document.

If you go to:
Settings > Molecule Settings > Prediction > Calculator button > Edit Current
you can see the list of molecules that are being used as the iRT standards.
One of those molecules has the name "#$#D0S6$691.098676000/691.098676000$". This is the molecule which is not present in your document. You can select that row in the "iRT STandards" grid in the "Edit iRT Calculator" dialog and then push the "Delete" button to remove it from the list of standards.
The reason that Skyline is displaying that molecule as that weird thing with the "#" and "$" is that the molecule in the iRT database does not match anything in the Skyline document. That is, all of the molecules in the iRT database get stored like that, but, for the ones that Skyline is able to match to something in your document, Skyline displays in a more friendly way.

Another thing that you should do is go to "Settings > Transition Settings > Full Scan" and change "Retention time filtering" to "Include all matching scans". When you have a PRM experiment you nearly always want Skyline to use all of the spectra where the mass spectrometer isolated the precursor because your PRM method probably already told the mass spectrometer the time range over which you wanted chromatogram data for each precursor.

The thing about Skyline offering to add iRT standards to your document usually only happens if you are using one of the built-in standards such as "Bigonosys" or "Pierce". Skyline knows which transitions to use for all of those built-in standards.
If it's a set of standards that you invented yourself, you should try to already have those molecules in your Skyline document.
-- Nick
lh48280 responded:  2024-01-26 13:14
I went ahead and removed the problem target and attempted to re-import my calibration spectra, but the same error is still occurring.

I went ahead and also changed the retention time filtering, as suggested. The standards are commercially available, they have just been used to develop the transition list for each of the acquisitions.

I will take your suggestions and see what I can do!

Thank you,