Toggle off protein overlay information

Toggle off protein overlay information Juan C. Rojas E.  2024-01-10 05:40

Hi Skyline wizards,

I am facing serious performance issues when I accidentally hover the protein node of Skyline documents. This is more significant the bigger the document is and specially if it has PTMs on it. I am not sure what is calculated when this is done, but it freezes the software completely. If I am lucky after some minutes of not clicking anywhere it will finish processing and let me continue. But I have had several instances I had to force shut the software and loose all unsaved progress.

I suspect these issues was introduced when the protein sequence coverage visuals were included some time ago (maybe 1-2 years). This might have a good appeal for many, but in my case I find it more troublesome than helpful so I was wondering if there is a way of disabling that feature or focus some rework on it to avoid these "freezes"?

Thank you for your time and help.
Juan C.

Nick Shulman responded:  2024-01-10 07:02
There is no way to turn off that feature, but I will try to make it faster so that it is impossible to notice.

The protein sequence coverage visuals have always been there, but, I do believe that the tooltip display did become slower about 2 years ago when Skyline stopped reading as much data from the .skyd file when you first open the document, but delays reading peak areas until that information is needed and does not keep that information in memory.

It would be helpful if you could point me at an example (you could send me an email with a link) of a Skyline document where you are seeing this performance problem and I will make sure that this particular performance problem disappears.
-- Nick