Error uploading MSFragger DIA GPF results into Skyline

Error uploading MSFragger DIA GPF results into Skyline Tomas Vaisar  2023-09-18 12:34

We are trying to upload MSFragger results from a search on DIA GPF, following the instruction ( using both DDA and DIA search results workflow in Skyline. But in both cases we get error that the spectra cannot be found. We have both interact-xx.pep.xml and the mzML files in the same directory, so I am not sure what is going on.
Apparently there has been previously similar issue with this when .mgf file were used.

Thanks for any advice.


Tomas Vaisar responded:  2023-09-18 13:45

Additional information:
I also tried to make the library directly using BlibBuilder.exe and got the same error:
c:\Users\vaisarlab\Documents\Study_198_SEARCH_Phase1_CVD_BDC\FragPipe\TV_fp10_test5good\1>..\blibbuilder\BlibBuild.exe interact-20230706_CL_BDCA_GPF8_SRA2_rank1.pep.xml test.blib
Reading results from interact-20230706_CL_BDCA_GPF8_SRA2_rank1.pep.xml.
Read 745 matches that passed the score filter (281 matches did not pass).
Loading .\20230706_CL_BDCA_GPF8_SRA2.mzML.
Reading spectra from .\20230706_CL_BDCA_GPF8_SRA2.mzML.
[SpectrumList::find] mismatch between spectrum id format of the file (controllerType=0 controllerNumber=1 originalScan=1 demux=0 scan=1) and the looked-up id (controllerType=0 controllerNumber=1 scan=7675)
ERROR: No spectra were found for the new library.