Skyline Problem

Skyline Problem jean-christophe prost  2023-09-04 00:47

Dear all,

We have a problem with skyline . I tried different thinks, but with always the same result.
We had the newest version installed on both. Then the working station did not recognized the Soft anymore. I tried to install an older version. When we click on the skyline shortcut a dowload tries to be accomplished and then comes a pop-up window telling the download is not possible.
THe skyline files are not recognized anymore. THis started 3 weeks ago.
I desintalled and installed again the soft many times but nothing changed. I really do not understand what I can do more.
And this is only happening on two specific working stations

I put you everything the in the attachment bellow.^
Thank you for your support.

Kind regards, JC

Nick Shulman responded:  2023-09-04 01:48
I do not know how to fix the "The application is missing required files" error.

Usually, when something like this happens we suggest that you try the "Unplugged" installer instead.

You can download the unplugged installer here:
jean-christophe prost responded:  2023-09-04 02:05
Dear Nick,

These both installations are unplugged versions. Due to high security level in the hopsital, almost all computers are intalled with the unplugged version.
Only these two computers are bugging since few weeks, I do not know why.

Nick Shulman responded:  2023-09-04 02:44
With the unplugged installer, you do not need to run the setup.exe.

You can also just directly run the Skyline.exe which is inside of the unzipped folder.

One downside to running Skyline.exe like that is that the program does not appear on your Start Menu. But, other than that, the Skyline.exe which you run this way will behave the same as a Skyline which has been installed in the usual way.

Does that help?
jean-christophe prost responded:  2023-09-04 04:49
Dear Nick,

I installed the Skyline.application and not the setup.exe.
We can use now the skyline app but, still not recognize the skyline documents. The double click on a skyline file is no more possible. Same problem than in my first message. Again application error download.
See the Word document attached with the printscreens, and the Application error popo-up window when I try to open a skyline file.

For our daily work it is really anoing that skyline does not work anymore like before. And I would be happy that somebody can explain wht this error window tells me.

Thank you for the help.
Nick Shulman responded:  2023-09-04 06:53
When you double-click on a file whose name ends in ".sky" in Windows Explorer, Windows tries to decide which program to run.

There might be some useful information about how to fix this on this page:
Sometimes it is also possible to fix the file association by right-clicking on a .sky file in Windows Explorer and choosing "Open With..." and then "Choose another app" and then choosing Skyline.

Are you able to launch Skyline using the Windows Start Menu?
When you launch Skyline from the Windows Start Menu, you can use the "Help > About" menu item to see which version you have installed.

When you use the "unplugged" installer, you download the .zip file, extract the contents and then run the setup.exe from the extracted folder.
The Skyline that gets installed remembers which folder it was installed from.
If you were to later delete the folder on your computer that Skyline was extracted from, then a few bad things will happen. When you start Skyline, you might see an error saying that Skyline failed to check for an update.

When you have installed the "unplugged" installer, Windows will use the word "downloading" when it describes the steps of the installation process, but what it is really doing is reading the folder that it found "setup.exe" in.
So, when Windows tells you "Cannot download the application", what it is really saying is that it can't read the files from the folder on your computer where it expects to find them.

I see that one of the errors that in the Word document in your initial post says:
Could not find a part of the path 'C:\Users\admin\Desktop\Skyline-64_22_2_0_312\Skyline-64_22_2_0_312\Skyline.application'

The error seems to be saying that the folder on your computer "C:\Users\admin\Desktop\Skyline-64_22_2_0_312\Skyline-64_22_2_0_312" no longer exists.

That error message is also talking about Skyline version "", which is a fairly old version. Is that the same version of Skyline that you get when you launch Skyline from the Start Menu?

It is possible that you have more than one version of Skyline installed on your computer right now.
You can use the "Programs and Features" section to see a list of programs installed on your computer.
Could you maybe send us a screenshot of what the "Programs and Features" list in Control Panel looks like? That might give us another clue about what might be going wrong on your computer.
-- Nick