Problem with importing msfragger output into skyline

Problem with importing msfragger output into skyline jdemeter  2023-08-03 10:31


I am trying to import peptide search results from msfragger into skyline (timstof pro, dda). This process used to work with the pep.xml, mgf and .d files, but now it stopped working and I get an error message (see attachment) of not finding the appropriate source files. When I use mzML with the pep.xml files, the library is generated fine, but the peaks are not imported correctly (see second attachment). I tried this using the latest skyline and skyline-daily with the same result.

Any help would be appreciated.

Thank you,

Nick Shulman responded:  2023-08-03 10:55
The error is telling you that it tried to find a file whose name starts with "073123-Minas_DMSO2_Slot1-4_1_14447_calibrated" and whose name ends with any of a number of possible endings including "_calibrated.mgf", ".mzML", etc.

What files do you have in the folder "F:\230831_minus". Is there a file there named "Minas_DMSO2_Slot1-4_1_14447_calibrated.mgf"?

If you do not have a file with that name, but you do have other .mgf files, you might be able to fix things by copying one of those other .mgf files to the name "Minas_DMSO2_Slot1-4_1_14447_calibrated.mgf".

We used to have a bug where BiblioSpec would be trying to find a file named "Minas_DMSO2_Slot1-4_1_14447_calibrated_calibrated.mgf", where the "_calibrated" is repeated, but we fixed that in Skyline-daily back in February. There is some information about the double "_calibrated_calibrated" in filenames in the following support request:

If you would like, you could zip up all of the files that you have in the folder "F:\230831_minus" and upload them here:
and we could try to figure out what is going on.
-- Nick
Nick Shulman responded:  2023-08-03 12:40

Thank you for uploading your .zip file.
If you copy the file "073123-Minas_DMSO1_Slot1-3_1_14445_uncalibrated.mgf" to the name "073123-Minas_DMSO1_Slot1-3_1_14445_calibrated_calibrated.mgf" then you will be able to successfully import peptide search results.

I am not sure whether it is a bug that the file needs to be named with "_calibrated" repeated in the filename.

By the way, I noticed that there were a couple of other files in there where "calibrated" was misspelled "caliberated".
-- Nick