MPP Report doesn't work after upgrade to 22.2

MPP Report doesn't work after upgrade to 22.2 denina simmons  2023-07-08 17:55

Hi there,

I am processing my first set of data since I upgraded to 22.2.

I use the MPPreport external tool to export my DDA results, and the tool no longer works. I have attached a screenshot of the error string from the "immediate window".

Can this be repaired? I am trying to find a different way to export my results, and I tried to export report from the file menu, and it sort of works, only my protein groups are not rolled up together, and I am not sure if there is a way to fix that? Or just to fix the MPP report external tool?



Nick Shulman responded:  2023-07-08 18:37
I do not know what might be going wrong but if you send us your Skyline document we can try to figure it out.

In Skyline you can use the menu item:
File > Share
to create a .zip file containing your Skyline document and supporting files including extracted chromatograms.

If that .zip file is less than 50MB you can attach it to this support request.

You can upload larger files here:
denina simmons responded:  2023-07-08 19:23
Thanks Nick.

By the way, I thought I was the only crazy person working late on a Saturday (I guess on the west coast it's not late, but it is a weekend!).

Okay, so I am on my way home to go to sleep now, but I uploaded a few files (two were larger than 50 MB, so I uploaded everything to the file sharing link you gave me): - this is the recent file with which I cannot export an MPPreport - this is a file I made using an older version (maybe 20?) that I just opened and tested - and I could get the MPPreport with this file
liver proteins 22_2 test.txt - this is the MPPreport I exported from the file made using an earlier version (described in the line above)

As far as I know I followed the same steps and workflow ... (DDA import) but there were a few slightly different options and settings in the newer version which I think required me to make a couple of minor changes regarding protein groups.

Thanks again
Nick Shulman responded:  2023-07-08 20:37

Thank you for sending those files.

The MPPReport external tool is choking on a protein description which has multiple lines in it.

Skyline 22.2 added a new feature "Protein groups". Protein Groups can be created using the menu item "Refine > Associate Proteins", and there is also a page related to protein groups in the "File > Import > Peptide Search" wizard.

When you create a protein group, the description ends up being multiple lines, such as:

prostacyclin synthase [Pimephales promelas]
7-alpha-hydroxycholest-4-en-3-one 12-alpha-hydroxylase [Pimephales promelas]
7-alpha-hydroxycholest-4-en-3-one 12-alpha-hydroxylase [Pimephales promelas]
prostacyclin synthase [Pimephales promelas]

Unfortunately, the MPPReport external tool has a small bug in it, and chokes on CSV fields that have line breaks in them.

We will probably be able to fix this bug in the MPPReport external tool and upload a fixed version of that tool to the Skyline Tool Store in a couple of days.

In the meantime, I think you can probably fix your document by using the menu item:
Refine > Associate Proteins
and uncheck the checkbox that says "Create protein groups".
-- Nick

denina simmons responded:  2023-07-10 09:33

Hi Nick

We tested the fix you suggested (to uncheck the box that says "create protein groups") and now the MPP report only exports one protein.

(see attached screen shot "new library peptide groupings" and export file Mucus_2_final.txt)

Also, we can export something that looks sort of like the MPP report tool would provide, but there are extra rows for each precursor charge (M, M+1, and M+2) (see attached screenshot called "export MPP report.png" for a visual)

We can probably clean the data in excel - but there are also extra rows for each peptide in proteins with multiple peptides. (see attached file called "final mucus export 2.csv")

If I wanted to use this file, how would I consolidate the extra rows? Would I take the average, sum, or ... something else? I was thinking average for the precursors, and maximum for the peptides?



Nick Shulman responded:  2023-07-10 14:06
Here is a fixed version of the MPPReport external tool.
You can install it in Skyline by downloading the attached file "".
Then, in Skyline, you can use the menu item:
File > External Tools
and then push the "Add" button and choose "From File" from the dropdown and then point Skyline at the .zip file you downloaded.

This fixed version of the tool will not choke on line breaks in the protein descriptions.

It is likely that this tool still will not produce the correct results for you. I am not sure exactly what you end up doing with the MPPReport.txt that you create, and whether the next thing that you need to feed that file to can handle line breaks in protein descriptions.

Let me know if I need to change the tool so that it gets rid of the line breaks in the protein descriptions. If I do need to fix that too, then I will probably make it so that the tool replaces those line breaks with maybe semicolons.

-- Nick
denina simmons responded:  2023-07-17 08:31
Hi Nick,

I am sorry that it took me a week to get back to this.

It looks like the fixed version worked well enough for our purposes!

Thanks :-)