Error parsing polarity type with SIM acquisition on Agilent 6490

Error parsing polarity type with SIM acquisition on Agilent 6490 oriane strassel  2023-05-10 04:33

Dear Skyline teams,
I’m analyzing some small molecules in SIM mode acquisition with an Agilent QQQ 6490, with polarity switching. I have this error when I try to process the data:
Failed importing results file 'C:\Users\strassel\Desktop\RKF\DATA_TestColumns\20230510_Biphenyl_OS_MIX1SIM.d'.
[translateAsPolarityType] Error parsing polarity type. (see screenshot attached)
I’ve tried to convert it with MSConvert using the commandline : msconvert -z --ignoreUnknownInstrumentError
But due to accessibility issues I wasn’t able to change the file.
Is there another possiblity to process this type of data? I didn't have any trouble processing fullscan acquisition with polarity switching.
Thank you and have a nice day !
Oriane Strassel

oriane strassel responded:  2023-05-10 05:14

Update information: I run an SIM acquisition only in positive mode, and I still got the same error when trying to process

Brian Pratt responded:  2023-05-10 07:18

This is highly unusual. Can you provide a copy of the file?

Brian Pratt

oriane strassel responded:  2023-05-10 07:35

Thank you for your fast answer, I just uploaded the 2 files on the file sharing folder

Brian Pratt responded:  2023-05-10 10:24

This is an interesting one! The error happens as we try to read the first chromatogram after the TIC. It's declared as having polarity "mixed" - we're only used to seeing positive or negative. I'm not sure what that would even mean - and there's no way to describe that in mzML - what does it look like when viewed in Agilent software?

Brian Pratt responded:  2023-05-10 11:26

In the meantime,

msconvert --continueOnError -z D:\data\Oriane\20230510_Biphenyl_OS_MIX1SIM.d

should produce a usable mzML file if you don't care about the chromatograms.

oriane strassel responded:  2023-05-10 23:12

Hi Brian,
Data on MassHunter seems fine (see screenshot attached)
Unfortunately I wasn't able to change the file using msconvert, I still got this accessibility issue (access denied)

Brian Pratt responded:  2023-05-11 11:53

I'm not sure what you mean by accessibility issues, but that sounds like you probably just need to tell msconvert to write to a different folder.