Error: No spectra were found for the new library

Error: No spectra were found for the new library Jess  2023-04-03

I am doing proteomic work and wanting to build a peptide spectral library using .dat files from Mascot. My software and system specifications are:

Skyline (64-bit) (28f9b9301)
Windows 10 Pro
Intel(R) Xeon(R) CPU E5-2660 v3 @ 2.60GHz

I generated mgf files from MZML files using MSConvertGUI (64-bit). My Mascot peptide searches have thousands of results. When I go into Skyline to build a spectral library, I go Settings>Peptide Settings>Library>Build. I choose my output path, and add my .dat files. Skyline then returns the error message "ERROR: no spectra were found for the new library".

I have attached 3 screenshots for 3 different instances where I received the error messages, described below:

  1. First error message after uploading my .dat files to build a peptide spectral library.

  2. After looking at different support threads on here, I tried converting my MZML files to mgfs again, this time making sure TPP compatibility was selected. I did a test search on Mascot with 1 mgf file, with over 1000 peptides being identified. To get my .dat file, I clicked "save link as" and changed the file name to end in .dat. This error message came after I uploaded that singular dat file.

  3. I thought there was an error in my dat file based on how I was exporting. Using the same TPP compatible mgf from above, I went into the search result report on Mascot and created a dat file by specifying "Export format: Mascot DAT file" and clicking Export Search Results. I did not change any file names and still got a Skyline error.

Can anyone tell me how to fix this issue? Is it a problem with my DAT file, or a problem with how I am generating my spectral library in Skyline?

Nick Shulman responded:  2023-04-03
Usually the cause of "No spectra were found for the new library" is that the spectrum IDs in the peptide search results are in a different format than what can be found in the file that BiblioSpec is looking for the spectra in.
However, with .dat files, there is no separate spectrum file, so I don't think it's possible for there to be a mismatch in spectrum id formats.

It is possible that none of the PSMs in your .dat file are good enough to be included in the library. You might be able to successfully build a spectral library if you set the cutoff score to the worst possible value (I am not sure what to set the score threshold to for .dat files in order to let in all spectra. It might be "0" or "1" or maybe even "100")

If that does not work then you should send us your .dat file.
Files which are less than 50MB can be attached to this support request.
You can upload larger files here:

-- Nick
Jess responded:  2023-04-03
Hi Nick,

I have tried changing the threshold to 0 and to 1, no luck. Same errors being reported.
I have uploaded one DAT file to the link you provided. It is called F001441.dat. If I can get the spectral libraries to work, I would be uploading 12 DAT files for 12 different searches to generate one spectral library. I appreciate any advice you can give me.