Issue with importing DIA-NN speclib

Issue with importing DIA-NN speclib joshuasmith  2023-03-06 11:20

Hi Skyline team,

I know this issue has been in the forums before (, but I tried the suggestions in that post and I still seem to be having issues.

Basically, I created a spectral library of a basic yeast search with DIA-NN and am trying to import into Skyline. I have moved the speclib and accompanying tsv file to their own folder, so that they are in the same directory and there isn't any confusion on which tsv to import. However, I am getting an error stating that Skyline cannot find the accompanying tsv file. See attached ppt for screenshots. I can upload the speclib and tsv if you'd like.

I'm running Skyline Any advice?


Nick Shulman responded:  2023-03-06 13:39
When BiblioSpec is looking for the report csv file, BiblioSpec looks at the contents of the file.

If the CSV file does not have some columns with the names "Precursor.Id", "Q.Value" and "RT" then BiblioSpec pretends the file isn't there and keeps looking for a file with a predicted name and the required set of columns.

If you upload your files we can take a look and figure out what is going wrong.
If they are less than 50MB you can attach them to this support request. Or, you might want to zip them up into a big zip file and upload them here:
-- Nick
joshuasmith responded:  2023-03-06 13:53
Thanks, I've attached the two files in a zipped folder.
Nick Shulman responded:  2023-03-06 15:07
Thanks for uploading the files "YeastDIALibrary.tsv.speclib" and "YeastDIALibrary.tsv".

This is what the first line of "YeastDIALibrary.tsv" looks like:
FileName    PrecursorMz    ProductMz    Tr_recalibrated    IonMobility    transition_name    LibraryIntensity    transition_group_id    decoy    PeptideSequence    Proteotypic    QValue    PGQValue    Ms1ProfileCorr    ProteinGroup    ProteinName    Genes    FullUniModPeptideName    ModifiedPeptide    PrecursorCharge    PeptideGroupLabel    UniprotID    NTerm    CTerm    FragmentType    FragmentCharge    FragmentSeriesNumber    FragmentLossType    ExcludeFromAssay    PTM.Informative    PTM.Specific    PTM.Localising    BestPTMQValue    PTMSiteConfidence

That file does not have columns "Precursor.Id" or "RT" so BiblioSpec knows that it is not the report TSV file that it is supposed to find.
Do you have a TSV file somewhere which does have columns "Precursor.Id", "Q.Value" and "RT"?
-- Nick
joshuasmith responded:  2023-03-06 15:30
Thanks for looking into this. I'm attaching another file from the DIA-NN output that does have those columns. I am not sure it's the "correct" one that Skyline needs in conjunction with the speclib file, though - it doesn't have the same file name structure as the speclib, as Skyline seemed to indicate it needed.

Note I'm just using the output directly from DIA-NN, so I haven't changed any files or filenames.
Nick Shulman responded:  2023-03-06 16:29
If you change the name of that file from "report.tsv" to "YeastDIALibrary.tsv" then you will be able to successfully import those search results into Skyline.
It ends up being a very nice looking spectral library, so that does seem to be what you should do.

Did that "report.tsv" file end up in the same folder as "YeastDIALibrary.tsv.speclib"? Maybe we should change BiblioSpec so that it also looks for "report.tsv".
(I am not the expert on BiblioSpec so I actually have no idea how things are supposed to work).
-- Nick
joshuasmith responded:  2023-03-07 08:33
Thanks, that seemed to have worked. Yes, those files were both in the same folder. See attached for the filenames of all the output that got put into the folder. I only specified the filenames for the files that begin with "YeastDIALibrary", everything else is automatically generated by DIA-NN.