Skyline daily closes upon import timsTOF DIAPASEF runs

Skyline daily closes upon import timsTOF DIAPASEF runs an.staes  2023-02-23 05:05


When importing timsTOF DIAPASEF runs in skyline daily, skyline closes down. Any idea what is going on?
List of peptides is not huge, only the promega isotopologues.....

Thank you for looking into this!

Kind regards,

Nick Shulman responded:  2023-02-23 05:57
Sometimes when Skyline abruptly exits like that, then the next time that you open Skyline it shows you an error message and gives you the opportunity to send us an error report. You would not happen to be seeing anything like that?

Alternatively, it might be necessary for you to send us your files so that we can try to reproduce this problem.
I am not sure exactly which files we need-- probably we would need your Skyline document and one or more of your Bruker .d data folders.

In Skyline you can use the menu item:
File > Share
to create a .zip file containing your Skyline document and supporting files including extracted chromatograms and spectral libraries.

You should send us that .zip file, and you should also zip up one or more of the .d data folders that you are having trouble importing results from.

You can upload those files here:
-- Nick
an.staes responded:  2023-02-24 01:43
Dear Nick,

Thank you for your swift reply. I tried with the newet daily released yesterday (, but the problem remains. I tried to create a shared document, but this failed with the error "Not a valid Win32 File Time". Have no idea what to do....
I did upload a .d file zipped that gives a problem (T00774_QC03_EvoAurEl1_5ngnoSens_S2-E2_1_806.d.7z)

Thank you for your help!

Kind regards,
Nick Shulman responded:  2023-02-25 19:15
Thank you for uploading that .7z file containing your .d folder.
I think the problem is probably that the file "analysis.tdf" in there is corrupted, and nothing will be able to read that data.
It looks like things are dying when the Bruker code asks Sqlite to execute the query "select count(*) from DiaFrameMsMsInfo".

When I try to use the commandline program "sqlite3.exe" to execute the same query, I get the message "Runtime error: database disk image is malformed (11)"

I will ask around and see whether there is anything that can be done to improve the behavior here. It probably will not be possible for Skyline to ever read this data but we can probably make it so that Skyline does not abruptly exit.
-- Nick
an.staes responded:  2023-02-26 12:56
Dear Nick,

Thank you for this very useful analysis! I'll try further on what the Bruker software does with this, and will notify Bruker about it.

Kind regards,