FATAL: An exception occurred: 'c' is not a valid amino acid

FATAL: An exception occurred: 'c' is not a valid amino acid jalbin28068  2023-02-08 06:38

I'm trying to import DDA files and complete a search within Skyline. I can get the search to complete sometimes with MSAmanda, but when I use MSFragger, I usually get the error, "FATAL: An exception occurred: 'c' is not a valid amino acid." I'm not sure where this is coming from. There are no "c" in my fasta; I'm searching a peptide library that lacks cysteines, and I have checked / resaved-as / etc. the fasta without effect. I think it might be related to modifications because I could get MSFragger to complete when I set the maximum variable modifications to 0 (though there were few identified peptides when I tried that compared with when I have searched in MSAmanda or MaxQuant). My library has fixed C-terminal amidation, but otherwise should not have any modifications. I've tried making a custom C-terminal amidation modification instead of using the built-in modification without effect. I've attached the full MSFragger log from my latest attempt if that would be helpful. Does anyone know where this error is coming from an how to fix it?

Nick Shulman responded:  2023-02-08 08:01
Can you send us the files "2_site_library_23_02_08.fasta" and "decoy_2_site_library_23_02_08.fasta"?
If those files are less than 50MB you can attach them to this support request.
You can upload larger files here:

My guess would be that there really is a "c" in one of those two fasta files.

If I do not find a "c" in there, then you would need to send me your Skyline document and the raw files that you searched.
In Skyline you can use the menu item:
File > Share
to create a .zip file containing your Skyline document and supporting files.
You can upload that zip file and your raw files to that same spot:

It might also be helpful if you could provide screenshots of the pages of the Import Peptide Search wizard so I know what settings you used.
-- Nick
jalbin28068 responded:  2023-02-08 08:16
I've attached the fasta files. I hadn't thought to check the decoy that Skyline generates; it does add the first line of the decoys onto the end sequence of the last sequence in the input fasta, resulting in, "FFKRIVQRYYDFLR>DECOY_Seq_1". I'm not sure whether that could do it.
Nick Shulman responded:  2023-02-08 08:55
Yes, there is no "c" in those FASTA files.

Can you send me your Skyline document and the six .raw files ("314_23_01_20_1_JSA482.raw" etc) that you searched?

You can use the Skyline menu item "File > Share" to create a .sky.zip and you can upload that .sky.zip and the six .raw files here:
-- Nick
Nick Shulman responded:  2023-02-08 09:27
I noticed the following line in the log file that you first attached to this support request:
variable_mod_01 = -0.984016 c^ 2
I wonder if that could be the cause of the problem (I don't know what msfragger variable modifications are supposed to look like, but that does have a "c" in it)
-- Nick
jalbin28068 responded:  2023-02-08 09:57
I have uploaded these now. It might well be something associated with the modifications, but I'm not sure how to modify them to avoid the problem. I tried using C-terminal amidation both as the built-in fixed modification and as a custom fixed modification and got the same error. Though, as I said, it did go to completion (with few identifications) if I didn't allow modifications.
Nick Shulman responded:  2023-02-08 11:47
I think you sent me a different Skyline document than the one into which you were trying to import the peptide search.
The document that you uploaded is here:
That document has the Enzyme set to "Trypsin" and does not have any modifications other than the default "Carbamidomethyl (C)".
The MSFragger output that you initially attached is using an enzyme called "Met" and seems to have different modifications.

Can you send me the Skyline document that you were using when you go this error?
-- Nick
jalbin28068 responded:  2023-02-09 06:30
I am unable to save the Skyline document with the associated settings because the search will not complete. I've uploaded a PDF with snips of what I'm entering in all the settings, which reproduces the error message.
Nick Shulman responded:  2023-02-09 08:18
Thank you for uploading that .pdf file with the screenshots of the settings that you used in the Import Peptide Search wizard.
I am able to reproduce the error that you are seeing.

The MSFragger search completes successfully, and the Percolator step complains about "c" not being a valid amino acid.

I will try to find someone who can figure out what is going wrong.
-- Nick
Matt Chambers responded:  2023-02-10 07:21
Hi jalbin,

Try the Skyline-daily.exe in this zip file and let me know if the problem persists:

Skyline doesn't support terminal mods, so it'll look like the mods are on the terminal AAs.
jalbin28068 responded:  2023-02-10 09:02
I added a custom modification to put an amide on the C-terminal arginines, which is every peptide in this group. MSFragger returns an appropriate number of identifications, and I can build a spectral library. What was the fix, so I can understand how to handle this in regular Skyline? Do I need to make a custom modification like the one above (and generally only search terminal modifications associated with a specific amino acid)? Or just use Skyline Daily for now? Thank you.
Matt Chambers responded:  2023-02-10 09:24
MSFragger writes Percolator PIN files with PEPTIDEKc[mass] to indicate the mod is on the C-terminal. I just trim out the 'c' to make it look like a mod on the K. I'm not actually sure that will work if there's also a mod on the K: PEPTIDEK[mass]c[mass]. I should test that. :) I had already added handling the N-terminal mods (n[mass]PEPTIDEK).