Finding unique peptides

Finding unique peptides prajita  2023-01-23

I have 15-20 peptides that I would like to confirm specificity against Human proteome. I took following steps:
Settings->Peptide setting->Digestion->background proteome
and have added human Fasta sequence.
Then I took following steps:
Edit-> Unique peptides
Under this option, I could see some peptides that have blue checks meaning they are not unique. However, if I keep scrolling I see a limited number of proteins in human. I am not sure if this option is covering all the human proteins. Can you please provide an insight to this?

Nick Shulman responded:  2023-01-23
I don't remember exactly how this feature is supposed to work but if you send us your Skyline document we could tell you what is going on.

In Skyline you can use the menu item:
File > Share
to create a .zip file containing your Skyline document and supporting files including background proteome.

If that .zip file is less than 50MB you can attach it to this support request. You can upload larger files here:

It might also be helpful if you could show us a screenshot of what you are looking at.
-- Nick
prajita responded:  2023-01-23
Hello Nick,
I have uploaded the file. The file is names Protein E.
Any help is appreciated.
Nick Shulman responded:  2023-01-23
Thank you for uploading that zip file. It seems to be missing the background proteome file "Humanproteome.protdb".
It is always a good idea to use the menu item in Skyline "File > Share" to create a file because Skyline will make sure that all of the necessary files are included in the

Could you send me either "Humanproteome.protdb" or a new
-- Nick
prajita responded:  2023-01-23
Hello Nick,
I re-uploaded the file.
Nick Shulman responded:  2023-01-23
Thank you for uploading that

The behavior that you are seeing is caused by the fact that the "Edit > Unique Peptides" dialog and the "Settings > Peptide Settings > Digestion > Enforce peptide uniqueness by" feature have different definitions of what it means for a peptide to appear in a particular protein.

The "Edit > Unique Peptides" dialog shows you all of the proteins which contain that peptide sequence, regardless of whether that peptide is a tryptic peptide within that protein.

The "Enforce peptide uniqueness" feature only considers that a peptide sequence can be found in a particular protein if the enzyme could produce that peptide from the protein sequence. According to this criteria, the peptide sequence "QVTLR" is a unique peptide because there is only one protein for which that is a tryptic peptide. That is the one protein sequence where "QVTLR" is at the start of the protein sequence. In all the other protein sequences, "QVTLR" is found in the of the protein sequence, and would not be cleavable by Trypsin.

What is your opinion of the uniqueness of the peptide "QVTLR"? Would you consider that to be a unique peptide because there is only one protein in the proteome where that is a tryptic peptide? Or would you consider it non unique since the sequence can be found in other proteins even though it could not be produced from them by digesting with Trypsin?

It could be that we should add a checkbox to the "Edit > Unique Peptides" dialog to control whether to only look for tryptic peptides.

Let us know how you would like these features to work.
-- Nick
prajita responded:  2023-01-24
Hello Nick,

Thank you for your response.

I want to check uniqueness created due to tryptic digest. When I check Edit > Unique Peptides, QVTLR is blue checked under multiple proteins. I just want to make sure I understand the purpose of blue check?

For my project, I care about uniqueness created due to tryptic digest. I will be using a peptide absent in human proteome for quantitation purposes. Please suggest me what are the best features to implement.
Nick Shulman responded:  2023-01-24
It sounds like you would like to exclude all of the peptides that can be found in the background proteome.
Skyline does not have this feature: Skyline only gives you the ability to exclude peptides which can be found more than once in the background proteome.

I think you can achieve the behavior that you want by adding all of the peptides that you are thinking about using to the background proteome.
That is, you could create a FASTA file which has all of your peptides:

Add that FASTA file to the background proteome file that you already have.
Then, when Skyline is excluding non-unique peptides, it will exclude all peptides which can be found in more than one "protein", which means that it will exclude peptides which could be found in both the human proteome and the extra fasta file you added.
-- Nick
prajita responded:  2023-01-24
My background proteome is entire human proteome. The column that are displayed, are not all the proteins in human (~81,837 proteins). Is the software finding uniqueness against the whole proteome because the number of columns displayed do not reflect that?
Nick Shulman responded:  2023-01-24
In the Unique Peptides dialog every column will have at least one checkmark in it.
Skyline is only showing you proteins which contain at least one peptide from the selected proteins in the Targets tree.
-- Nick
prajita responded:  2023-01-24
Thank you again.

After I have done Include unique only> proteins, I received all the unique peptides. Is there a way to generate a report format of this output?