Skyline Batch error if decimal symbol is a comma

Skyline Batch error if decimal symbol is a comma roman sakson  2023-01-06 13:29

Hello Skyline team,

I would like to report an error issue that might not have been mentioned here yet.

I am working with Skyline Batch, where I shared a bcfg file and tried to import it back into Skyline Batch on a different computer. Both systems were using Skyline Batch While trying to import the bcfg file I got an error complaining that the version of my file is newer than the version of the program, which was, of course, wrong (see screenshot).

Since the version number look weird with a comma in the error message, I checked the windows 10 region settings and realized that the decimal symbol on my German system was set as comma and the digit grouping symbol was set as dot. Reversing this in thw windows settings resolved the issue. I am not sure, whether something can or should be done here but I thought I better report this.

Thank you for this great software,

Nick Shulman responded:  2023-01-06 14:01
Can you attach that file "Roman_Test.bcfg"? That will help us track down which line of code is incorrectly writing out that number.

This bug seems to have been reported before, but we never actually fixed it:
-- Nick
roman sakson responded:  2023-01-06 14:16
Hi Nick,

ups, sorry, I missed that one. Hopefully, the bcfg file is of any help.

Nick Shulman responded:  2023-01-08 16:47
The problem of not being able to read the version number on computers with different decimal separators was fixed in May 2022.
If you use a newer version of Skyline Batch I would expect that you would not have any problems sharing .bcfg files with other people.

-- Nick
roman sakson responded:  2023-01-09 16:35
What would be the newest version of Skyline Batch today? This page here might be outdated:

Here, I am being offered the version

When I run my Skyline Batch, it displays version on top, as you can see in my screenshot above (not quite sure where I downloaded this version from, I think this was a link somewhere in a support thread). This is the version that still seems to have the bug that I described. I am afraid that I do not know where to get a newer version from...

Thank you for your help,
Nick Shulman responded:  2023-01-09 16:54
Oops. I had no idea that we haven't released a new Skyline Batch in over a year.

Here's a build of Skyline Batch which I made on my computer today.
You can download the .zip file, unzip it (If using Windows Explorer to unzip it, before you unzip it you should right-click on the .zip file in Windows Explorer, and choose "Properties" and check the "unblock" checkbox), and then run "setup.exe" in the unzipped folder.

I will ask around and find out who is responsible for releasing new Skyline Batch versions.
(Also, let me know if this new Skyline Batch does not fix your problem or if you notice any other issues)
-- Nick
roman sakson responded:  2023-01-09 16:59
Great, thank you, I will test this one!