Import FASTA file

Import FASTA file prajita  2022-12-19 14:55


Can you please let me know to import FASTA file is this the only way:
Or is there any other way?

Nick Shulman responded:  2022-12-19 15:47
There are a couple of ways of getting a FASTA file into your Skyline document.
File > Import > FASTA
there is also:
Edit > Insert > FASTA

Also, if you do "File > Import > Peptide Search", at some point it asks you to provide a FASTA file, and the peptides from that FASTA file get added to your document.

If you have a spectral library, then a good way to get those peptides into your document is with:
View > Spectral Libraries
and then press the "Add All Peptides" button.
Then, after you have added the peptides to your document you can tell Skyline to group those peptides by the proteins they belong to using the menu item:
Refine > Associate Proteins

I am not sure I understood your question but I hope this helped.
-- Nick
prajita responded:  2022-12-19 21:01
Hello Nick,

Thank you for your response.That helped.

I have one more question:

After I import a fasta sequences, peptides are displayed on the left most column. For peptides when you hit + next to it, shows the m/z. Some especially longer peptides are not showing m/z and don't have + next to them. Can you please tell me why this would happen?
Nick Shulman responded:  2022-12-19 21:31
The peptides without a plus sign are ones whose m/z is outside of the range of the instrument.

You probably should go to:
Settings > Transition Settings > Filter
and put some more numbers (separated by commas) in the "Precursor charges" textbox.

Skyline is probably only giving you charge 2 precursors, but if you are interested in bigger peptides you should put some more numbers in that list.
You will probably also want to change the set of product ion charges too.

-- Nick
prajita responded:  2022-12-20 13:15
Thank you so much.
prajita responded:  2023-01-04 12:02
After a fasta sequences is uploaded, peptides are displayed on the left most column. The first 2-3 are not showing up in the list and it is starting from position 35-40. Can you please let me know what settings I am missing?
Nick Shulman responded:  2023-01-04 15:45
You probably need to change the "Exclude N-terminal AAs" setting at "Settings > Peptide Settings > Filter".
The default value of that setting is "25" which would cause you to be missing the first few peptides in each protein like you are describing.
-- Nick
prajita responded:  2023-01-10 15:47
Thank you for the response. Is that the default value because of N-end rule not good for quantitation purposes?