Problem with Import or Search of TMT Labeled Peptides

support
Problem with Import or Search of TMT Labeled Peptides philip remes  2022-11-22
 

Hello,

I'm trying to build a library of Yeast peptides labeled with 11-Plex TMT, using Eclipse DDA MS2. I've tried doing this in several ways:

  1. Search the data in Proteome Discoverer, import the .pdResult files. There are 17k peptides with q-value < 0.01, however I'm not able to successfully import the results. We get the old, "Importing the FASTA did not create any protein targets".

  2. Search the data in Skyline. I tried using MSAmanda, and MS-GF+. There appears to be an error parsing the TMT modification string. I'm pretty sure that this is the string that Skyline supplied for that modification.

Based on this thread I made sure that there were a number of good targets in PD. I've had no trouble importing standard, unlabeled HeLa results from PD or searching them in Skyline, so it seems like the TMT modifications must be the issue. https://skyline.ms/announcements/home/support/thread.view?entityId=5a28316e-8430-1035-b2a7-e465a393b02f&_docid=thread%3A5a28316e-8430-1035-b2a7-e465a393b02f

I've uploaded the pdResult files, raw files, and Skyline files to the file sharing server with the name ForSkyline.zip. Could you have a look and see if the problem is on my end, or the Skyline end?

Thanks
Philip

 
 
Nick Shulman responded:  2022-11-22
Philip,

Can you send us the FASTA file that you used when you were importing the PD results into Skyline? I will try to figure out why Skyline did not want to add any peptides from that FASTA file to your document.

It looks like the error that you got when you did the MS-GF+ peptide search in Skyline was:
Error: Invalid Mass/Composition at line 6 in file tmp2779.tmp: H20C8C'4NN'O2, K, fix, any, TM6.

I do not know anything about MS-GF+, but maybe someone else on this support board can offer some insight about what might be going wrong there.

-- Nick
 
philip remes responded:  2022-11-22
Sure, here's the FASTA file. MSAmanda also wasn't able to find any peptides with how I've got the document set up. I updated the slides with the configuration and output from MSAmanda, which didn't crash on the TMT modification, but just couldn't find anything to import.

<\Philip>
 
Nick Shulman responded:  2022-11-22
The reason that Skyline refuses to add any peptides to your document when you do "File > Import > FASTA" is that "Ion types" at:
Settings > Transition Settings > Filter
is just "p", and does not include any types of fragments (e.g. y, b).
but also, at "Settings > Transition Settings > Library", it says "Pick 3 minimum product ions".

The problem is that Skyline is never able to find at least 3 product ions in any spectrum since Skyline has is not looking for any types of fragment.

You should go to:
Settings > Transition Settings > Library
and change the "minimum product ions" to zero.
(alternatively, you could change the "Ion Types" in the Transition Filter)

Then you will be able to do:
File > Import > FASTA
and get all the proteins and peptides you expect.

By the way, I imagine that the reason that MS-GF+ is choking on "H20C8C'4NN'O2" is that using apostrophes to indicate heavy isotopes is something that Skyline came up with and I don't think any peptide search engines understand it. We will probably need to fix Skyline so that it translates the chemical formulas of the modifications into something that the search engine would understand.
-- Nick
 
philip remes responded:  2022-11-22
Thanks for pointing out the transition filter problem with the PD import. I'm happy to have that way of getting the data into Skyline. I thought for a moment that this was also why the MSAmanda search didn't work, but in that case the transition settings were correct.

I had been hoping to compare the libraries built by DDA and DIA for these compounds, and I'd found Skyline pretty convenient for searching the DDA or DIA data for HeLa. I'll have to find some other way to search those data for now. Thanks!

Philip
 
Nick Shulman responded:  2022-11-22
Did the MS Amanda search work correctly, or is that something that we should look into?
If you want to see whether any peptides were found, you can go to:
View > Spectral Libraries
and see whether the .blib file which was created from the Import Peptide Search has any peptides in it (the .blib file created in this way will have the same name as the Skyline document).

By the way, using the "Add All" button on the Spectral Library Viewer is a different way that you can get peptides into your document if there's some reason that Import Fasta is not doing the right thing. After you get the peptides in your document use can use the "Refine > Associate Proteins" menu item to rearrange the peptide into their appropriate proteins.
-- Nick
 
philip remes responded:  2022-11-22
The last version of the PPT I attached shows what happens with the MSAmanda search. I've attached Skyline document from after the search completed. Good tip about viewing the Spectral libraries. There's only ~900 peptides in it, and none of them are TMT labeled. One hypothesis then is that either I've specified the TMT modifications incorrectly, with the second one being that MSAmanda did not know what to do with these mods and ignored them, instead of throwing an error like MS-GF+.