Can't connect to prosit server

support
Can't connect to prosit server sp807  2022-10-27
 

Everytime I try to conncet to the prosit server, it says "server unavailable".
I have updated my software to Skyline (64-bit) 22.2.0.255 (c99206313) but the same things happens.

Any way to fix this?

 
 
Nick Shulman responded:  2022-10-27
Prosit in Skyline seems to be working for me.

This might have been a temporary server problem that has been fixed by the Prosit people.

All versions of Skyline talk to the same Prosit server, which I believe is a machine located in Germany.
If things are still not working for you we can try to find someone to take a look at and may need to ask you for more details.
-- Nick
 
sp807 responded:  2022-10-28
Hi Nick,

The same thing is still happening for me.
Any ideas?
 
Nick Shulman responded:  2022-10-28
What do you see when you go to:
Tools > Options
and choose the "Prosit" tab?

If the "Intensity model" and "iRT model" dropdowns are blank, then you need to choose the first non-blank item in each list. Otherwise, it will say "Server unavailable".
I do not know why the Prosit settings in Skyline seem to start off in an unusable state requiring a selection to be made there (might be a bug).

Is that the behavior that you are seeing?
If that's not the behavior that you are seeing, could you post some screenshots of what things look like in your Skyline?
-- Nick
 
sp807 responded:  2022-10-28
I have attached a photo of what it is I'm seeing.
Thanks.
 
Nick Shulman responded:  2022-10-28

It is a mystery why this is working on my computer but not working on your computer.

Does Prosit work if you try to use Skyline on a different computer?

Have you tried rebooting your computer?

I wonder if this would work if your computer was on a different network, for instance if you turned your cell phone into a hotspot and had your computer connect to that Wi-Fi connection.

What do you see if you go to a Command Prompt and type "ping proteomicsdb.org"?

Here's what I see:

C:\>ping proteomicsdb.org

Pinging proteomicsdb.org [131.159.152.5] with 32 bytes of data:
Reply from 131.159.152.5: bytes=32 time=180ms TTL=47
...

(I do not know much about how to diagnose problems where computers cannot talk to each other, so, if these questions do not yield anything useful we might have to get someone who knows more to help)
-- Nick

 
Brendan MacLean responded:  2022-10-28

Hi all,
I do not understand this either. We saw the same issue during the recent Skyline-Online: Session 1. Several of the participants were unable to connect to Prosit. It is most likely a network issue between you and the Prosit server (proteomicsdb.org). Notice that we use port 8500 in connecting to the server. Perhaps for some reason port 8500 is no allowed somewhere between your computer and proteomicsdb.org, e.g. your computer firewall or your institution firewall.

So, while the "ping" that Nick suggests is an okay place to start, because proteomicsdb.org does respond to ping, it doesn't really tell you if you can get to port 8500 from your computer. A better option can be found on this page (had to Google it myself):

https://www.libe.net/en-ping-port

With it, I was able to check 8500 (and also 80 for normal HTTP and 443 for normal HTTPS), all 3 are open to my comptuer on proteomicsdb.org, but port 1000 is not:

PS C:\Users\brendanx> Test-NetConnection -computername proteomicsdb.org -port 8500

ComputerName     : proteomicsdb.org
RemoteAddress    : 131.159.152.5
RemotePort       : 8500
InterfaceAlias   : Ethernet
SourceAddress    : 128.208.10.70
TcpTestSucceeded : True


PS C:\Users\brendanx> Test-NetConnection -computername proteomicsdb.org -port 80

ComputerName     : proteomicsdb.org
RemoteAddress    : 131.159.152.5
RemotePort       : 80
InterfaceAlias   : Ethernet
SourceAddress    : 128.208.10.70
TcpTestSucceeded : True


PS C:\Users\brendanx> Test-NetConnection -computername proteomicsdb.org -port 443

ComputerName     : proteomicsdb.org
RemoteAddress    : 131.159.152.5
RemotePort       : 443
InterfaceAlias   : Ethernet
SourceAddress    : 128.208.10.70
TcpTestSucceeded : True


PS C:\Users\brendanx> Test-NetConnection -computername proteomicsdb.org -port 1000
WARNING: TCP connect to (131.159.152.5 : 1000) failed

ComputerName           : proteomicsdb.org
RemoteAddress          : 131.159.152.5
RemotePort             : 1000
InterfaceAlias         : Ethernet
SourceAddress          : 128.208.10.70
PingSucceeded          : True
PingReplyDetails (RTT) : 167 ms
TcpTestSucceeded       : False

Try this on your computer along with ping. I would be surprised if ping or ports 80 or 443 are blocked to you, but 8500 may be, and that would be a problem for Skyline trying to communicate with Prosit on proteomicsdb.org.

Armed with this information, you should also be able to approach an IT professional and clearly explain what you want (i.e. access to port 8500 on the proteomicsdb.org server). Hopefully, that would be enough for them to help expose that port on whatever is currently blocking it.

If you figure out what is blocking it and why, we would be interested in understanding that. It might enable us to approach the Prosit team and request a change that is more likely to work for more Skyline users.

Thanks for your post and the time you have taken to investigate this issue on your computer.

--Brendan

 
sp807 responded:  2022-10-31

Hi both,

Thank you for your replies!
I tried the hotspot suggestion with my phone and it worked!

Not sure why it wasn't working with my institution's wifi network.