Skyine-Daily failing due to application error thrown on Windows 2016

support
Skyine-Daily failing due to application error thrown on Windows 2016 hchandler  2022-10-22
 

Dear Skyline support team:

When launching Skyline-Daily or even trying to run the program, we are getting the same error that we have attached to this trouble ticket. We first thought that RAM was problematic as another product had taken so much, but even when the other program is not running and the server is rebooted to clear resident memory and caches, the error occurs. It states that the system did not have enough resources to complete the operation. The server is pretty beefy with 128GB of RAM, plus 2 Xeon 3.2GHz CPUs in an enterprise level Dell server running Windows 2016. The drives all have plenty of disk space (500GB or more) available, plus the NAS drives not only have plenty of free space, but the Network load does not reach above 10% utilization on the 1TB network interface. So not sure of the resources needed, other than we thought that the browser level was still using the old deprecated IE 11 ( we just installed Edge, but IE 11 is still on the system) and maybe the .NET needs to be updated (it is v4.8). So rather than guess at the issue, we are asking if you could read the error and determine the possible issue at hand.

Thank you for any help or assistance on this matter, in advance.

Sincerely,

Henry Chandler

 
 
Nick Shulman responded:  2022-10-22
This is the same error that was reported by a user here:
https://panoramaweb.org/home/support/announcements-thread.view?rowId=4810
There does not seem to be any useful information in that other post-- it appears that the error eventually went away and they moved on to some other issue.

The log file that you attached seems to be an error trying to run AutoQC (it looks like the error might be happening when AutoQC checks whether there is an update available).

It sounds like you are also saying that Skyline-daily does not work at all. Are you perhaps getting a different error when you just try to run Skyline-daily, perhaps by launching it from the Start Menu?
-- Nick
 
hchandler responded:  2022-10-26
Skyline fails on both itself and the daily update checks with the same error. Regardless of the method of starting the program it throws the same error. Is there an application log file that I can get to? I then maybe get some more information. I cannot have the software not function any longer. Are there any special dependencies for the software, like version of .NET, or JAVA or any other side libraries that the program uses to launch and run on?

-Henry
 
Nick Shulman responded:  2022-10-26
What error do you see when you try to start Skyline-daily? Can you post a picture of the error that you are seeing?
If I knew what that error message looked like, I might have some ideas about where to find more information.

Usually, with errors like this, the thing to do is to go into Control Panel, uninstall Skyline-daily, and then install it again from the website.

If you are not able to install Skyline the usual way, there are other ways:
1. The "unplugged" installer can be installed from here:
https://skyline.ms/wiki/home/software/Skyline/daily/page.view?name=install-disconnected-64
2. The Administrator installer (which installs to "C:\Program files\Skyline-daily" instead of inside of your user directory) can be installed from here:
https://skyline.ms/wiki/home/software/Skyline/daily/page.view?name=install-administrator-64

These alternative installers both have the limitation that they do not automatically check for updates.
-- Nick
 
hchandler responded:  2022-10-26
Nick,

The error experienced is the one I had attached to the trouble ticket. It is verbatim from the system when shown in a pop-up window. Our Proteomics Professor is still having issues with the system. The Skyline installation is the full version according to him.

- Henry
 
Nick Shulman responded:  2022-10-26
The error log that was attached to the original support request is from running a program called "AutoQC".
It is possible that you are seeing a very similar error when you try to run Skyline-daily by itself, but the log file would presumably contain "Skyline-daily" instead of "AutoQC".
AutoQC and Skyline are both ClickOnce applications, which means that they use Microsoft's self-updating installer process.

Sometimes all ClickOnce applications on the computer stop working, and it is necessary to delete the folder "AppData\Local\Apps\2.0" from your home directory. I do not know whether that is what is going on in this case. I am also not sure what sort of negative side effects there might be to deleting that folder from your computer if you have many ClickOnce applications installed.

There are some instructions about finding and deleting that 2.0 folder here:
https://skyline.ms/wiki/home/software/Skyline/page.view?name=tip_recover_install

Both AutoQC and Skyline install in a user's home directory. If you are unable to get Skyline working with the current user account, things might work better if you create a new Windows account on the same computer.
-- Nick
 
hchandler responded:  2022-10-26
So I suppose we should first uninstall and reinstall Skyline? If this does not work, then try the removal and recreation of OneClick? or Should we do the reverse? Uninstall and reinstall OneClick and then do the same to Skyline if that does not work?

- Henry
 
Brendan MacLean responded:  2022-10-28

Hi Henry,
Let me just extract the relevant part from the log you posted:

OPERATION PROGRESS STATUS
* [10/21/2022 2:28:23 PM] : Activation of C:\Users\pd_server\AppData\Roaming\Microsoft\Internet Explorer\Quick Launch\User Pinned\TaskBar\AutoQC.appref-ms| has started.
* [10/21/2022 2:28:24 PM] : Performing necessary update check as specified by the deployment.

ERROR DETAILS
Following errors were detected during this operation.
* [10/21/2022 2:28:33 PM] System.Runtime.InteropServices.COMException
- Insufficient system resources exist to complete the requested service. (Exception from HRESULT: 0x800705AA)

So, as Nick is saying, the problem is happening during start-up of AutoQC (User Pinned\TaskBar\AutoQC.appref-ms), and it seems to have something to do with system resources. I Googled that error message and ended up on this page:

https://answers.microsoft.com/en-us/windows/forum/all/error-code-0x800705aa-and-insufficient-system/06fdc4fd-a2fe-4c11-b1ae-d60acef18caa

It has some suggestions, like turning off your antivirus software, etc.

This is not an issue with Skyline, or probably really even AutoQC, but something about your system configuration which you will need to work out with the help of IT or Google searching.

Hope this at least points you in a more productive direction to solving this issue.

--Brendan