Spectral library quality control data

support
Spectral library quality control data cervenka  2022-09-29
 

Dear Brendan,
I would like to ask you if there is any way how to get data about spectral library and its quality for QC, e.g. how many y ions/b ions/PMS/peptides/shared peptides/peptides with PTM(s)/proteins the library contains, what is the average mass error and spectra quality etc.? Basically something as the DIALib-QC tool does (http://www.swathatlas.org/DIALibQC.php). I tried to export library in format for Spectronaut (Skyline Schema for exporting Spectronaut compatible libraries - https://biognosys.com/resources/spectronaut-further-user-resources/) and used the DIALib-QC tool, but I was not able to get any results.

I found slightly similar question in the forum - https://skyline.ms/announcements/home/support/thread.view?entityId=e2b45ef9-e45b-1035-96fc-e465a39343b4&_docid=thread%3Ae2b45ef9-e45b-1035-96fc-e465a39343b4 Do you think that such apporach would also work for me (Skyline 22.2), please?

Thank you very much for your help!

Jakub

 
 
Nick Shulman responded:  2022-10-03
If you want to know which transitions were detected in a spectral library, one way to do this would be to tell Skyline to add all of the peptides to your document and then see which transitions Skyline gives you.

That is, you would go to:
View > Spectral Libraries
and then press the "Add All" button in the Spectral Library Explorer

You should make sure that the setting "If a library spectrum is available pick its most intense ions" is checked at "Settings > Transition Settings > Library".
Also, set "Pick X product ions" to a high number so you Skyline will add all of the transitions that it finds to your document.

You tell Skyline which transitions to look for (b, y ions etc) using the filter settings at "Settings > Transition Settings > Filter".

After you have done this, you would use the "Transitions" report in the Document Grid to see what transitions you got.
You can learn more about the Document Grid in the Custom Reports tutorial:
https://skyline.ms/wiki/home/software/Skyline/page.view?name=tutorial_custom_reports

I imagine that there may be much better ways to do this which involve tools designed to look at your specific type of peptide search results. A .blib spectral library does not really contain any information about which transitions were seen. What it does has is a list of m/z and intensity values. Skyline then uses its own knowledge of peptide fragment m/z's to decide which fragments can be seen in that m/z and intensity list.
-- Nick
 
Brendan MacLean responded:  2022-10-03

Hi Jakub,
Thanks for posting your request to the Skyline support board.

Because we now have so many things that various people consider a "spectral library" or a "chromatogram library" or an "assay library", I am going to need to get clarification from you on what the source of the "library" is and that you do indeed want these data for, say, what Skyline displays in the "Library Match" view (or the View > Spectral Libraries form titled "Spectral Library Explorer").

I guess it seems like that is what you mean, since the DIALib-QC tool you mention even talks about Prosit predicted spectra. Have you asked why they are not supporting the BiblioSpec (*.blib) format, which is what Skyline generally uses? Surprised the reviewers of the paper didn't request that. It seems like a very prevalent library type to just ignore. I know a few of the people on the paper. I will ask if they might have any interest.

Thanks for pointing all of this out. We may be able to provide more information about the "Library Match" spectra in Skyline reports. We are actively working on adding more spectrum information to the .blib files and being able to show it in a new property page we will show with all of our spectrum viewers.

--Brendan

 
Brendan MacLean responded:  2022-10-03

Hi Jakub and Nick,
Yes, I think what Nick is suggesting could work, but I would use File > Import > Peptide Search - DIA instead, picking the entire ion series ("ion 1" to "last ion") and no limit on the number fragment ions, and then choose the FASTA file you want to use to associate proteins with the spectra in your library. You can skip the step where it asks for data files, and the wizard will ask if you are creating a template. You can answer yes to that question.

Once you have a fully populated Targets list in Skyline, you should be able to use the Spectronaut template to get most of the values you have described. The one I don't think we yet provide is the mass error between the original measured MS/MS spectrum peak and the calculated m/z of the fragment ion. That, we should be able to add relatively easily along with the original measured m/z from the library spectrum (which would be zero in both cases, of course, for a library from a prediction tool, like Prosit).

But, I think we should work with you a bit more to make sure this is the right direction since you say "I was not able to get any results." That surprises me, if you have a fully populated Targets list ready for DIA processing in Skyline.

Thanks again for bringing this up.

--Brendan

 
cervenka responded:  2022-10-04

Dear Nick and Brendan,
Thank you very much for your help! I will try both of your suggestions and I will compare the results. Nick, thank you for pointing out that I may get a lot of information I want directly from reports with adjusted columns – I did not consider it before.

Brendan, thank you for your comprehensive responses. I will give you more background for my question. We measured brain tissue samples with various sample preparations and several fractionation techniques (in total 53 DDA measurements) of non-model organism to get complex spectral library for further DIA analyses. We searched DDA data with Mascot and built spectral assay library in Skyline from individual .dat files (each DDA measurement = one .dat file). Now, we would like to publish our spectral library separately from other results in journal Scientific data. I looked at older articles about spectral libraries and authors often use the DIALib-QC tool for spectral library quality control. Therefore, I thought it could be reliable way how to check our library.

Thank you for your suggestion to contact directly DIALib-QC tool creators, I will definitely try it. To be honest, I did not conceive this idea. And moreover, I know that you are really helpful and user-oriented at this support – I have several positive experience!

I tried export report in Spectronaut format (see attachments) and process it with DIALib-QC tool via web interface (https://db.systemsbiology.net/sbeams/cgi/PeptideAtlas/AssessDIALibrary), but I have got only empty web page (see attachments). I will read more about the tool and I am going to run it on my computer to see if it will help. Otherwise, I would contact the DIALib-QC tool creators for solution.

Thank you once more, I really appreciate your kind help!

Jakub