DDA search hangs on "Running percolater..." with a specific FASTA file

DDA search hangs on "Running percolater..." with a specific FASTA file Remco van Soest  2022-09-20 18:27

Skyline (64 bit) (c99206313)

When using the "Import DDA Peptide Search" workflow Skyline hangs on "Running percolator..." after the search has successfully finished. I have to manually end the "percolator.exe" task in order to make the software respond again.

The issue seems related to the FASTA file (attached; downloaded from NCBI; sequence is correct). If I manually remove line 11 and 12 everything works just fine. It is not the length, as everything works fine as well if I replace line 11 and 12 with A's.

Why does the percolator task hang when using a specific FASTA file? I don't see anything wrong with the file, and obviously want to be able to use the full sequence for my search.


Nick Shulman responded:  2022-09-21 13:42
I think we will need to get more files from you in order to reproduce this bug.
Can you send us the raw files or mzML files that you were searching?

It sounds like you did "File > Import > Peptide Search" and told Skyline to perform a peptide search.
Can you send us screenshots of the pages of the Import Peptide Search wizard so that we can see what settings you used?

It might also be helpful if you could send us the Skyline document that you were importing the search into. That might be a blank Skyline document, but it might still be helpful for us to see it in case any of the settings in the document impact the reproducibility of this bug.

In Skyline you can use the menu item:
File > Share
to create a .zip file containing your Skyline document and supporting files including spectral libraries, ion mobility libraries, extracted chromatograms, etc.

If that .zip file, your raw files, and your screenshots are less than 50MB you can attach them to this support request.
If those files are larger than that, it might be easiest if you could package them all into a zip file and upload them here:

-- Nick
Remco van Soest responded:  2022-09-21 17:47
See attached PPT for the settings used. We prefer not to make the data publicly available, but if you contact me directly, I can make it available through box.

I tried again today, and found that the search works fine with the unmodified FASTA file as long as I use "0" for "Max missed cleavages" in the "Import FASTA (required)" screen.

Nick Shulman responded:  2022-09-22 15:18
I will send you an email.
-- Nick
a kotronoulas responded:  2022-12-01 05:34

Have you maneaged to find any solution? It seems that I have a similar issue with Remco as Skyline hangs on "Running percolator..." wwhen I use specific FASTA files. Others work fine although I always use the same process to download them Uniprot (https://www.uniprot.org/id-mapping).

I use .raw files and the same settings as in Remco's ppt to "Import DDA Peptide Search"

Plz send me an email if you need data.

Nick Shulman responded:  2022-12-01 07:12
We did not figure out exactly what was going wrong here except that the FASTA file had only one protein in it.
Doing a peptide search for only one protein is not really a valid thing to do since there is not enough data to do target/decoy statistics. Even so, Percolator should not hang like this, but we never did figure out what was the cause of that.
Yes, it would be helpful if you could send us your files which are causing problems. You can upload those files here:

I will also send you an email directly in case it is easier for you to share your files in some other way.
-- Nick
a kotronoulas responded:  2022-12-05 02:03
Thank you Nick for the response.

I have already sent you the files using google drive.

I hope you recieved them well
Nick Shulman responded:  2022-12-05 09:01
Thank you for uploading the file "05122022_AK_perc.rar".
I have a couple of different versions of Skyline on my computer. In some of those Skylines, I do see Percolator hang, but in others, it does not hang, but I do get the message "No spectra were found for new library". (Probably has something to do with my settings in these different Skylines being different from each other).

I see that the FASTA file that you sent me was very small. It only has 15 proteins in it, and the protein sequences are very similar to each other.
When you are doing a peptide search, you should use a FASTA file which is much bigger than that, and which contains many proteins that are expected to be found in the sample.

In the Import Peptide Search wizard, on the "Import FASTA" page, there is a checkbox "Import target proteins from a separate FASTA".
You should use this checkbox if you are interested in only a small subset of the proteins which are in the sample.
In the first textbox, you should point Skyline at a big FASTA file, and in the second text box which appears after you check the checkbox you should point Skyline at your smaller FASTA file which contains only the proteins you are interested in.

I will try to find someone who can figure out why Percolator sometimes hangs.
-- Nick
a kotronoulas responded:  2022-12-08 08:07
Hi Nick,

This morning I tried to use only Fasta files with a big number of proteins and the percolator does not hang any more.

However, the "No spectra were found for new library" error kept appearing.
After testing, I came up with the conclusion that it depends on the .raw file that I use to build the library.

The .raw files of sample 1 work perfectly, while those of sample 3 give the "No spectra were found for new library" (see attached ppt)

Any idea of what is the difference between sample 1 and 3?

Related fiels have been uploaded

Thanks you,