Issue with "Edit -> Insert -> Peptides"

support
Issue with "Edit -> Insert -> Peptides" pavel  2022-09-12
 

Hi,

I have a small issue when pasting peptides via "Edit -> Insert -> Peptides". My system is Windows 10, Skyline-daily 64-bit, 22.1.9.252.
When I try to copy a few peptides with descriptions from excel into the Skyline document, description is not included. The excel table looks like this:
EAGHLVFDR protein 1 description 1
IEAGHLVFDR protein 2 description 2
LIEAGHLVFDR protein 3 description 3
Just taking these three peptides from the Excel file into the clipboard and going to Edit -> Insert -> Peptides results in the third column empty in the table (see the attachement). I would expect to paste also the “description…” part.
Pasting only the description column into the third column of the grid did not work as well.

Thank you for your help.

Best regards,
Pavel

 
 
Nick Shulman responded:  2022-09-12
When you are doing "Edit > Insert > Peptides", the "Description" column is read only.

If you have a background proteome (.protdb) file, then Skyline will look for the protein name that you have typed in and, if it finds a matching protein in the .protdb file, will fill in the Description column.
You can create a background proteome file on the "Settings > Peptide Settings > Digestion" tab.

One thing that you could do is use the "Edit > Insert > Peptides" to add a list of peptides without proteins to your document.
Then, you can use the "Refine > Associate Proteins" menu item and give Skyline a FASTA file, and Skyline will figure out which peptides belong to which proteins and rearrange the peptides in the document.
-- Nick
 
pavel responded:  2022-09-22
Dear Nick,
thank you for your explanation, I was not aware of "read only" status of the Description column.
- Pavel