Losing proteins during dda import from orgs other than human

support
Losing proteins during dda import from orgs other than human jdemeter  2022-08-31
 

I am using the 'Import DDA peptide search' wizard to import results from a dataset generated by msfragger/fragpipe. The dataset contains peptides from human and a couple of viruses, with all the detected proteins included in the fasta library that I used during loading of the dataset into skyline. All viral peptides are in the generated spectral library, but none of them - and none of the proteins - made it into the target list, only the human proteins/peptides are there. I am wondering if I overlooked a setting that may have this effect. Any help would be greatly appreciated.

I am using skyline-daily v22.1.9.208.

Thank you,
Janos

 
 
Nick Shulman responded:  2022-08-31
When you are importing peptide search results, there is a page where you specify which FASTA file to use. Skyline will only give you peptides which appear in that FASTA file.
If you specified the wrong FASTA file when you did the import peptide search, or if you wanted to but were unable to specify more than one FASTA file, you can use the "File > Import > FASTA" menu item to tell Skyline to give you more proteins and peptides.
If you don't have a FASTA file for the missing peptides, but you want to add them to your document anyway, you can use the "View > Spectral Libraries" menu item to see all of the peptides which are in the spectral library which was built from your peptide search results. You can use the "Add All" button in the Spectral Library Viewer to add all of the missing peptides to your document.

After you have added these new peptides you should tell Skyline to extract chromatograms again using the "Reimport" button on the "Edit > Manage Results" dialog.

When you use the Import Peptide Search wizard it is roughly equivalent to the following steps:
1. Go to "Settings > Peptide Settings > Library" and build a spectral library
2. Use "File > Import > FASTA" to import a FASTA file
3. Use "File > Import > Results" to tell Skyline to extract chromatograms.

-- Nick
 
jdemeter responded:  2022-09-01
Hi Nick,

I am sorry - this was entirely my mistake. I accidentally picked the wrong library. You can close/delete this request.
Thank you,
Janos