Unexpected tab rearranging behavior

support
Unexpected tab rearranging behavior aboatman  2022-07-29
 

Hi there,

I'm on Skyline-daily version 22.1.9.208, using the small molecule interface and ion mobility filtering. I am trying to rearrange the tab order of my chromatograms to match the order of the results. However, when I click and drag a tab, it does not stay in the spot it is dropped. Instead it jumps two tabs to the left of where I tried to move it. This is really just a minor inconvenience, but it would be nice if the click and drag rearranging worked as expected.

It would be even nicer if there were an upgrade so that when you rearrange your results in Edit > Manage Results, the tab order automatically changes to match.

Thanks!
Anna

 
 
Nick Shulman responded:  2022-07-29
Can you send us your Skyline document?
In Skyline you can use the menu item:
File > Share
to create a .zip file containing your Skyline document and supporting files. One thing that will be included in the Skyline document will be the .sky.view file which tells Skyline the layout of all of the graph windows.

I am not able to reproduce the behavior that you are seeing on my computer, but maybe after I see your Skyline document I will be able to.

By the way, one way to reset the layout of all of the windows would be exit Skyline and delete the .sky.view file. The next time that you open that document, Skyline will arrange the chromatogram graph windows in their default order which would match the order of the Replicates in the "Edit > Manage Results" window. But, it would be great if you could make your .sky.zip file to send to us before you delete the .sky.view file.

(Actually, I imagine that deleting your .sky.view file might fix the problems you are seeing and that there is just something weird in that file like a hidden window in an unexpected location which is messing everything up).
-- Nick
 
aboatman responded:  2022-07-29
Hi Nick,

Here's the zipped file that I was still seeing the issue with. After saving it, I took your suggestion to delete the .sky.view file, and that did seem to fix the problem. Thanks for that tip, that'll be really useful!

Thanks,
Anna
 
natalia goykhman responded:  2022-07-31
Hello,

I have a similar issue with chromatogram and tab order, my workaround is: change the chromatogram order under Manage Results, then: View--> Arrange Graphs --> Tabbed.
The tabs are rearranged according to the chromatogram order defined under Managed Results.

Regards,
Natalia
 
Brendan MacLean responded:  2022-08-02
Note that the ordering is defined and can be changed under View > Arrange Graphs > Grouped. There you have a choice of:

Position
Document
Acquired Time

If you make a choice in this form, it is "sticky" and will impact the next time you use View > Arrange Graphs > Tabbed or Tiled, etc.

You can use this form with Group panes = 1 or Group panes = n where n is the number of replicates. To get Tabbed or Tiled, and then you can use the menu options, and it will continue to order the panes in the same way.

"Position" attempts to keep the graphs in the same order they are in when the command is issued. "Document" uses the order in Manage Results or various other places in the Skyline user interface, like the Document Grid - Replicates report or the Replicates list at the top of the Targets view. And "Acquired Time" orders the panes by the time of acquisition of the file in the replicate.

I couldn't say why the docking window drag-and-drop is not working the way you expect, but if it is persistent from run to run of Skyline, then maybe Nick will figure it out from the contents of the ZIP file you provided from File > Share.
 
Brendan MacLean responded:  2022-08-02
I downloaded the ZIP file and when I drag-and-drop the "SIL_test" tab among the other tabs it always ends up in the order I expect which is shown by the transparent blue shadow tab when I am dragging. So, I guess I am not seeing it jump 2 spaces from where the UI indicates as described.