Error when Importing .raw Files: "Search failed: [RawFileImpl::ctor()] Instrument index not available for requested device"

support
Error when Importing .raw Files: "Search failed: [RawFileImpl::ctor()] Instrument index not available for requested device" ehubb004  2022-06-21
 

Dear Skyline Team,

I am trying to build a Skyline document using proteomic DDA data, but am running into an error at the DDA search step at the very end of the import peptide search process:

Search failed: [RawFileImpl::ctor()] Instrument index not available for requested device
Parameter name: instrumentIndex

It seems like an issue with the raw files themselves, since Xcalibur won't open them and MSConvert gives the same error as Skyline. I've seen a similar error in other support threads but none with "ctor()" as the designated cause of the problem. I've attached a screenshot of the error message. The raw file itself is too large to post, though I'd be happy to provide it any other way if you'd like. Is there any solution to this issue?

Best,
Evan

 
 
Brian Pratt responded:  2022-06-21

Hi Evan,

If you can provide the file, we'll take a look at it - you can upload to http://skyline.ms/files.url .

But if Excalibur is having a hard time with it too, it's likely just a damaged file. Still, we'll have a look if you like.

Thanks for using the Skyline support board,

Brian Pratt

 
ehubb004 responded:  2022-06-21

Hi Brian,

I've uploaded one of the raw files under the name "Skyline_ctor_error_raw_ex"

Evan

 
Brian Pratt responded:  2022-06-21

Got the file, thanks. And the same error message when trying to view in it SeeMS.

What is known about the file? Any unusual instrumentation or acquisition modes?

Best,

Brian

 
Brian Pratt responded:  2022-06-21

Forgot to say - that's a pretty small file, as mass spec raw files go.

 
ehubb004 responded:  2022-06-21

The example file is just one of a dataset if that explains its smallness. I did not collect the data, but there appears to be nothing exceptional about the collection method. What I know is that this is from DDA on a Q-Exactive-HF with precursor acquisition 350-1600 Da, 60,000 resolution at m/z 200. MS2 with resolution 15,000 at m/z 200 and HCD fragmentation. There's no other information that I know of indicating anything strange with the data collection.

 
Brian Pratt responded:  2022-06-21

I don't know, even "small" mass spec files are usually much larger than this. Can you check with whoever did the data collection? I have a suspicion that this isn't actually mass spec data - perhaps it's from some other kind of detector instead. Or, again, it's damaged.

 
ehubb004 responded:  2022-06-22

Just an update: the files were damaged due to a (fixed) issue with incomplete downloading. The files work fine with Skyline!

 
Brian Pratt responded:  2022-06-23

Excellent, thanks for letting us know.

Best regards,

Brian