Transition List Not Working In New Version

support
Transition List Not Working In New Version kaitlyn b donohoo  2022-02-22
 

Hello,

I've been using the same transition list in skyline for a while but when I downloaded the new version the list keeps coming up with an error in line 634, column 3. I'm not sure what to do about this, and have attached the transition list below.

 
 
Brian Pratt responded:  2022-02-22

Hi Kaitlyn,

Thanks for providing the transition list. What version of Skyline are you using, exactly? I am not able to produce an error with this transition list on the current Skyline release 21.2.0.369, nor with Skyline-Daily 21.2.1.403.

Can you give more information on the error? A screenshot could be helpful.

Thanks for using the Skyline support board,

Brian Pratt

 
kaitlyn b donohoo responded:  2022-02-22

Brad,

I'm not sure which version of skyline it is, though it says it is the most recent version when I check for updates. If you can direct me on how to view the version information I would be happy to include it. For now I have two screenshots for you.

Regards,
Kaitlyn

 
Brian Pratt responded:  2022-02-22

You can find the Skyline version in the Help > About menu item.

The screenshot is a little fuzzy (you can use Alt-PrtScn to grab just the current window) but it looks like the text Skyline complains about isn't actually in the Excel file. I was using Copy+Paste from Excel directly into the Skyline Targets window, what method are you using to get where you are?

Regards,

Brian

 
kaitlyn b donohoo responded:  2022-02-22

I've gotten you the version.

I was using Edit>Insert>Transition List and then copy and pasting from the exel file.

 
Brian Pratt responded:  2022-02-22

This is very strange. Perhaps it has to do with settings (though I can't think how...) - can you provide the Skyline document you're working with? Use Skyline's File > Share > Store Everything menu item to create a .sky.zip file.

Thanks,

Brian

 
kaitlyn b donohoo responded:  2022-02-22

It won't allow me to share for some reason. The option is greyed out.

 
Brian Pratt responded:  2022-02-22

That is also very curious. Can I get a screenshot of that?

Regardless, let's try just a plain ol' Save, and zip up the directory you save to and send that.

Thanks,

Brian

 
kaitlyn b donohoo responded:  2022-02-22

Sure. Here's the screenshot and the files.

 
Brian Pratt responded:  2022-02-22

Ah, OK - that's not the File > Share menu item. That's Settings > Share, a different thing - but the confusion is understandable as I mentioned settings.

Anyway, working with the Test.sky you've sent, the one issue that I do hit is that the instrument settings (Settings > Transition Settings > Instrument) aren't a match for the transitions you're wanting to import. The transition list has precursor m/z values as great as 5351.6640 but your Instrument settings are Min m/z = 50 and Max m/z = 1500. Try setting that to Max m/z = 6000 or similar.

That doesn't explain the weird error message you seem to get, but it can't hurt.

Try that, and if you still get a failure then please do use the File > Share menu item to create a .sky.zip file, and send it along.

Best regards,

Brian

 
kaitlyn b donohoo responded:  2022-02-22

My bad. Still getting the error after the change.

 
Brian Pratt responded:  2022-02-22

Thanks, that file does seem to have suitable settings.

What happens when you save that excel file as a CSV and import that file (copy the CSV text from notepad or similar) instead?

Not that you should have to, but I'm wondering if there's some weird interaction between Skyline and Excel.

Thanks,

Brian

 
kaitlyn b donohoo responded:  2022-02-25

So importing as a CSV through file>import>transition list fixes the issue. Saving as a CSV and then coping from notepad does not work as it cuts off pretty early on in the list for some reason instead of copying the whole thing. I tried cutting down the list in excel (mostly because I realized my mistake in not taking out the values that are too high or low to have shown up) and tried to copy over again but that got the exact same error despite basically being a new list. Even checked and line 634 column 3 was a different adduct. It seems that the edit>insert>transition list has issues with both excel and importing CSV from notepad. I'm going to try my other computer tomorrow to see if it's just my laptop that creates the error or if it's the program.

Hope this helps.

 
Brian Pratt responded:  2022-02-28

Hi Kaitlyn,

Looking at this again I find that while I don't get an error, I also don't get the right transition count using the Edit>Insert>TransitionList method.

Thanks for pointing this out, I will continue my investigation.

Brian

 
Brian Pratt responded:  2022-03-18

Just leaving a note to say that we found the problem, and it's fixed in upcoming Skyline releases. Thanks again for the heads up.