merging documents for library construction

support
merging documents for library construction Will Thompson  2022-01-03
 

Hi Brendan

Following up on our conversation before the holidays about a 'work around' method for building a small molecule library from files which are sparsely populated with analytes. I have attached two skyline files, each containing a 'common' set of iMT standards and a 'unique' set of library molecules. The skyline documents have also each been curated such that the correct peak is integrated for the unique set of molecules, in two raw files (two injections) for each set of standards. Whenever I use the "File/Import/Document" method, it correctly combines the target lists, but Skyline is still integrating the 'unique' molecules in the raw files from the other document. What I want it to do is to merge the molecules which are the same, and leave the unique molecules empty (essentially the same as if I right clicked on the chromatograms and selected 'remove peak')...those molecules are absent in those runs, and if there are integrations performed in those runs it will not be able to build the indexed retention time regression properly. I have tried all combinations of import/Document that I can think of, to no avail. Would you be willing to give it a shot?

Thanks

Will

 
 
Nick Shulman responded:  2022-01-03
Will,

I think what you need to do is, for both the "...RowA.sky" and "...RowB.sky" you need to go to:
Edit > Manage Results > Minimize
and check the box that says "Discard unused chromatograms" and then push either the "Minimize in Place" or "Minimize and Save As" buttons.

Then, if you try to merge the documents that have had the unused chromatograms discarded, you will not have the problem that molecules suddenly get chromatograms that they aren't supposed to have.

You actually have to do one more thing with that "...RowB.sky" file. When you go to "Edit > Manage Results > Minimize", you will actually see that "<Unmatched files>" is listed as one of the replicates, and "discard unused chromatograms" is not going to fix this. To fix that, what you need to do is "File > Import > Results" and extract chromatograms from some other file (any file, doesn't matter what). Then, go to "Edit > Manage Results" and remove that newly imported replicate.

After you have done that to RowB.sky, then, when you import the minimized RowB into the minimized RowA, only the molecules which you expect to have chromatograms will have chromatograms.
-- Nick
 
Will Thompson responded:  2022-01-05
Nick, thanks so much! This worked! I wasn't aware that without removing the 'remnant' raw data from the files via discarding the unused chromatograms, it would automatically extract something. Makes sense. By using your instructions above, i was able to merge the files and then build one iRT library containing all analytes. Very good! Now to do this for the other couple hundred runs :)

As always, much appreciate the help of this team.

Cheers

Will