View Modification label for U-15N heavy peptides

support
View Modification label for U-15N heavy peptides joshuasmith  2021-10-16
 

Hi Brendan et al,

I am using a uniformly 15N labeled protein internal standard in my DIA experiment. When setting up my Skyline document, I know how to add a 15N heavy label for each residue on a peptide, and this works fine for the analysis.

My question is about the user interface/display. If I navigate to View-->Modifications from the menu bar, I can change the way that the modifications are displayed in the peptide list on the left. When there's just a single modification in a peptide (whether that's a PTM or a heavy residue), it's pretty straightforward, for example: "LVNEVTEFAK[+8]" when displaying just the mass shift of a heavy Lys, or "LVNEVTEFAK[Label: 13C(6)15N(2) (C-term K)]" when showing the full name.

However, when selecting a 15N label for every residue, the peptide list can get pretty hard to read: "LVNEVTEFAK" becomes "L[+1]V[+1]N[+2]E[+1]V[+1]T[+1]E[+1]F[+1]A[+1]K[+2]” or "L[Label: 15N]V[Label: 15N]N[Label: 15N]E[Label: 15N]V[Label: 15N]T[Label: 15N]E[Label: 15N]F[Label: 15N]A[Label: 15N]K[Label: 15N]".

I would like to be able to list a peptide as uniformly 15N-labeled with one label or a shorter labeling scheme - is this option available and I just don't know how to display it? Something like "[U-15N]LVNEVTEFAK" might work and wouldn't make it seem like only the residue to the left is labeled, as it might with putting a label pertaining to the whole peptide after the last residue, like "K[Label: 15N]", for example.

I do get that I can choose View-->Modifications-->Not shown, which omits all modification labels, identifies modified residues with bold+underline, and displays heavy peptides in blue bold. That is useful, but I am actually dealing with a lot of different modifications on the endogenous light peptides, and so without any labels I would have a whole list of light peptides which all look identical. So I would like to be able to display the modifications for identification at a glance, rather than having to hover over each peptide to see what particular modification is present.

Thanks for your help, and thanks for all your work on what has been an indispensable software tool in my research.

Josh

 
 
Nick Shulman responded:  2021-10-16
It would be straightforward for us to add new choices under the "View > Modifications" menu item.
It sounds like if we added an option "View > Modifications > Total Mass Difference", that might be helpful for your scenario.

Can you send us a copy of your Skyline document so that we can see what things look like for you now?
In Skyline you can use the menu item:
File > Share
to create a .zip file containing your Skyline document and supporting files including extracted chromatograms. If that .zip file is less than 50MB you can attach it to this support request. Otherwise, you can upload it here:
https://skyline.ms/files.url
-- Nick