MZXML Data is only partially importet

support
MZXML Data is only partially importet juergen gindlhuber  2021-10-12
 

Hello Skyline Team,

we encountered a strange issue, and did not find anything similar by using the serach function in the forum.

We are using a Shimadzu GC-MS QP 2010 SE for targeted FAME analysis.
As skyline does not import the GC/MS file format we export them as MZXML files.
We use the newest version of skyline available 21.1.0.278, also treid it with an older version before encountering the same problem.

Various methods of a naming scheme have been tried and can be sen in the Fame1ms1 image.
highlited there is that one of the chromatograms is just a flat line but the all transitions get picked for all molecules.

If Into the same Transition settings the same file but only ms2 levels, the chromatogram looks how it's supposed to, but i loose the chromatograms for most of the molecules, as seen in immage Fame1ms2.

If I only use a single molecule for analysis on ms 2 level everything looks like its working perfekt, as seen in image Fame2ms2, wich is a solution but due to the amount of samples and moluces not a solution we would prefere.

Thank you for all your work on the Software
Greetings from the Proteomics Pirates

 
 
Nick Shulman responded:  2021-10-12
Can you send us your Skyline document and mzXML files?

In Skyline, you can use the menu item:
File > Share
to create a .zip file containing your Skyline document and supporting files including extracted chromatograms.

If that .zip file and those mzXML files are less than 50 MB you can attach them to this support request.
Otherwise, you can upload them here:
https://skyline.ms/files.url

I am not sure I understand what is going on in your screenshots.
If you are having trouble with extracting chromatograms from an mzXML file, that is an issue that we know about. Skyline gets confused about what in a mzXML file is a regular MS1 spectrum, versus a SIM spectrum, and you end up getting two separate chromatograms extracted, one containing all of the spectra where the observed m/z's spanned a range less than 500 units (which Skyline calls the "SIM chromatogram", and the other chromatogram from the spectra where the observed m/z's spanned a range greater than 500 units (the regular MS1 chromatogram) and Skyline ends up only showing you the SIM chromatogram. Before January 2000, the cutoff number for deciding something was "SIM" was changed from 200 to 500, so that might explain why you are seeing a difference in behavior with older versions of Skyline.

There is some information about that problem here:
https://skyline.ms/announcements/home/support/thread.view?rowId=47955

For this reason, we recommend that you use the .mzML format instead of .mzXML.

-- Nick
 
juergen gindlhuber responded:  2021-10-12
Hi Nick,

I Uploaded the Data into the files deposit.

Using the mzML format left me with the same result.

The problem is that for some of the parent child fragment pairs i get just a flat line at 0 like nothing would have been measured.
And it`s the first time we encountered this Problem. I included 3 Versions of the same file, 1st the mzXML, 2nd one filtered for only ms 2 runs and the 3rd an mzML. I hope you can understand what i meant by looking simply at the first precursor in the target list.

Thanks for the fast answer
Jürgen
 
Nick Shulman responded:  2021-10-12
Jürgen,

After Skyline extracts chromatograms, the first thing that Skyline does is resample the chromatogram in the time dimension in order to make it so that all of the chromatogram points have retention times that are evenly spaced. The reason that Skyline does this is that our peak picking algorithm relies on the times being evenly spaced, and so Skyline's computation of height, area, and background are performed on this interpolated chromatogram.

You can see the original chromatogram if you right-click on the chromatogram graph and choose "Transform > None".

When I do that, I get the attached picture (Fame1ms1.png). I can see that there are two chromatograms with nice shapes, except that half of the points in both of those chromatograms have intensities which are zero.
One of those chromatograms ends up getting completely flattened by the interpolation procedure. Usually our interpolation algorithm does change the area like that, but, in this case, because of how close in time the zero and the nonzero points are to each other, the nonzero points end up being effectively ignored.

If you left click on a point along the chromatogram, Skyline will bring up the full scan viewer and you can see what the spectrum looked like that Skyline extracted that chromatogram from. I can see in the attached images "Scan980.png" and "Scan983.png" that your two different transitions for that precursor only have signal in different spectra.

I am not sure what you should do about this. I imagine you need to somehow combine those spectra before you ask Skyline to extract chromatograms from them so that your chromatograms do not end up being jagged like that. Alternatively, if you could trick Skyline into thinking that those two transitions have different precursors there might be a way to only have Skyline use the spectra that you intend for each precursor.

-- Nick
 
juergen gindlhuber responded:  2021-10-12
Hi Nick,

Im just Mesmerized that you showed me now a third option, inever ended up with this jagged chromatograms.
Did you need to adjust any settings? This would already be great for us to get and overfiew and we could later invest the time with the extracted MS 2 runs.
Mine are either perfectly plotted or flat line like my Fame1ms1.bmp that i send earlier. Intrestingly if i hover over it and left click it as you suggest it shows me the correct values, so the link is correct.

Thanks a lot for your time
Jürgen
 
Nick Shulman responded:  2021-10-12
The jagged chromatogram is what you see if you right-click on the chromatogram and choose "Transform > None".
You see the flat chromatogram if you right-click and choose "Transform > Interpolated".

These are the extracted chromatograms that were already in that "FAME1.sky.zip" that you sent me.

The "Transform > None" is the "raw chromatogram" where every point corresponds to a spectrum in your raw file.

The Interpolated chromatogram has been resampled in the time dimension. The interpolated chromatogram is supposed to look very similar to the raw chromatogram. Usually, the interpolated chromatogram ends up looking like a slightly smoothed out version of the raw chromatogram, because that is what happens if you average nearby points. I have not seen a case where the interpolated chromatogram ends up being flat like this, but I think it has something to do with the fact that the raw points nonzero intensity immediately followed by zero intensity, and then a bit of a gap followed by nonzero and immediately zero.

-- Nick
 
juergen gindlhuber responded:  2021-10-13
Thank you!

Best regards
Jürgen