Export only certain precursor to PRM precursor list

support
Export only certain precursor to PRM precursor list dtran24979  2021-10-08
 

I input 575 peptides from a DDA into Skyline to build a spectra library and a PRM precursor list. After examining the data, I deleted the other peptides from the Target Window and was down to 199 peptides, 201 precursors. However, when I went to export the PRM precursor list, Skyline still exports all 575 peptides. Is there a way to export only the ones that I have in the target window?
Thanks,
Duc

 
 
Nick Shulman responded:  2021-10-08
Are you saying that you did:
File > Export > Isolation List
and you are getting some peptides that have been deleted from the Targets tree?

That does not seem possible to me (although I am not that familiar with exporting isolation lists, so there might be something going on that I do not understand).

It might help if you send us your Skyline document.

In Skyline, you can use the menu item:
File > Share
to create a .zip file containing your Skyline document and supporting files including spectral libraries.

If that .zip file is less than 50MB you can attach it to this support request. Otherwise, you can upload it here:
https://skyline.ms/files.url

By the way, when you delete the peptides from the Targets tree, those peptides will still be present in the spectral library. That is, you will still see the peptides:
View > Spectral Libraries

If you would like to remove those peptides from the spectral library, you can do:
File > Share
and on the "Share Skyline Document" dialog choose "Minimize Libraries". This will remove all peptides from the spectral library which are not present in the Targets tree.
If you then open the .sky.zip file, you will have a document whose library does not contain the peptides that you deleted.

However, those peptides not being in the spectral library should not have any effect on the isolation list you are exporting.
-- Nick
 
dtran24979 responded:  2021-10-08
Hi Nick,
Thank you very much for your response. It's very helpful. To answer your questions:

"Are you saying that you did:
File > Export > Isolation List
and you are getting some peptides that have been deleted from the Targets tree?"

No, I Export a Report, then define what I want in the report including: precursor mz, precursor charge, sequence and peptide retention time. When I do this, you are correct Skyline exports everything present in the spectra library. The isolation list doesn't include RT and because I'm exporting a scheduled PRM precursor list, I want to export the RT as well.

I did try the minimize library trick to get rid of the other peptides in the library, however, when I export the PRM report, the 575 peptides are still there!

Thanks so much for your help!
Duc