Missing fragment results for precursors with fully permuted isotope labels which have the same mass

support
Missing fragment results for precursors with fully permuted isotope labels which have the same mass stephan kamrad  2021-08-10
 

Hi,
I cannot figure out why my Skyline document is missing results for some fragments, and Skyline's behaviour appears somewhat inconsistent to me.

The setup is a bit unusual, but I hope the following makes sense.

  • I am interested in peptides with two K residues and these can be either 13C or 12C. I have therefore applied a variable isotope label and used Refine -> Permute Isotope Modifications -> Complete. This results in 4 precursors per peptide (both lysines labelled, no lysine labelled, the first lysine labelled, the second lysine labelled).
  • For other reasons, my cells were grown on 13C glucose, all other amino acids therefore carry fixed structural modifications to make them 13C
  • Samples were measured on a Sciex QTOF 6600 with a targeted PRM method generated by Skyline.

The problem is as follows: The two precursors with exactly one labelled and one unlabelled lysine have exactly the same precursor mass, but they do have unique fragments (fragments which contain exactly one lysine). I would therefore like to use these for quantification to distinguish the two label states. When I import my .wiff data, Skyline shows no result for some fragments. And it seems to somehow recognise which fragments are shared and unique between the two precursors. Sometimes it shows no data for fragments which are shared (which is weird but OK for me), but in other cases it excludes all unqie fragments (which is bad).

Do you have any insight why it is not extracting results for some of these fragments? I realise this is a somewhat off-label use of Skyline but hopefully there is a workaround. I have attached a Skyline file with two peptides. The interesting thing is happening with the heavy2 precursor where some fragments are not quantified. For the first peptide the unqiue fragments are not quantified, for the second fragment, the shared fragments are not quantified.

Thanks a lot for your help,
Stephan

 
 
Nick Shulman responded:  2021-08-10
Stephan,

Can you send me your .wiff and .wiff.scan files too? If those files are less than 50MB you can attach them to this support request. Otherwise, you can upload them here:
https://skyline.ms/files.url

The reason that you are seeing the behavior that you are seeing is that Skyline has two put one set of chromatograms in the .skyd file for each of the precursors in your document. However, when Skyline wants to find the chromatograms in the .skyd file for a particular precursor, the only things that Skyline is comparing are the Peptide Modification Sequence and the Precursor M/Z. Because of this, Skyline often makes a mistake, and looks at the set of chromatograms which are associated with a different precursor than the one it was supposed to.

This is a bug in Skyline, but it might be tricky to come up with a fix for it. I will ask around and see if anyone has any good ideas about how it would be possible to fix this.

It is unfortunate that this bug exists, since it does appear to make the "Complete" option on the "Permute Isotope Modifications" dialog useless.

Thank you for reporting this bug. My guess is that you are the first person to use Permute Isotope Modifications to distinguish between isobaric precursors.

If you needed to work around this bug today, I would recommend that you go to:
Settings > Peptide Settings > Modifications
and define a new Isotope Modification whose monoisotopic and average masses are both a really small number (such as .0001) which can be applied to any amino acid. Then, right-click on the peptides in the Targets tree, and selectively apply that tiny modification to precursors in the document so that no two precursors end up having exactly the same precursor m/z.

I will try to fix this bug soon so that you will not have to do that workaround.

Let me know if you run into any more problems.
-- Nick
 
stephan kamrad responded:  2021-08-10
Hi Nick,

Thans a lot for getting back to me! That all makes sense and I will definitely try the workaround you suggested.

I have uploaded the files as requested: 20210519_colonySwitchingK_MRM_17_K70_48h_r2.wiff and .scan

Thank you, all the best,
Stephan
 
Nick Shulman responded:  2021-08-10
Stephan,

By the way, if you are going to do the trick of changing the precursor m/z by a small amount, you also need to go to:
Settings > Transition Settings > Full Scan
and change MS/MS Filtering Acquisition method to "DIA" and change the isolation scheme to something like "Results Only".

The problem with having the acquisition method as "Targeted" is that Skyline will only assign each MS2 spectrum to the precursor(s) in the document with the closest matching m/z. That worked fine when your precursors had exactly the same m/z, but now that they're slightly different, only one precursor is going to be able to use each spectrum.
If you change the acquisition method to "DIA", that should fix this problem.

-- Nick
 
stephan kamrad responded:  2021-08-10
Hi Nick,

Thanks! That did the trick.

Stephan