Using Skyline for target-directed DCC analysis

support
Using Skyline for target-directed DCC analysis antoine lacour  2021-08-04
 

Hi all,

I am looking to use Skyline to speed up the analysis of a target directed DCC run. For those not familiar with the experiment, you take a library of reagents (in this case aldehydes and hydrazides) which react to form a library of products (here acylhydrazones). The reaction is an equilibrium which can be modified by Le Chatelier's principle, in this case by the addition of an enzyme. The idea is to find the products in the equilibrium which are amplified by adding the enzyme, which indicate potential binders to the target in question. See the following article for an example : https://pubs.rsc.org/en/content/articlelanding/2021/sc/d1sc00330e#!

I am wondering if I can use Skyline to help with the analysis of the data coming from these runs. We run a blank experiment with no enzyme and one with enzyme and compare the formation of the products in both.

I created a transition list (M to M+H (not sure if this is what I should be inputting but it seems to work as I intend)) with all possible products of the equilibrium, and imported the LC-MS data from both the blank run and enzyme run. Using this I can easily figure out the retention time of the product and compare its presence or absence in each run.

However I Have the following issues/questions

  • Skyline seems to be only reading the MS channel from the .raw file imported from the HRMS machine we use to perform the runs. Therefore the integration of the peaks is done on the MS channel. In an ideal world, I would be able to use the integration from the UV trace that is measured in parallel during the run to compare amplification of certain compounds by comparing peak areas. I realise this could also be done with the MS channel, but due to greatly varying ionisation potentials within the library of compounds, I have my doubts whether this will compare well with the more well-established. Therefore, is there anyway to find the masses of the products in the MS channel but use the UV trace to do the integration analysis? Or would this have to be done in separate software?
  • I don't seem to be able to find a way to export the peak areas to a table to compare the values for the two runs, I can only generate the chart using the "Peak Area - Replicate comparison" feature
  • I was wondering if there is a way to subtract two chromatograms generated by Skyline using the transition list to only see the difference between the blank and protein-containing runs.

I attached a sample picture of the extracted chromatograms with all the compounds shown.

Thanks in advance for your help, and I apologise in advance for any incorrect terminology I use, MS is not my strong suit.

Cheers,

Tony

 
 
Nick Shulman responded:  2021-08-04
If you want to get lists of numbers out of Skyline, you can use either the Document Grid (View > Document Grid), or the Export Report command (File > Export > Report).
You should take a look at the Custom Reports tutorial:
https://skyline.ms/wiki/home/software/Skyline/page.view?name=tutorial_custom_reports

If you want to compare numbers between groups of replicates, we recommend that you use the Group Comparison feature, which will tell you fold changes and adjusted p-values. Here is the Group Comparison tutorial:
https://skyline.ms/wiki/home/software/Skyline/page.view?name=tutorial_grouped

I do not believe that Skyline can do anything with UV trace data.

If you would like to, you can send us a Skyline document and we might be able to give you better answers, especially if you have more questions. In Skyline you can use the menu item:
File > Share
to create a .zip file containing your Skyline document and supporting files including extracted chromatograms.

If that .zip file is less than 50MB you can attach it to this support request. Otherwise you can upload it here:
https://skyline.ms/files.url

-- Nick
 
antoine lacour responded:  2021-08-05
Thanks for the quick answer Nick. I will look into these tutorials. Please find my file attached as requested.

Cheers,

Tony