MS stats error exporting the report

support
MS stats error exporting the report io  2021-07-28
 
Hi again,

I have another error with MS Stats: Error exporting the report

---------------------------
Skyline
---------------------------
Error exporting the report, tool execution canceled.
---------------------------
OK More Info
---------------------------
System.IO.IOException: Error exporting the report, tool execution canceled.
   en pwiz.Skyline.Model.Tools.ToolMacros.GetReportTempPath(ToolMacroInfo toolMacroInfo) en C:\proj\skyline_21_1_x64\pwiz_tools\Skyline\Model\Tools\ToolMacros.cs:línea 266
   en pwiz.Skyline.Model.Tools.ToolMacros.ReplaceMacrosHelper(SrmDocument doc, IToolMacroProvider toolMacroProvider, ToolDescription tool, IProgressMonitor progressMonitor, String replacein, Macro[] macros) en C:\proj\skyline_21_1_x64\pwiz_tools\Skyline\Model\Tools\ToolMacros.cs:línea 206
   en pwiz.Skyline.Model.Tools.ToolDescription.RunExecutableBackground(SrmDocument document, IToolMacroProvider toolMacroProvider, TextWriter textWriter, IProgressMonitor progressMonitor, Control parent) en C:\proj\skyline_21_1_x64\pwiz_tools\Skyline\Model\Tools\ToolDescription.cs:línea 492
   en pwiz.Skyline.Model.Tools.ToolDescription.<>c__DisplayClass79_0.<RunExecutable>b__0() en C:\proj\skyline_21_1_x64\pwiz_tools\Skyline\Model\Tools\ToolDescription.cs:línea 334
---------------------------
 Can you help me?

Thank you

Irene
 
 
Nick Shulman responded:  2021-07-28
Can you send me your Skyline document? I will try to reproduce the error that you are hitting.

In Skyline you can use the menu item:
File > Share
to create a .zip file containing your Skyline document and supporting files including extracted chromatograms.
If that .zip file is less than 50MB you can attach it to this support request. Otherwise, you can upload it here:
https://skyline.ms/files.url

Skyline appears to be discarding the most useful information about the error that you are hitting, so it is not possible for me to see what is going wrong. I will fix this so that a future version of Skyline will have better information if an error occurs in that part of the code. If I am not able to reproduce the error with the files that you send me, I might need to give you a special build of Skyline so that you will be able to get more information about that error.

-- Nick
 
io responded:  2021-07-28
OK. The file is saliva v4stats2.There are 3 technical replicates (=3 runs) and 1 biological replicate, 4 conditions
Thank you very much
Irene
 
Nick Shulman responded:  2021-07-28
Irene,

I have not been able to reproduce your error, but I have some ideas about what might be going wrong.
One thing is that the MSstats tool requires a report in the "External Tools" group called "MSstats Input". If you have deleted or renamed that report, Skyline will give you the message that you are seeing.

I would recommend that you click the Skyline menu item:
Tools > Tool Store
and then choose "MSstats" and push "Reinstall"

Skyline will then give you the MSstats report if it is missing.

Once you get MSstats working, I think you are going to run into a different problem because MSstats cannot handle your WIFF files that have multiple runs in them. You are going to see errors that look like:
*** Subject : 12, Condition : Fragilidad has multiple rows (duplicate rows) for some features

The way to work around this is to replace the MSstats report with a different report in which the column "FileName" contains the full path of the WIFF file including sample name.

1. To get this new report definition you should save the attached file "MSstats Input.skyr" somewhere on your computer.
2. Then, do:
File > Export > Report
press "Edit List"
3. In the "Group" dropdown at the top of the Manage Reports dialog, choose "External Tools"
4. Press the Import button and choose the file that you saved in step 1.
5. If you are asked whether to replace the report that already exists, choose "Yes".

After you have done that, you should be able to run the MSstats tool on your data without error.
-- Nick
 
io responded:  2021-07-29
Hi again,
I have problems with point 1. I dont know where is the attached file "MSstats Input.skyr"
Irene
 
Nick Shulman responded:  2021-07-29
The file "MSstats Input.skyr" was attached to my earlier response.
https://skyline.ms/announcements/home/support/download.view?entityId=8f6567ae-d206-1039-a3a0-e465a393713c&name=MSstats%20Input.skyr

I am sorry that my first response was so complicated: I was trying to anticipate the next problem you were going to run into after you got past your first problem, but we should first make sure that your first problem has been fixed.

Have you tried using the menu item "Tools > Tool Store" and then asked Skyline to update MSstats?
Has that fixed your original problem, or are you still running into the error "Error exporting the report, tool execution canceled."?

Let me know whether you are still running into that error, or whether you are now seeing a different error.
-- Nick
 
io responded:  2021-08-02
Yes Nick, I Have solved the errors.
Thank you very much
Irene