ambiguous PRM peptides don't show up as targets, but can be found in the library

support
ambiguous PRM peptides don't show up as targets, but can be found in the library susanne matschi  2021-07-23
 

Hello,

First of all, I am quite new to the MS field so there might be some obvious error I just don't know any better about. I am working on Windows 10 Pro with Skyline 20.2.0.343.
I am trying to analyze PRM data measured on a Thermo QExactive Plus, including heavy peptides for quantification. Doing identification with Proteome Discoverer using our Mascot server, it can find the native peptides (unfortunately only 10-80 PSMs depending on the sample) as well as the labelled ones (more than 1000 PSMs per sample).
When trying to build a library with the msf or PD result files and importing the data to Skyline, the peptides do not show up as targets at all. I went back and tried to import some of the Mascot dat files, which then gave me the error "Peptides had multiple ambiguous peptide matches and were excluded". I redid the library build and importing, checking the box "include ambiguous peptide-spectrum matches", and now I can find the peptides in the library (only with the dat files, not the msf or PDresult), but it still doesn't show up as a target peptide. I could then manually add them as library matches to the target peptides, but I don't really understand why it would not do this automatically. I played around with a lot of peptide and transition settings but nothing worked to make them appear.
What could be an explanation for this, Is there anything I am missing?

Thanks,
Susanne

 
 
Nick Shulman responded:  2021-07-23
When you see the warning message "Spectra matching the following peptides had multiple ambiguous peptide matches and were excluded", Skyline is telling you that there are some spectra which were matched to multiple peptides. It is likely that there were plenty of other spectra which only matched to a single unambiguous peptide, and were included in the library. If you want to see which peptides were included in the library you can use the Skyline menu item:
View > Spectral Libraries

There are a few different menu items which result in Skyline building a spectral library, and I am not sure I understand which menu item you used.

If you use the menu item:
File > Import > Peptide Search
Skyline guides you through a process where you build a spectral library from peptide search results, and then you provide Skyline with a FASTA file, and then Skyline will add all of the library peptides which can be found in that FASTA file to your document.

A different way to build a spectral library is:
Settings > Peptide Settings > Library > Build
If you build a library that way, the library will be added to your Skyline document, but Skyline will not add any peptides to your document.
If you then want to add peptides to your document after building a library you can either use the menu item:
File > Import > FASTA
or you can use the menu item:
View > Spectral Libraries
and then press the "Add All" button in the Spectral Library Explorer

Does that answer your question?
If you have more questions, and if you would like, you could send us your Skyline document and/or your peptide search results and raw files, and we could tell you what is going on.
In Skyline you can use the menu item:
File > Share
to create a .zip file containing your Skyline document and supporting files including spectral libraries.

If that .zip file is less than 50MB you can attach it to this support request.
Otherwise, you can upload it here:
https://skyline.ms/files.url

-- Nick