export fasta of all verified proteins from Skyline

support
export fasta of all verified proteins from Skyline kguehrs  2021-07-15
 

Hello Skyline team,

Perhaps this matter was already asked but I could not find any answer after I drastically limited my search to "export fasta".

I have done a DIA analysis of some special tissues from an model organism. The basis for the analysis was a rather large fasta database of not so good quality which I used as the background proteome. The analysis of the run data was done with Umpire/Fragpipe and imported into Skyline for visualization and curation. I did quite a bit of manual refinement and came up with a status in which I erased a lot of identified by the search engines proteins that do not match my quality restriction. Besides the generation of a spectral library I would like to also create a fasta file of either all or a specified fraction of the proteins remaining after the curation of the data. This fasta coould be used for other purposes or as a core background proteome that could be further expanded by additional data.

Is there any chance to export the proteins remaining after curation as a fasta file from Skyline. If there is no direct way, can you propose an other tool or procedure to do so from any Skyline generated report.

Best Karl-Heinz

 
 
Nick Shulman responded:  2021-07-15
Skyline does not have any feature to export a FASTA.
A FASTA file alternates between:
1. lines that start with ">" followed by the protein accession number and the protein description
2. lines which contain the protein sequence

I imagine you could create a custom report to list the protein access, protein description, and protein sequence in a tab-separated-value file.
Then you could use search and replace in a text editor to make it look like a FASTA file.

You can learn more about Skyline custom reports here:
https://skyline.ms/wiki/home/software/Skyline/page.view?name=tutorial_custom_reports

-- Nick
 
kguehrs responded:  2021-07-16
Hello Nick,

Thank you for the response and the proposal of how to proceed. As I have several hundert proteins in the curated DIA results the proposed way is at least not very elegant. As there are that many proteins it is rather impossible to manually check all precursors identified by the search software.
As the quality of the DIA data is not always sufficient for a confident statement about the presence and the quantities of some proteins of interest there is very often the need for verification. In several cases a fasta based on the curated data (especially if related to special tissues or cells) might be helpful for the selection of peptides for different types of PRM assays (PTM search, cell type specificity etc.) as well as for spectra prediction (prosit etc.).
Perhaps, it might be worth thinking to add a feature for exporting fasta files from results or reports to Skyline.

Best Karl-Heinz
 
Nick Shulman responded:  2021-07-16
I am not sure I understand what you are asking for. It sounds like, in addition to wanting to export a FASTA file consisting of the proteins in your Skyline document, you are also asking for ways to remove the proteins that do not match some particular criteria.

The Document Grid has a "Actions" button at the top which can be used to delete the peptides or proteins that are selected in the grid, so if you can filter or sort the grid based on other criteria, you can often use that to delete the things that you want to.
There are also some main menu items "Refine > Accept Peptides" or "Refine > Accept Proteins" which you can use if you have a list of the peptides or proteins you want to keep.

If you send us your Skyline document, it might help us understand what you are asking for.

In Skyline you can use the menu item:
File > Share
to create a .zip file containing your Skyline document and supporting files including extracted chromatograms.

If that .zip file is less than 50MB you can attach it to this support request. Otherwise, you can upload it here:
https://skyline.ms/files.url

-- Nick
 
Brendan MacLean responded:  2021-07-16
A little known secret:
Selecting a protein element in the Targets tree, Edit > Copy followed by a paste into a text editor such as Notepad gives you FASTA for the protein. And this works for multiple selections.

So, I would:
1. Reduce the document to only the proteins you want in your FASTA.
2. Edit > Collapse All > Proteins
3. Edit > Select All
4. Edit > Copy
5. Paste into a text editor.

We could make this less well hidden and easier to use, but this should get you what you are looking for.

Hope this helps. Thanks for posting to the Skyline support board.

—Brendan
 
kguehrs responded:  2021-07-18
Great advice!
Thanks a lot, Brendan.