Regex filter tab

support
Regex filter tab af1234  2021-06-07
 

Hi,

I have been trying to remove peptides containing specific AA, but I am having some issues.
I imported a msms.txt file from MQ then imported all the dda raw files.
I then went to the refine>advance> select all precursors/transition/peptides and I went to the filter tab selected> filter C/M added [Q|B|W] and then autoselect all matching peptides, but there are still peptides with C/M and also containing either Q, B or W.
Am I missing something obvious?

 
 
Nick Shulman responded:  2021-06-07
Can you send us your Skyline document?

In Skyline, you can use the menu item:
File > Share
to create a .zip file containing your Skyline document and supporting files.

If that .zip file is less than 50MB you can attach it to this support request. Otherwise, you can upload it here:
https://skyline.ms/files.url

I am not sure that I understand your description of the things that you tried.

A different way to remove peptides matching certain criteria would be to use the Document Grid. You can use the Document Grid to filter down the set of rows that you are looking at so that you see those peptides whose sequence contains a certain letter. You can then select all of the rows, and use the "Actions" dropdown button at the top of the Document Grid to delete the peptides associated with all of the selected rows.
-- Nick
 
Brendan MacLean responded:  2021-06-07
Hi Andrea,
I don't really follow your steps either. I would expect you to build a library from the msms.txt file (plus its matching raw data files). I would expect you to go to Peptide Settings - Filter and define an item for "Exclude peptides containing" by clicking the "Edit List" button. I guess you are saying that you did this by checking the "Cys" and "Met" exclusions and then adding another or possibly 3 other filters to exclude Q, B, and W, possibly using the regular expression "Q|B|W" with the "Auto-select all matching peptides" option selected.

If you then or previously imported a number of FASTA sequences into your document, you should immediately see all peptides containing C, M, Q, B, W removed from your document. However, if you used a method that defines a peptide list, like View > Spectral Libraries and clicking the "Add All" button, then you have created a custom list, which Skyline will not necessarily filter based on this setting.

The best way for us to know for sure, is to get your files as Nick has requested.

Thanks for posting to the Skyline support board.

--Brendan
 
af1234 responded:  2021-06-08
Hi Brendan and Nick,

I did created a library from the importa dda search using the msms.tx, so I did what Brendan described. Here is a smaller example

Thanks!
 
Brendan MacLean responded:  2021-06-08
Ooops! You need the Peptide Settings - Library - Pick peptides matching field to be "Library and Filter" (not just "Library").

I have been thinking about other settings like this that cause Skyline to ignore another setting. In this case, choosing "Library" causes Skyline to ignore the filter. I have been thinking that we should improve the UI to ask when there are what it sees as conflicting settings. e.g.

- You check a exclude filter. (and you have just "Library" in the Pick peptides matching field)
- Skyline tells you that you need a different setting to have the filter impact the choices and asks which filter type you want.
- If you cancel without choosing an appropriate type, then the checkbox is cleared.

- You switch the Pick peptides matching field to "Library". (and you have checked elements in the Exclude peptides containing list)
- Skyline tells you that this will clear your exclude choices and offers you OK and Cancel.

There are other places in the settings UI that we need this kind of logic to warn the user and to leave the visible settings internally consistent so that you don't appear to have settings which Skyline is really going to ignore, like what happened to you.

Thanks for pointing this out! Luckily, once you understand there is an easy solution.

--Brendan
 
af1234 responded:  2021-06-08
Thanks for spotting this, totally missed it.I think that would be really useful to have something like this, considering that there a lot of parameters and it is possible like in my case to set up everything but one thing incorrectly. Other options would be to make the filter tab not editable until the library+filter checkbox is selected