about ms/ms filtering

support
about ms/ms filtering minyg98  2021-06-06
 

Dear Skyline team

Hi! This is Minyeong Ji from the Center for ProteoGenome Research in Korea University.

I'm using SureQuant Method but I want to customize it.

Let me explain about how I want to customize it first.

First, the SIL peptides are scanned with 7,500 resolution

Once the Quant Mode is triggered, the SIL peptides are scanned one more time but this time with 60,000 resolution.

I already gave it a try this way, and when I opened the raw file on Skyline, the profile looked like the image I attached.

So I want to know if I can give a filter with resolution so only scans with 60,000 resolution can be used for drawing profiles.

I tried to use the MS/MS filtering in Transition Settings but I don't think it filtered scans with 7,500 resolution.

Could you help me please?

Best regards, Minyeong Ji

 
 
Nick Shulman responded:  2021-06-06

Can you send us your Skyline document and one of your raw files? I can help you figure out the easiest way to get past this problem.

In Skyline, you can use the menu item:
File > Share
to create a .zip file containing your Skyline document and supporting files including extracted chromatograms.

You can upload that .zip file, and one of your .raw files here:
https://skyline.ms/files.url

The usual reason that chromatograms look jagged like that is that they are including two different types of MS2 scans.

This can happen with SureQuant methods when a heavy precursor has a m/z which is very close to a light precursor belonging to a different peptide.
Skyline decides which MS2 spectra should be used for which precursors based on the "MS/MS filtering Acquisition Method" and "Isolation Scheme" settings at:
Settings > Transition Settings > Full Scan

Sometimes, it is possible to customize the isolation scheme so that Skyline never gets confused about whether a particular MS2 spectrum belongs to a particular heavy or a different light precursor.

However, if your SureQuant method is targeting a large number of peptides, there will always be some cases where you have two peptides whose m/z's are so close to each other that there is no way to use the Isolation Scheme to tell Skyline how to distinguish them.

In these cases, there is a different way to tell Skyline which spectrum goes with which peptide. Your mass spectrometer method needs to add a "Scan Description" property to each spectrum that will tell Skyline which peptide the spectrum was for. The rules for exactly what that "Scan Description" property need to look like are complicated, and I am not sure whether you need to know what those rules are, or whether that has already been taken care of in the instrument method that you got from Thermo.

In case, you need to know what the rules are for what the Scan Description is supposed to be, those rules are:
The Scan Description property needs to start with either "SQ_ENDO_" (for light peptides), or "SQ_IS_" (for heavy peptides). After that, it should have either "K_" or "R_" depending on which amino acid is labeled, followed by the mass difference of the label. Then, it ends with the charge state of the precursor.
Hear are some example Scan Description property values.
SQ_IS_R+10_2
SQ_ENDO_K+8_2

Skyline only pays attention to the Scan Description property if "Triggered Acquisition" is checked at "Settings > Transition Settings > Instrument".

Anyway, please send us your Skyline document and one of your raw mass spectrometry data files and we can help you find the best way to fix this problem.
-- Nick

 
Nick Shulman responded:  2021-06-07
Minyeong Ji,

Thank you for uploading your file "2D_SureQuant_MinyeongJi.zip"

That file contains "2D_PRM_SureQuant_PDAC263_10ug_2X_pepmix_120min_FN05_C1_060421.raw" which is good.

Unfortunately, the other file that is in there is "2D_PRM_PDAC263_SureQuant_10ug_2X_pepmix_120min_060421.skyd", which is not the correct file to send.

Can you send me the ".sky.zip" file that you get when you do "File > Share" in Skyline?

-- Nick
 
minyg98 responded:  2021-06-07
I uploaded my file again

Please check on it

- Minyeong
 
Nick Shulman responded:  2021-06-07
Minyeong,

Thank you for uploading your .sky.zip file.

The recommended settings for SureQuant are that you go to:
Settings > Transition Settings > Full Scan
and change "MS/MS filtering Acquisition Method" to "DIA".

Then, under "Isolation scheme", choose "Add" and set it like in the attached picture "IsolationScheme.png".

After you change those settings, you should reimport your chromatograms by going to "Edit > Manage Results > Reimport".

This will improve things a little bit, but you will still have problems with some (many) of your peptides.

In the attached picture, "ProblematicPeptide.png", Skyline is still using two different types of MS2 spectra for the chromatogram for the heavy precursor "ILNPLLDR++" (m/z 480.3026).

I am not sure what other peptide those spectra might be intended for. There is no other precursor in your Skyline document which has a precursor m/z close to 480.30.

Some of the spectra in the chromatogram have the Scan Description set to "PDAC_SIL_re_+2" and others have the Scan Description set to "PDAC_R+2".
Skyline ignores the scan descriptions for these spectra since they do not start with "SQ_", but they might give you some clue as to what the mass spectrometer were looking for.

One thing that you could do is change your mass spectrometry method so that it is not collecting MS2 scans for precursors that are not in your Skyline document.
The other thing that you could do is to make it so that your mass spectrometer sets the Scan Description to values that Skyline understands. I am not sure how you do that in the Thermo Method Editor. If you need help with doing that, I might be able to ask someone from Thermo to provide more info about how to do that.
-- Nick
 
minyg98 responded:  2021-06-08
Nick,

Thank you for your help!!

I solved the problem thanks to you.

By the way, I have more questions.

The first thing is if the setting "MS/MS filtering Acquisition Method" should be always "DIA" when I'm using the SureQuant method.

The next question is if it is essential to make the scan descriptions start with "SQ_".

Also, is there any instruction or a manual telling about above information?


- Minyeong
 
Nick Shulman responded:  2021-06-08
Yes, you should set the MS/MS filtering Acquisition Method to "DIA".

When the acquisition method is "Targeted", a particular MS2 spectrum will only contribute to the chromatogram for the one peptide in your Skyline document whose precursor m/z is closest to the m/z that the mass spectrometer isolated for that spectrum. In a SureQuant acquisition, that precursor m/z is based on the peak that was observed in the MS1 scan, and will vary by a small amount around the expected m/z for that peptide.
When the acquisition method is "DIA" the MS2 spectrum will contribute a point to all of the peptides in your document whose precursor m/z fall in the window specified by the Isolation Scheme. You are supposed to create an isolation scheme with a fixed window size of 0.007 because that is how much the isolation m/z reported by the mass spectrometer might vary from the m/z of the peptide that the spectrum was targeting.

Your Scan Descriptions only need to start with "SQ_" if you need Skyline to do the smart filtering where Skyline only uses the spectrum for the precursor that it was intended for. Your SureQuant acquisition method has a list of m/z's that it is telling the mass spectrometer to look for. If there are two m/z's in that list that are really close to each other (i.e. the difference between them is less than 0.007, the fixed window size that you have specified in your Isolation Scheme in your Skyline full scan transition settings), then you would need to make sure that your Scan Descriptions start with "SQ_" and have the exact format that Skyline is expecting.

Using the Scan Description in this way is very tricky, especially because if your scan description does start with "SQ_" but is not exactly what Skyline is expecting, Skyline will not tell you about it: Skyline will simply skip over the spectrum.

There is currently no place that has this information, but I will try to update the PowerPoint on the Triggered Acquisition tips page so that includes the things that I am telling you now:
https://skyline.ms/wiki/home/software/Skyline/page.view?name=TriggeredAcquisition

-- Nick
 
minyg98 responded:  2021-06-08
Thank you for answering my questions.

I was lost and I didn't know to fix the problem, but now I got a clue.

You're a lifesaver!!

I hope you have a nice day :)

- Minyeong