optimization for small molecule

support
optimization for small molecule carlos penno  2021-06-03
 

Dear all,

I am exploring the software for small molecule work.

During the CE optmization I noticed the following issues

When I export transition list in csv value the precursor name is changed to something like Oxylipin.15-KETE.[M-]Ion [112_999451_112_999451][M-].CE_-17.0.light.

Another problem is that when I try to export a method the DP values are changing and therefore the data collect cannot be re imported in the software?

Why I am experience these and how can I solve it?

Thank you very much, Carlos.

 
 
carlos penno responded:  2021-06-03

another problem when I export transition list

you document does not contain compensation voltage results, but compesation votlages is set under transition settigs. are you sure you want to continue this?

I am using the latest version 2.1 and sciex 6500 instrument

thanks for the support

 
Nick Shulman responded:  2021-06-03
Carlos,

Can you send us your Skyline document?

In Skyline you can use the menu item:
File > Share
to create a .zip file containing your Skyline document and supporting files including extracted chromatograms.

If that .zip file is less than 50MB you can attach it to this support request.
Otherwise, you can upload it here:
https://skyline.ms/files.url

Is the precursor name causing a problem for you? I am not sure exactly how Skyline decides what to put in that column, but my understanding was that the mass spectrometer would ignore whatever Skyline puts in that column.

-- Nick
 
carlos penno responded:  2021-06-04
Hi Nick,

Please see attached.

I was trying to follow the tutorial on CE optimization for small molecule. I was not success in doing it.

The issues I have found:
-when export method to analyst, DP (volts) are not correctly copied. Some happens when: export transition list.
-when export transition list the precursor name is changed from example:
15(S)-HETE -> Oxylipin.15-KETE.[M-]Ion [112_999451_112_999451][M-].CE_-17.0.light.
-failure to execute ce optimization workflow.

I am using Sciex 6500+ and analyst 1.7.

if you can help to make this work it would be great as I do like using skyline.

Best, Carlos.
 
Kaipo responded:  2021-06-04
Hi Carlos,

For the compensation voltage warning, this is because the document has SCIEX selected for compensation voltage under Settings > Transition Settings > Prediction. You can set it to "None" if you don't want to see the warning.
When exporting the transition list, the csv output contains the DP in the 5th column. Can you provide a screenshot of what happens when you copy it to Analyst and what you would expect instead?
The precursor name is just an ID generated by Skyline and shouldn't affect the method - is it causing problems?
Also, can you clarify what you mean by failure to execute CE optimization workflow?

Thanks,
Kaipo
 
carlos penno responded:  2021-06-04
Hi Kaipo, thanks

When exporting the transition list, the csv output contains the DP in the 5th column. Can you provide a screenshot of what happens when you copy it to Analyst and what you would expect instead? that is correct and I have -80 everywhere even though the data has been collected with other settings. Why do I have -80 everywhere in this column?

The precursor name is just an ID generated by Skyline and shouldn't affect the method - is it causing problems?
The problem is lack of consistency. The first transition list I loaded to skyline has for example a precursor name of for example 15(S)-HETE. If I am optimizing the method and need to export a new transition list why skyline does not keep the same nomenclature and why is changing to Oxylipin.15-KETE.[M-]Ion [112_999451_112_999451][M-].CE_-17.0.light?

can you clarify what you mean by failure to execute CE optimization workflow?
I follow all the steps in the tutorial, and after doing all manual work to correct the precursor name and the wrong DP values and even I did of this I did not manage to get the visualization (split transition) to identify which CE was best.

I can also connect via team to discuss this problem if you want.

Best regards, Carlos
 
Brendan MacLean responded:  2021-06-04
The precursor name is in a format requested by SCIEX for targeted proteomics where it helps support their tools like MultiQuant and Analyst. The proteomics format is expected to be:

<protein-name>.<modifiied-peptide-sequence>.<transition-name>.<opt-value-text>.<label-type>

And you see:

molecule-group = 15(S)-HETE -> Oxylipin
molecule = 15-KETE
transition-name = [M-]Ion [112_999451_112_999451][M-]
opt-value-text = CE_-17.0
label-type = light

I don't love that they are using a decimal value with a period for "opt-value-text" in a text encoding format where periods are used as separators. You can see that the decimal periods get replaced with underscores (_) in the "transition-name" field. I hope that you can now look at your Skyline document with these values in mind and understand where they come from, and why you end up with the text you have reported.
 
Brendan MacLean responded:  2021-06-04
Hi Carlos,
Oops. I slightly misunderstood your description:

15(S)-HETE -> Oxylipin.15-KETE.[M-]Ion [112_999451_112_999451][M-].CE_-17.0.light

Now, I see that you were hoping to have that text in your transition list be only your "molecule-name", in this case "15(S)-HETE", but feeling that Skyline had given you the text after " -> ", which isn't quite correct, because Skyline wouldn't transform "15(S)-HETE" to "15-KETE". So, you are note quite doing a one-to-one comparison.

When I downloaded your file and exported a transition list (without optimization) from it (after setting CoV prediction to "None" as Kaipo suggested), I got the following SCIEX encoded precursor names:

Oxylipin.15(S)-HETE.[M-]Ion [174_999451_174_999451][M-].light
Oxylipin.11(S)-HETE.[M-]Ion [166_999451_166_999451][M-].light
Oxylipin.15-KETE.[M-]Ion [112_999451_112_999451][M-].light
Oxylipin.8(S)-HETE.[M-]Ion [154_999451_154_999451][M-].light
Oxylipin.12(S)-HETE.[M-]Ion [134_999451_134_999451][M-].light
Oxylipin.9R-HETE.[M-]Ion [122_999451_122_999451][M-].light
Oxylipin.5(S)-HETE.[M-]Ion [114_999451_114_999451][M-].light
Oxylipin.12-KETE.[M-]Ion [152_999451_152_999451][M-].light
Oxylipin.5-KETE.[M-]Ion [202_999451_202_999451][M-].light

So, you can see that the first line has the "15(S)-HETE" that you are looking for, it is just surrounded by other values which are separated from eachother by periods.

I hope you can combine this with my earlier response to make sense of how Skyline is constructing these complex names from the values you are providing. This is how our SCIEX collaborators suggested to compose these names to work best with their software, ast least for quantifying peptides. It may be that our attempt to translate that to small molecules is less useful.

Thanks for posting your questions, and for clarifying what you are asking.

--Brendan
 
Brendan MacLean responded:  2021-06-04
And now I think I see the confusion: The names above I got from exporting a transition list for SCIEX did not use the "Order by m/z" checkbox, which SCIEX would recommend you use, because it optimizes the quadrupole switching. However, it may also have lead you to mistakenly expect to see the first precursor in your list at the top of your transition list, but it actually moves 15-KETE to the top with its 112.999451 m/z, giving you the impression that Skyline changed:

15(S)-HETE -> Oxylipin.15-KETE...

When actually 15(S)-HETE can still be found lower down (line 4) in the now ordered list:

Oxylipin.15-KETE.[M-]Ion [112_999451_112_999451][M-].light
Oxylipin.12-KETE.[M-]Ion [152_999451_152_999451][M-].light
Oxylipin.5-KETE.[M-]Ion [202_999451_202_999451][M-].light
Oxylipin.15(S)-HETE.[M-]Ion [174_999451_174_999451][M-].light
Oxylipin.11(S)-HETE.[M-]Ion [166_999451_166_999451][M-].light
Oxylipin.8(S)-HETE.[M-]Ion [154_999451_154_999451][M-].light
Oxylipin.12(S)-HETE.[M-]Ion [134_999451_134_999451][M-].light
Oxylipin.9R-HETE.[M-]Ion [122_999451_122_999451][M-].light
Oxylipin.5(S)-HETE.[M-]Ion [114_999451_114_999451][M-].light
 
carlos penno responded:  2021-06-04
Hi Brendan, Kaipo

My bad confusing 15(S)-HETE to 15-KETE.

I imported this in skyline as quantitation method (insert-transition list)
Oxylipin    15-KETE    light    317    -1    113    -1    20    25
Oxylipin    12-KETE    light    317    -1    153    -1    50    23
Oxylipin    5-KETE    light    317    -1    203    -1    60    22
Oxylipin    15(S)-HETE    light    319    -1    175    -1    40    19
Oxylipin    15(S)-HETE    light    319    -1    219    -1    60    16
Oxylipin    11(S)-HETE    light    319    -1    167    -1    40    23
Oxylipin    8(S)-HETE    light    319    -1    155    -1    40    19
Oxylipin    12(S)-HETE    light    319    -1    135    -1    50    19
Oxylipin    9R-HETE    light    319    -1    123    -1    40    20
Oxylipin    5(S)-HETE    light    319    -1    115    -1    40    20

When I do export transition list this I what I got back
317    113    20    Oxylipin.15-KETE.[M-]Ion [112_999451_112_999451][M-].light    -80    -25
317    153    20    Oxylipin.12-KETE.[M-]Ion [152_999451_152_999451][M-].light    -80    -23
317    203    20    Oxylipin.5-KETE.[M-]Ion [202_999451_202_999451][M-].light    -80    -22
319    219    20    Oxylipin.15(S)-HETE.[M-]Ion [218_999451_218_999451][M-].light    -80    -16
319    175    20    Oxylipin.15(S)-HETE.[M-]Ion [174_999451_174_999451][M-].light    -80    -19
319    167    20    Oxylipin.11(S)-HETE.[M-]Ion [166_999451_166_999451][M-].light    -80    -23
319    155    20    Oxylipin.8(S)-HETE.[M-]Ion [154_999451_154_999451][M-].light    -80    -19
319    135    20    Oxylipin.12(S)-HETE.[M-]Ion [134_999451_134_999451][M-].light    -80    -19
319    123    20    Oxylipin.9R-HETE.[M-]Ion [122_999451_122_999451][M-].light    -80    -20
319    115    20    Oxylipin.5(S)-HETE.[M-]Ion [114_999451_114_999451][M-].light    -80    -20

it seems to me the DP is not correctly copied. -80 everywhere?
Is it possible to get an identical export transition list to the first one inserted?

Thank you again for the support, Carlos.
 
Brendan MacLean responded:  2021-06-04
Though, it is actually ordering by the precursor m/z and then the product m/z, and you can't see the precursor m/z in the names which are all 317 for KETE and 319 for HETE.

This seems to indicate a bug in Kaipo's ordering code, in that it is not correctly handling multiple precursors with exactly the same precursor m/z. It appears to be achieving the ordering:

<precursor m/z>,<precursor document position>,<product m/z>

Instead of more strictly:

<precrusor m/z>,<product m/z>

I also don't totally understand the transition-name format that is producing the text like "[M-]Ion [112_999451_112_999451][M-]". I will have to ask Brian Pratt about that.
 
Brendan MacLean responded:  2021-06-04
You DP values need to end up in the "Explicit Declustering Potential" field when you add your transition list. If you used Edit > Insert > Transition List, then you can choose this field by clicking the "Columns..." button and checking its checkbox. It is the last field listed, but once you add it, you can rearrange the fields to any order you desire and then paste into the grid.

Alternatively, if you used Edit > Paste or File > Import > Transition List, then you need to make sure you use the correct name in the column headers. We will be working on implementing a column picker for small molecules as we did for peptides in the Skyline 21.1 release, but until then, these are your options.

You can also populate this field for existing transitions by doing the following:
- View > Document Grid
- Reports > Small Molecule Transition List from the Document Grid: Reports menu.
- Reports > Edit Report
- Click the binoculars (Find) button and search for "Declustering" until you find "Explicit Declustering Potential"
- Check the "Explicit Declustering Potential" field.
- OK

You should see the field added to the end of the report and it should be possible to type or paste into it. If your original adding of your transition list worked correctly, then the field should already be populated as you expected... In which case, the fact that you always get -80 is a bug and we will fix it.

Give some of this a try, and let us know how it goes.

Thanks for your persistence.

--Brendan