File Not Reopening After Saving and Exiting the Program

support
File Not Reopening After Saving and Exiting the Program kaitlyn b donohoo  2021-05-28
 

Hello,

I'm having an issue where my file does not open once I have saved and closed out of the program. It keeps popping up with a window stating "The file contains an error at line 114 column 9". I have tried remaking the file with the same transition list only to see the problem occur a second time. I will be uploading both the file and the transition list (in excel format) under the file name KBD_RiboB. I believe the issue must be in the transition list but I used the same format for other samples (not the exact same list but the molecule name, adduct names, and adducts are the same as in other lists) and had no issue.

 
 
Nick Shulman responded:  2021-05-28
Can you send us the file "Ribo B Standards.sky"?
The file that you sent us was "Ribo B Standards.skyd". The .skyd file contains extracted chromatograms, which is not the file that you are having trouble with. The ".sky" file is the one that we need to see.

After you send us your .sky file, we will probably be able to fix it for you.
-- Nick
 
kaitlyn b donohoo responded:  2021-05-28
This should include the .sky file. I'm having a hard time seeing the file type on my computer at the moment.
 
Nick Shulman responded:  2021-05-28
This time you included the .sky.view file, but still no .sky file.

You might have an easier time if you tell Windows Explorer to show you the filename extensions.
The way to do that is:
View > Options
and then in the Options dialog, on the "View" tab of the "Folder Options" dialog, uncheck the checkbox that says "Hide extensions for known file types"

-- Nick
 
kaitlyn b donohoo responded:  2021-05-28
Thank you. Here is the .sky file
 
Nick Shulman responded:  2021-05-28
That file is too small to be the one that caused the error. (It does not have a line 114).

Do you have a different .sky file that you could send me? I don't think that was the file that you were trying to open in Skyline when you got this error.
-- Nick
 
kaitlyn b donohoo responded:  2021-05-28
Try this one. When I open it it claims an error at line 69.
 
Brendan MacLean responded:  2021-05-28
Also, it would be best to just ZIP together all of the files you have provided in previous posts (.sky, .sky.view, .skyd) This is what File > Share would do for you, if you could get the file open. If you can reproduce the error, you might consider using File > Share before you close the file, when you are sure you have saved a file that you won't be able to open.
 
kaitlyn b donohoo responded:  2021-05-28
Alright. I have made a new file and shared it before exiting. After exiting it will not open.
 
kaitlyn b donohoo responded:  2021-05-28
These are the other two that do not open. I used the share function on them
 
Brian Pratt responded:  2021-05-28
Thanks for the files.

There is certainly something strange here - the document has precursor transitions that claim a different adduct than the precursor itself, which should not be possible.

Might I see the transition list you used to build the Skyline document?

Thanks,

Brian Pratt
 
kaitlyn b donohoo responded:  2021-05-28
So this file has three transition lists on it. The Fetuin and Ribo B lists seem to cause the arror as those are the ones that will not open after exiting the program. The HBS transition list does not cause this issue. It seems strange as the Ribo B list is actually copied into the others.
 
Brian Pratt responded:  2021-05-28
Excellent, this is exactly what I need to sort out what's going on.
 
Brian Pratt responded:  2021-05-28
There appears to be a problem with Skyline's initial selection of transitions when reading your transition list. You'll notice that the precursor adduct descriptions reflect the masses of the various tags, but the generated transitions in the Targets tree all just claim a simple [M+H] even when the precursor is labeled, which is nonsensical. I need to figure out why that's happening, but a workaround for you is to just go into Transition Settings and make a change that provokes reevaluation of those transitions. For example, go to Transition Settings filter tab and change "Ion Types" from "f" to "p".

Side note: I noticed is that the first two lines of the Rbo B list seem inconsistent. If the formula of Oligomannose is C58H98N2O46, then the monoisotopic mass of Oligomannose + CH3 would be 1573.563, and the m/z of a protonated ion would be 1574.570. That m/z is given as 1572.8248 in your list. If we accept that value then the unprotonated mass is something like 1571.824, and the m/z for a doubly protonated ion should be 786.9128 but your list gives it as 787.4203 . This isn't the actual problem that Skyline is dealing with, but I thought it worth mentioning since they appear to be intended to be two different ionizations of the same mass.
.